The latest update addressed the crashing issue that some of you have been experiencing, Click here to found out more!
November 20 - Everyone ready for the Friday Highlight? It's ready for you here.
You are browsing an archived read-only section of the forums. The Sims 4 Help Center can now be found here.

Issues with Mods and CC in The Sims 4 on Mac

Comments

  • devonnedevonne Posts: 5 New Member
    So i deleted some of the cc and it's working now but now I'm having that issue with blue, glitchy hair
  • xxLeilaaxxLeilaa Posts: 57 Member
    I really really do hope that EA will fix issue 3 asap. I love to download CC and I can entertain myself for hours with just downloading...
    Read that there is a patch coming up in March, really hope they will fix it then!
  • gracesimslover22gracesimslover22 Posts: 2 New Member
    I can't find my Sims 4 folder! I downloaded my game on Orgin, and I do have the Sims 3 installed so I already have my Electronic Arts folder, however there is no folder that has the Sims 4 set up stuff! I'm really upset because I wanted custom content in my games but I've even restarted my computer and there is still no Sims 4 folder :( does anyone know how to find it?
  • Ottie24Ottie24 Posts: 47 Member
    > @gracesimslover22 said:
    > I can't find my Sims 4 folder! I downloaded my game on Orgin, and I do have the Sims 3 installed so I already have my Electronic Arts folder, however there is no folder that has the Sims 4 set up stuff! I'm really upset because I wanted custom content in my games but I've even restarted my computer and there is still no Sims 4 folder :( does anyone know how to find it?

    Have you booted up the game yet? There won't be a folder for the sims 4 until you boot up the game.
  • yelly201yelly201 Posts: 79 Member
    hawkwhy wrote: »
    I played on Windows for a while before the Mac version came out and I switched back to my native operating system. I didn't copy my CC folder over from my old game, just redownloaded new CC. Everything's running pretty much smoothly (nothing I can't troubleshoot by myself), except for one thing - the gallery. If I save a sim that has CC to my personal gallery, it won't show up at all, much less if I try to upload it to the gallery. If I remove the CC from my game, I can save sims to the gallery. If I go to my profile in-game, it says I have "4 creations", but I can only see one. Basically it's just not working at all. Any tips?

    (I feel like this makes no sense, I'll try to clarify if you're confused.)

    I don't know if you were able to find the solution to this, but I had the same problem. You have to enable "View with CC" option in the advanced section of the gallery, even if you're viewing your own content.

    2Qf5pkp.gif


    As you can see, when the CC box is checked I can now view additional content in My Library.

    Hope this helps!
  • Tremayne4260Tremayne4260 Posts: 3,123 Member
    This also includes Outdoor Life and the Holiday Pack which are EA made "CC".
    Second Star to the Right and Straight on 'til Morning.
  • yelly201yelly201 Posts: 79 Member
    I just had to comment and say thank you to @SimGuruModSquad because the temp solution to issue 3 is amazing and I can finally add all the CC I want! Just an FYI for those looking to use it, the code should read (in all lowercase):
    sudo launchctL limit maxfiles unlimited
    

    at first, I thought the "L" at the end of launchctl was instead the number 1, but I had to double check. And I'm glad I did, because apparently really bad things can happen when you type incorrect code into the terminal after the "sudo" command. Just thought I'd share the lesson with those who might need it!
  • BluebellFloraBluebellFlora Posts: 7,089 Member
    yelly201 wrote: »
    because apparently really bad things can happen when you type incorrect code into the terminal after the "sudo" command. Just thought I'd share the lesson with those who might need it!

    Yes they can but only if the OS recognises the command. When someone gives you a command to put into Terminal, and they are a trusted source as in this case, you should really just copy and paste it without typing it yourself :)
    apple-signature.png
  • yelly201yelly201 Posts: 79 Member
    yelly201 wrote: »
    because apparently really bad things can happen when you type incorrect code into the terminal after the "sudo" command. Just thought I'd share the lesson with those who might need it!

    Yes they can but only if the OS recognises the command. When someone gives you a command to put into Terminal, and they are a trusted source as in this case, you should really just copy and paste it without typing it yourself :)

    Ah, I didn't realize copy/paste was an option in terminal, I've always typed things out by hand... guess I'm old school like that. I will be doing that for every future instance where I have to enter the code though -- thanks for the heads up!
  • BluebellFloraBluebellFlora Posts: 7,089 Member
    yelly201 wrote: »
    yelly201 wrote: »
    because apparently really bad things can happen when you type incorrect code into the terminal after the "sudo" command. Just thought I'd share the lesson with those who might need it!

    Yes they can but only if the OS recognises the command. When someone gives you a command to put into Terminal, and they are a trusted source as in this case, you should really just copy and paste it without typing it yourself :)

    Ah, I didn't realize copy/paste was an option in terminal, I've always typed things out by hand... guess I'm old school like that. I will be doing that for every future instance where I have to enter the code though -- thanks for the heads up!

    No problem. Terminal isn't to be messed with :D
    apple-signature.png
  • lilmiszceelilmiszcee Posts: 47 Member
    Can anyone tell me why cc clothing makes my sims appear with shiny patches all over?
  • BluebellFloraBluebellFlora Posts: 7,089 Member
    lilmiszcee wrote: »
    Can anyone tell me why cc clothing makes my sims appear with shiny patches all over?

    http://forums.thesims.com/en_US/discussion/comment/13356347/#Comment_13356347
    apple-signature.png
  • lilmiszceelilmiszcee Posts: 47 Member
    @BluebellFlora
    No that's not it. It looks different from that. And I don't have Intel HD 4000 graphics either.
  • BluebellFloraBluebellFlora Posts: 7,089 Member
    lilmiszcee wrote: »
    @BluebellFlora
    No that's not it. It looks different from that. And I don't have Intel HD 4000 graphics either.

    What graphics do you have? Can you post a link to a picture?

    apple-signature.png
  • yelly201yelly201 Posts: 79 Member
    edited March 2015
    @lilmiszcee

    Is this the issue? I had the same thing happen to me. No fix as of yet.

    http://forums.thesims.com/en_US/discussion/817891/shiny-sims-texture-bug#latest
  • lilmiszceelilmiszcee Posts: 47 Member
    @BluebellFlora
    Unfortunately I can't post a link or picture because I'm a "new" member. But yes! It seems to be the same problem as @yelly201.
  • BluebellFloraBluebellFlora Posts: 7,089 Member
    lilmiszcee wrote: »
    @BluebellFlora
    Unfortunately I can't post a link or picture because I'm a "new" member. But yes! It seems to be the same problem as @yelly201.

    This is such a ridiculous situation that people can't post pictures showing problems they're having. Well done EA.

    What graphics do you have and what operating system are you using? Apple icon > About This Mac



    apple-signature.png
  • magfishmagfish Posts: 1 New Member
    Heads up to everyone. I was encountering issue 3 but even after the terminal workaround was still unable to open the game.

    I'd read that its fine to put your package files in folders and had it all nicely organized. Turns out the most I can have is one folder, no more or the whole game won't open. Noticed someone mentioning something like this but I thought I would clarify. Do not use more than one folder-level in the Mode folder. (ex I can have Mods -> Tulton -> .pkg files, but not Mods -> Bathroom lsn-> Tulton -> .pkg files.
  • lilmiszceelilmiszcee Posts: 47 Member
    @BluebellFlora
    Macbook Pro Mid 2010
    OS X Yosemite Version 10.10.2
    Processor 2.4 GHz Intel Core Duo
    Memory 8 GB 1067 MHz DDR3
    Graphics NVIDIA Geforce 320M 256 MB
  • yelly201yelly201 Posts: 79 Member
    edited March 2015
    @magfish that's good to know!!
  • BluebellFloraBluebellFlora Posts: 7,089 Member
    yelly201 wrote: »
    @lilmiszcee this is the issue you're having with shiny sims, right?

    3kNtM0u.png

    Oh wow, they look coated in plastic! Have you figured out what CC is causing it yet?
    apple-signature.png
  • SgarciaSgarcia Posts: 1 New Member
    when i go to create a sim the clothes and hair are all pixel cant see any color its just beige and pixel
  • TeddybearhoneybeeTeddybearhoneybee Posts: 13 New Member
    > @lilmiszcee said:
    > BluebellFlora
    > Unfortunately I can't post a link or picture because I'm a "new" member. But yes! It seems to be the same problem as yelly201.

    I had the same problem. Do you have post processing effects on? I turned that off, restarted the game and it went back to normal. Another time, I went into CAS and changed the hair a few times and went back to the original hair , and it went back to normal out of CAS.
  • lilmiszceelilmiszcee Posts: 47 Member
    @BluebellFlora
    I can't use any cc except hair. The hair works fine.
    @Teddybearhoneybee
    I don't have that on no. And I've tried to change stuff around. Still have the same problem so I just don't use the cc anymore.
  • BluebellFloraBluebellFlora Posts: 7,089 Member
    edited March 2015
    @lilmiszcee - I thought this was a CC issue as you've posted in the CC/mods thread? What happens when you move your Sims 4 folder out onto the desktop and play a completely new game without any CC or previous saves? Does your Sim still 'glow'?

    Judging by what @Teddybearhoneybee has said about hair, maybe the hair is the issue? It would help the community if you listed the CC hair you've installed.
    apple-signature.png
Sign In or Register to comment.
Return to top