September 20 - Friday Highlight is here! Check it out!
September 17 - We just released a small patch for The Sims 4 on PC/Mac - click here for more details.

Please help - mod won't show up in game!

12345679...Next

Comments

  • rosemowrosemow Posts: 148,513 Member
    edited April 2018
    hondagirl wrote: »
    Hello I was wondering if any one can help i am trying to install the nyx mermaid mod and i downloaded it and used winrar to open it then i copied it into my mod folder. I had already enabled mod then i enabled script just to be safe and closed the app. But when I opened the app back up the mod wasn't even showing up in that show content thing in the game options i have deleted it and I downloaded it again to see if that was the problem but it still wont show up any suggestions would be helpful thanks very much

    Hello @hondagirl
    When you extracted the files using winrar, did you put them directly into the mods folder, without them being in a sub folder? If you didn’t, try doing that and see if the mod then appears.
  • hondagirlhondagirl Posts: 4 New Member
    Yes I had put them directly into the mods folder thank you
  • rosemowrosemow Posts: 148,513 Member
    hondagirl wrote: »
    Yes I had put them directly into the mods folder thank you
    Try moving your whole mods folder to the desktop. Launch the game, and a new mods folder will be generated in the sims 4 folder.. Exit the game. Then put your mods/cc from the old mods folder into the newly generated mods folder and test to see if the mod appears then.
    This is also to test to make sure that a new mods folder is being generated, and that the game is using the correct mods folder.
  • hondagirlhondagirl Posts: 4 New Member
    I moved the mods folder but a new one is not being generated should I create a new mods folder?
  • rosemowrosemow Posts: 148,513 Member
    hondagirl wrote: »
    I moved the mods folder but a new one is not being generated should I create a new mods folder?

    Do you use One Drive? If you do it could be causing this issue, Try seeing if there is a mods folder in One Drive . The game may be using that mods folder instead of the one in Documents -Electronic Arts -sims 4 folder . One Drive can cause issues, It would be best to unsync One Drive and Sims 4.

    If you don’t use One Drive, try using the search bar on your computer , and search to see if there may be another mods folder on your computer that the game is using instead of the one directly in the sims 4 folder.
  • hondagirlhondagirl Posts: 4 New Member
    My EA folder was in my One Drive documents so I moved it to my desktop documents and their showing up now Thank you very much You were a great help.
  • rosemowrosemow Posts: 148,513 Member
    hondagirl wrote: »
    My EA folder was in my One Drive documents so I moved it to my desktop documents and their showing up now Thank you very much You were a great help.

    You’re welcome :)
  • tarmbrustarmbrus Posts: 2 New Member
    hey, ok so i feel like at this point i've tried everything, So i've been playing the sims for about 8 years and have never had a problem like this so i have got my mods in the mod folder as well as those that were in zips out of zips etc. Also yes i have my allow 'custom content' and 'script mods' on but the problem is the the game is not recognising that they are their which is really confusing i've tried repairing the game, updating the game, un-adding the a re-adding the cc, contacting EA, going on youtube and then i've already tried un-installing and re-installing the game i've done that twice. i've read through the comments for people that have had the same problem and using the answer that helped them to help me but it did not work. At this point i'm starting to think that i should give up but CC and Mods really change the way i play the game , any help would be so dearly appreciated :).
  • rosemowrosemow Posts: 148,513 Member
    tarmbrus wrote: »
    hey, ok so i feel like at this point i've tried everything, So i've been playing the sims for about 8 years and have never had a problem like this so i have got my mods in the mod folder as well as those that were in zips out of zips etc. Also yes i have my allow 'custom content' and 'script mods' on but the problem is the the game is not recognising that they are their which is really confusing i've tried repairing the game, updating the game, un-adding the a re-adding the cc, contacting EA, going on youtube and then i've already tried un-installing and re-installing the game i've done that twice. i've read through the comments for people that have had the same problem and using the answer that helped them to help me but it did not work. At this point i'm starting to think that i should give up but CC and Mods really change the way i play the game , any help would be so dearly appreciated :).

    Hello @tarmbrus
    Do you use One Drive? If you do it could be causing this issue, Try seeing if there is a mods folder in One Drive . The game may be using that mods folder instead of the one in Documents -Electronic Arts -sims 4 folder . One Drive can cause issues,

    If you don’t use One Drive, try using the search bar on your computer , and search to see if there may be another mods folder on your computer that the game is using instead of the one directly in the sims 4 folder.
  • tarmbrustarmbrus Posts: 2 New Member
    > @rosemow said:
    > tarmbrus wrote: »
    >
    > hey, ok so i feel like at this point i've tried everything, So i've been playing the sims for about 8 years and have never had a problem like this so i have got my mods in the mod folder as well as those that were in zips out of zips etc. Also yes i have my allow 'custom content' and 'script mods' on but the problem is the the game is not recognising that they are their which is really confusing i've tried repairing the game, updating the game, un-adding the a re-adding the cc, contacting EA, going on youtube and then i've already tried un-installing and re-installing the game i've done that twice. i've read through the comments for people that have had the same problem and using the answer that helped them to help me but it did not work. At this point i'm starting to think that i should give up but CC and mods really change the way i play the game , any help would be so dearly appreciated :).
    -----------------------------------------------------------------------------------
    > Hello @tarmbrus
    > Do you use One Drive? If you do it could be causing this issue, Try seeing if there is a mods folder in One Drive . The game may be using that mods folder instead of the one in Documents -Electronic Arts -sims 4 folder . One Drive can cause issues,
    >
    > If you don’t use One Drive, try using the search bar on your computer , and search to see if there may be another mods folder on your computer that the game is using instead of the one directly in the sims 4 folder.
    -----------------------------------------------------------------------------------
    No i am for sure using the one thats in the sims 4 folder , Do you think that this is unusual i should just give up ?
    But thank you if your un-able to help.
  • rosemowrosemow Posts: 148,513 Member
    tarmbrus wrote: »
    > @rosemow said:
    > tarmbrus wrote: »
    >
    > hey, ok so i feel like at this point i've tried everything, So i've been playing the sims for about 8 years and have never had a problem like this so i have got my mods in the mod folder as well as those that were in zips out of zips etc. Also yes i have my allow 'custom content' and 'script mods' on but the problem is the the game is not recognising that they are their which is really confusing i've tried repairing the game, updating the game, un-adding the a re-adding the cc, contacting EA, going on youtube and then i've already tried un-installing and re-installing the game i've done that twice. i've read through the comments for people that have had the same problem and using the answer that helped them to help me but it did not work. At this point i'm starting to think that i should give up but CC and mods really change the way i play the game , any help would be so dearly appreciated :).
    > Hello @tarmbrus
    > Do you use One Drive? If you do it could be causing this issue, Try seeing if there is a mods folder in One Drive . The game may be using that mods folder instead of the one in Documents -Electronic Arts -sims 4 folder . One Drive can cause issues,
    >
    > If you don’t use One Drive, try using the search bar on your computer , and search to see if there may be another mods folder on your computer that the game is using instead of the one directly in the sims 4 folder.
    No i am for sure using the one thats in the sims 4 folder , Do you think that this is unusual i should just give up ?
    But thank you if your un-able to help.

    Hello
    Try moving your whole mods folder to the desktop. Launch the game, and a new mods folder will be generated in the sims 4 folder.. Exit the game. Then put your mods/cc from the old mods folder into the newly generated mods folder and test to see if the issues remain. Make sure that there is only one resource.cfg file in the folder
  • MCGCastMCGCast Posts: 2 New Member
    I had a same problem but with this the Improved Weather Variety for Worlds mod.
    I did the instructions but nothing happened. Is this broken?
  • rosemowrosemow Posts: 148,513 Member
    MCGCast wrote: »
    I had a same problem but with this the Improved Weather Variety for Worlds mod.
    I did the instructions but nothing happened. Is this broken?

    Hello @MCGCast
    The mod may be conflicting with another mod. Try seeing if the mod appears if there are no other mods in the mods folder.
  • MCGCastMCGCast Posts: 2 New Member
    @rosemow
    I checked. There was only one...
  • rosemowrosemow Posts: 148,513 Member
    edited October 2018
    MCGCast wrote: »
    @rosemow
    I checked. There was only one...

    Do you have any other mods/cc @MCGCast ? If you do, are they appearing or are they not?
  • samwisesamwise Posts: 4 New Member
    Hi! I hope this thread is still open... I just now got an account. I am having a similar problem to everyone else in this thread: I can't get CC to work. I'm running Sims 4 on my Windows 10 laptop. I've been trying to get CC to work for several months now and I'm getting really frustrated. I have tried every solution I can find (and asked my friends who have CC), but nothing works. I only have .package files, no subfolders, I've repaired my game through Origin, nothing is in OneDrive, and I've had the game regenerate the Mods folder several times. The CC just won't show up. I've used CC from different locations and it's definitely updated. Can you help me, please?
  • rosemowrosemow Posts: 148,513 Member
    samwise wrote: »
    Hi! I hope this thread is still open... I just now got an account. I am having a similar problem to everyone else in this thread: I can't get CC to work. I'm running Sims 4 on my Windows 10 laptop. I've been trying to get CC to work for several months now and I'm getting really frustrated. I have tried every solution I can find (and asked my friends who have CC), but nothing works. I only have .package files, no subfolders, I've repaired my game through Origin, nothing is in OneDrive, and I've had the game regenerate the Mods folder several times. The CC just won't show up. I've used CC from different locations and it's definitely updated. Can you help me, please?

    Hello @samwise
    Go to game options and check that the " enable custom content and mods" button is ticked, which is found in :
    Game Options | Other | Enable Custom Content and Mods. If it isn't ticked, do that.Also check that the script mods allowed button is ticked as well. Exit the game. Then go back into the game again and see if the cc appears then .
  • samwisesamwise Posts: 4 New Member
    Yes, it was ticked. I also tried un-checking it, restarting the game, checking it, and restarting the game again. It still won't show up. (Also, thank you for responding so quickly!)
  • rosemowrosemow Posts: 148,513 Member
    samwise wrote: »
    Yes, it was ticked. I also tried un-checking it, restarting the game, checking it, and restarting the game again. It still won't show up. (Also, thank you for responding so quickly!)

    I am sorry that you are having this issue :( Make sure that there is only one resource.cfg file in the mods folder.
  • samwisesamwise Posts: 4 New Member
    Thanks. It's certainly quite annoying. :/ There is only one resource.cfg file in my mods folder. I can't think of anything else that I can do to fix the issue.
  • rosemowrosemow Posts: 148,513 Member
    samwise wrote: »
    Thanks. It's certainly quite annoying. :/ There is only one resource.cfg file in my mods folder. I can't think of anything else that I can do to fix the issue.

    I am not sure what is the cause of the issue :( Although I don’t like suggesting it, and I am not sure if it will help, you could perhaps see if uninstalling and reinstalling the game may help. I don’t think that it will help, but it is an option.
  • samwisesamwise Posts: 4 New Member
    I'm not sure if I'm comfortable doing that if it won't definitely help. I suppose I'll just go CC-free until (if) I can figure it out. Thank you for trying to help, though! I really appreciate it. :smile:
  • Ciaran07Ciaran07 Posts: 1 New Member
    Hello, I'm trying to download cc and mods because i see everyone else do it and I wanted to try. I have followed instructions on how to download them,

    After downloading move them into documents, then Electronic Arts, Sims 4, then Mods

    Now when i try to play the game it doesn't appear in the main menu in settings even though i have enabled Custom Content and Mods and i did the other one, it doesn't appear in game either and i was wondering if someone could help
Sign In or Register to comment.
Return to top