April 19 - We just released a small patch for The Sims 4 on PC/Mac - click here for more details.
April 11 - Outdoor fun for a Stuff Pack? Take a look at our giveaway!

Supernatural Bug Thread

Comments

  • GanvalGanval Posts: 14 New Member
    edited January 2013
    i bought super natural from the steam sale and it's pretty good but there are a few bugs that i discovered.

    The Fortune teller career is broken.
    1.) Once my main character reached level 10 mystic track, all my family members started hating him for no reason.
    I did a test to see if level 10 was broken so I made him quit his job and now his all his relationships are back to normal.

    2.) The career uniforms are also buggy. Evey time I choose plan outfit and add an additional outfit in the career section, something on the default outfit. The default clothes either change colors or into a different style. Annoying but not game breaking.
    This is my characters second job, I am not sure if that has any effect with this bug.

    3) another bug that might be related to #2) At one point my sims wont go to work unless I order them to change to there career uniforms. My sims no longer change to the uniforms automatically.
    I solved this by deleting all the alternate career outfits.



    Please EA do something about this.
    Edit:
    1# might not be a glitch :
    http://www.carls-sims-3-guide.com/forum/index.php?topic=13209.0
    bug 2 and 3 needs to be fixed
  • ivinianivinian Posts: 1,957 Member
    edited January 2013
    Crinrict, I don't know if anybody else has mentioned this, but a few of us over at the Friendly Simmers thread were just talking about trouble we'd all had with the school lot in Moonlit Falls. I had trouble editing the lot (it edited fine, more to the point, but crashed to desktop on my PC whenever I tried to save the edited lot); others had trouble with Sim children attending class or going home properly after class. I did end up getting my lot edited, but dang if I can remember just what I did. It was not pretty, I'll just say that. I think I had to go get a new rabbithole from the bin to do it.
  • fortega83fortega83 Posts: 23 New Member
    edited February 2013
    Sooo... after uninstalling everything, reinstalling each expansion one by one, and after patching each one by one. I noticed my gardening glitch was FIXED.

    Before my sim would "jump" out of gardening when told to tend garden, and everything in the queue disappearing. Also, I noticed my gardening collection journal isn't blank anymore, as it was before the reinstall.

    I still have most of the common glitches, like sims spinning while walking through doorways, tv screen going black while playing videogames, etc.

    Crashing has also gone away after adding ts3w.exe and ts3.exe to the DEP list, and running the game as administrator.
  • christinebremnerchristinebremner Posts: 3,513 Member
    edited February 2013
    After the recent patch 1.48 my fairy has lost her magic in her bar, there are no seeds in her inventory to mess with it, and most of her magic backfires to the point if she uses hot head it backfires and sets her on fire and if she isnt near a shower or water, she dies. I have had to refrain from her magic, her auras wont go.

    It seems when they get to a level of magic this happens, and its only happened since the last update 1.48. It's actually annoying, and is interfering with my game as her fairy powers are not right. I thought it was the new game i started, but it's not, it's also in my game that's in it's second generation.

    If anyone has this problem with their fairy's and has a fix, could you please let me in on it? Because I don't like using cheats or mods, and surely there is a way without that stuff?

    Apart from uninstalling and reinstalling in correct order, as i have added three EP's since, It could be that, but geeez it's annoying :( As soon as she hits a level of power, everything goes wrong, oh and also her fairy house loses the emote to drink pollen punch.
    Has anyone else had this problem?
    FEvr1sR.gif
  • OMGImInsaneOMGImInsane Posts: 15
    edited February 2013
    My fairy magic bar is empty all of a sudden and the fairy houses no longer have the option to drink pollen punch.
    My sim can use auras (and never seems to be drained), but cannot play fairy tricks or make plants bloom anymore. The only time he gets an option to play a fairy trick is on his werewolf friend and it says he can't play a trick on her since she's a werewolf.
    He has the King of the Fae reward and can summon other fairies, but still cannot do normal fairy magic besides the auras.
  • ZessinnaZessinna Posts: 117 Member
    edited February 2013
    Problem: I know this was on the front page, that opportunities are not being registered as complete. The particular one I am having trouble with is bringing a sim back as a playable ghost at the science center. I do it, she comes back as a playable ghost, but the opportunity is still there, so if I cancel it, I can't go back to the center to restore another ghost because it didn't register that I finished that opportunity.
    So I split the original building into 2 buildings on the same lot, didn't work. Then I separated them onto different lots, still didn't work.
    Has there been a fix for this?

    *edit*
    I don't know if this matters, but I replaced the Moonlight Falls Hospital/Science Center with one lot for the Hospital from the base game, and the science center is from Ambitions.

    1. Are you using any Custom Content or mods ? Yes
    2. If you are using mods, are you using any of the 'big ones' like Awesome Mod or Twallan’s mods ? No
    3. If you're not using mod, did you never use them or did you take them out for the EP (as you are supposed to do) I have mods
    4. Did you update the mods you put back with a compatible version ? Yes
    5. Do you have Supernatural or just the Patch ? I own supernatural
    6. Which Patch Level are you at ? 1.48
    7. Did you start a new game or are you playing an existing ones ? Existing
    8. Did you transfer an existing Sim over or are they new/Pre-Made ? I had a "savedsim" file and just edited them so they could be not humans.
    9. What town are you currently playing ? EA or Custom ? Moonlight Falls (EA)
    10. What is your Operating System (Mac, XP, Vista, Win 7) Windows 7 64-bit
    11. Do you have the download or DVD Version of the game. Mix. (See below)

    Disks: Base, World Adventures, High End Loft Stuff, Late Night, Generations, Ambitions, Pets, Supernatural.

    Digital Download: Outdoor living stuff and Seasons
    Post edited by Unknown User on
  • ZessinnaZessinna Posts: 117 Member
    edited February 2013
    Raven1988 wrote:
    Fogwgl wrote:
    Raven1988 wrote:
    Why are the gardening glitches STILL not fixed? they're basically game breaking.

    I have no gardening glitches whatsoever...

    Count yourself lucky. Tend garden doesn't work, they just stop after the first plant, plants only yield once, then are forever stuck in "harvest" life state, with nothing to actually harvest among other things.

    I'm also having a glitch that started since installing seasons in which the music that i think typically plays after completing a wish is on constant loop.

    I don't know if this helps but that happened to me in Appalosa Plains (the Pet's World) and it bothered me, but when I moved to Moonlight Falls after getting Supernatural, that glitch stopped. But that might have been because the lot I saved was before the glitch, though in all honesty I do not remember.
  • gambitt775gambitt775 Posts: 7 New Member
    edited February 2013
    maurmchl wrote:
    Gardening bug started today. Family members I'm trying to keep not able to tend, or harvest as they should. Disposable townies moved in, with zero gardening skill, able to harvest normally (as in consecutive plants).

    2: Paused game to que up "harvest" for family gardener, while disposable character was starting Gold Transmutation death. Disposable character turned invisible during this, now his gold statue is invisible and unable to be moved/deleted. Have tried "moveobject" cheat.
    I'm having a similar problem. I'm trying to get gold statues of every life state for my cemetery. I have 4 so far, but I've had several failures. I've discovered that if I use the sledge hammer tool, it deletes the statue, but I can't select, view, or move the invisible statue object. It keeps happening, which also creates unbuildable areas on my lot. Has anyone found a fix for this?
  • CrimsonshionCrimsonshion Posts: 3
    edited February 2013
    Like others, I am having trouble with my werewolf randomly resetting to the default EA werewolf when transforming, rather than using the appearance I picked for them. However, this only begins happening once the sim has been edited via the mirror or the wardrobe. I don't get this issue with sims that I haven't planned an outfit for or changed their appearance, and actively attempt to avoid doing so with werewolves that haven't already been affected by this glitch. I can't seem to edit their werewolf form at all like you said in order to fix it...


    1. Are you using any Custom Content or mods ?
    Yes, but I experienced all of these issues before I had downloaded any custom content/mods.
    2. If you are using mods, are you using any of the 'big ones' like Awesome Mod or Twallan’s mods
    No.
    3. If you're not using mod, did you never use them or did you take them out for the EP (as you are supposed to do)
    I do have mods, but I remove them all before I install a new patch or a new game.
    4. Did you update the mods you put back with a compatible version ?
    Yes.
    5. Do you have Supernatural or just the Patch ?
    Yes, I have Supernatural
    6. Which Patch Level are you at ?
    1.47
    7. Did you start a new game or are you playing an existing ones?
    Existing are the only ones affected, as I said with the whole mirror/wardrobe thing.
    8. Did you transfer an existing Sim over or are they new/Pre-Made ?
    Both sims premade and new experience the werewolf issue.
    9. What town are you currently playing ? EA or Custom ?
    Appaloosa Plains, but the sims were located in Moonlight Falls before. I moved them. However, in both towns, they got this issue.
    10. What is your Operating System (Mac, XP, Vista, Win 7)
    Mac.
    11. Do you have the download or DVD Version of the game.
    I have the disk version of all of the games, except Late Night, World Adventures, and Generations.
  • DawnmccarthyDawnmccarthy Posts: 58 Member
    edited February 2013
    Bonehilda won't care for the children at all. It made it much easier when she did.
  • pwilliams642pwilliams642 Posts: 189 Member
    edited February 2013
    I have been playing in 'riverview for some time and decided to try Moonlight falls, for a change.
    The first time of loading, it 'nearly' made it - the green colour progress bar reached until the semicircle at the end. then the spinning cursor' slowed right down and the game crashed.
    cleared the %temp% files and tried again - same thing happened but moonlight falls eventually loaded. I made a new 'human' sim and moved her into a house.
    now - when she showers she 'spins' as normal, but changes into outdoor clothing, showers, spins and changes into normal clothes.
    anyone else have this problem?
    I hav'nt made any other sims since installing 'supernatural'and 'seasons' so don't know wether this 'bug' came with the ep's or with a patch.

    running windows xp home edition,
    dell dimension 4600
    intel pentium 4 3ghz
    4 gig ram
    nvidea ge force 5200 video card
  • Hungergames101Hungergames101 Posts: 4
    edited March 2013
    Okay so I have the sims 3, late night, pets, world adventures, generations and supernaturals and the Super Natural was working great and then it started glitching. Like When I try and change between "Sim A" and "Sim B"; when i click to go to Sim B the icon still says it's Sim A and that the feeling, relationships and work are all of Sim A. How can I fix this because it's messing up all the relationships and it's hard to play like this. Thank you!
  • RickatlRickatl Posts: 115 New Member
    edited March 2013
    Supernatural hangouts have a closing time of 3am, but the bartenders are configured incorrectly. They leave at 1am. This is a plain vanilla game with no mods.
  • LadyReaperLadyReaper Posts: 1
    edited March 2013
    I just got Supernatural and whenever i try to save it takes forever to do it. So long that i eventually have to close my laptop. Does anyone know what might be causing this?
  • RiaraWinterRiaraWinter Posts: 65
    edited March 2013
    Tried switching supernaturals off in settings, game says they are switched off but they still appear in my game. Not using any mods or cc.
  • piratas1989piratas1989 Posts: 1
    edited March 2013
    I do not have option to buy cure for Vampire from science lab. Play whit Van Gould family.I know I have to be Vampire to buy I am. Never used mods. I think I have all patch automatic update then launcher starts.
  • coolangel533coolangel533 Posts: 3
    edited March 2013
    1. Are you using any Custom Content or mods ?
    No

    2. If you are using mods, are you using any of the 'big ones' like Awesome Mod or Twallan’s mods

    //
    3. If you're not using mod, did you never use them or did you take them out for the EP (as you are supposed to do)

    Never used any.

    4. Did you update the mods you put back with a compatible version ?

    //

    5. Do you have Supernatural or just the Patch ?

    Supernatural
    6. Which Patch Level are you at ?

    I don't know where to see that.

    7. Did you start a new game or are you playing an existing ones ?

    Existing one
    8. Did you transfer an existing Sim over or are they new/Pre-Made ?

    New sims

    9. What town are you currently playing ? EA or Custom ?

    Monte vista
    10. What is your Operating System (Mac, XP, Vista, Win 7)

    Windows 7
    11. Do you have the download or DVD Version of the game.

    DVD

    The issue I have has been mentionned twice already, it's about the elexir consignment shop. I can't get the buy menu to open up even if I speak to the person.
  • DracathioDracathio Posts: 81
    edited April 2013
    Um this is not a big issue, just a 2 little ones.

    1: So I've moved over to a large empty lot to have a nice mansion area, I go and work on building up the kitchen and see I have some good counter choices even a SN one, I decide to go with the highest version which is a regular one. I later than decide after about a week or two of having a regular counter and want to check the SN one I seen. I open it up and the SN counter is no longer there, I go through the store and see my other SN stuff is there like doors windows etc etc, just not the counter. Wanted to know if my head was just seeing things or did they end up taking that out or something?

    2: I am having a tiny issue with trying to sell a small space rock I anylized, I can't seam to drag it over to the sell slot nor drag it what so ever, I had one small Anyilized space rock do the same thing but it stopped glitching after i got smelted ore out of the mail.


    I don't know if u mentioned the top issue, but you might of mentioned the 2nd issue I put here. I'll just say this, I don't use mods, and I haven't used any cheats at all, hell I haven't even looked up cheats or mods what so ever for the game because I don't really use them nor need them when I know how to use the games tiny useful glitches which I haven't used any at all yet. I just hope I am not forced to completely start the game over yet agian. [also I just recently got the game near the end of March like on thursday]
  • Orbit17Orbit17 Posts: 55 New Member
    edited April 2013
    Hi again Crin, I have a post on page 39 I believe that contains my info but this is just about a little funny Zombie Glitch that I don't know if anyone else noticed....here it is
    545956_4113917039988_472801400_n.jpg
    Nothing to cry over but just thought I'd put it here any how. TY for your help with all of the important glitches you rock! :mrgreen:

    HEY! Is that a Gir signature!? Finally, another Invader Zim/Sims fan! :D
  • davina1221davina1221 Posts: 2,947 Member
    edited April 2013
    :D Hi. I mentioned to you before about not being able to catch birds. This could be at the Elixir shop only. I recently caught a lizzard there, but when I went to catch birds there, it would only allow a watch option and no capture option. Just thought I would share. Happy simming. :D
  • singingcrazy123singingcrazy123 Posts: 14
    edited May 2013
    I'm trying to start a zombie apocalypse in my game, i made loads of the potent zombification elixir's, i used them and turned most of the town i saved and quit my game and when i went on it the next day everyone was human again
  • Turbofrog89Turbofrog89 Posts: 2 New Member
    edited May 2013
    Today I bought the Sims 3: Supernatural on a disc. I have already bought the default disc, along with World Adventures and University Life. All three downloaded fine. However, I put my S3 Supernatural in the disc drive, and nothing shows up. No launcher, no installation prompt, nothing except for a quick blue ring on my mouse. I have tried clicking on the actual disc icon. It reads the disc, and I have at least 11GB of space.

    My questions are:

    1. Do you know how to fix this problem?

    2. If you don't, how do I check if my game is region-locked?

    Thank you for your time.
  • MoonWolf321MoonWolf321 Posts: 12
    edited June 2013
    So I've had sims 3 supernatural for a little bit now, and it has most updates that aren't with University.

    My problem is that my witches and vampires can click on 'research alchemy' but the action disappears. I had 1 mod that was a skill book from mod the sims, and I deleted It. I reopened my game, then I did the action again. it did the same as before.

    another issue is that when I go to the supernatural alchemy store I click on 'buy' and they talk then the action disappears and nothing happens. this is not okay.

    Can someone help me? I REALLY need to get this problem fixed. any help is appreciated
  • shadowcat85shadowcat85 Posts: 5,219 Member
    edited June 2013
    Edit I just saw that this bug has already been reported.
    tumblr_inline_ne699tiMiG1r36c5t.gif


  • V1ck3yV1ck3y Posts: 5
    edited June 2013
    I'm having trouble adding Supernatural to my current Sims 3.
    I've tried adding it to the same Sims folder, but it still says that it cannot recognize it. It keeps saying to add to a volume...
    What do I do?
    Please help.
    The software is MAC.
Sign In or Register to comment.
Return to top