SEPTEMBER 12 - It's Patch Day for The Sims 4, see what issues were fixed.
The Sims 4 Is Coming To Xbox One and PlayStation 4! Read the blog for more info.

Sims 3 problems after update ''Windows 10 creator''

Jordan061102Jordan061102 Posts: 844 Member
I don't know what to do... The problem is not my PC. Since I installed the update ''Windows 10 creator'' I have problem in the launch of TS3 and the lights... I repaired the game and update the game. Please help me...
Post edited by Jordan061102 on

Comments

  • Jordan061102Jordan061102 Posts: 844 Member
    When I leave the game, the page Origin is not like I put before...
  • Jordan061102Jordan061102 Posts: 844 Member
    Anybody can help me? :(
  • Jordan061102Jordan061102 Posts: 844 Member
    @rosemow ? (Sorry for post but I really need help...)
  • rosemowrosemow Posts: 113,357 Member
    @rosemow ? (Sorry for post but I really need help...)

    Hello,
    I am sorry that you are having these issues :(
    When the Sims 3 Tech help simmers come onto the forums they will assist you.
  • Jordan061102Jordan061102 Posts: 844 Member
    edited July 16
    Alright...Thank you... :smile:
  • igazorigazor Posts: 12,742 Member
    Yes, we can help but not if you are going to post every five minutes about it while waiting for one of us to arrive on the forum board. :)

    We need a tech responder who has more direct experience with Win 10 and the Creator Update to assist. Paging @Dusty_Boots. But in the meantime, here is a thread where she recently helped a player out with something similar.
    http://forums.thesims.com/en_US/discussion/comment/15848939/#Comment_15848939
  • Jordan061102Jordan061102 Posts: 844 Member
    Thank you @Igazor , I could fix one of the problem, it rest just one problem. When I leave the game the page origin is little and I everytime have to enlarge. It's just annoying me but it's not a big problem. Again thank's.
  • igazorigazor Posts: 12,742 Member
    Wish I could be of more help directly, but Dusty should be able to provide further guidance when she sees this thread. We're all in different time zones here, it could be the middle of the night for her right now or she may be busy offline. Others with experience here might also respond. :)
  • Jordan061102Jordan061102 Posts: 844 Member
    Yes I can understand because in my country it's 23:49. :smiley:
  • mollymegan82mollymegan82 Posts: 627 Member
    ok I "think" I'm having the same problem my computer did the update last night and everytime I start my game it shuts down and says sims 3 has stoped working>>>>I'm assuming that this is the same issue?? I'm not at all tech savy :blush:

    so what I am asking is this the same problem as what jordan061102 asked??
  • igazorigazor Posts: 12,742 Member
    edited July 17
    On a certain level, this should be simple. If the game worked before the Win 10 Creator Update and now does not, then the Win 10 Creator Update is causing the problem and should be removed.

    Unfortunately I am sure that Microsoft does not make it all that simple, especially for the Home version users (Pro is likely more flexible in this regard). This is where it hurts not having access to a Win 10 machine in that I can't see what others are experiencing when something new like this comes along. We really need to wait for a tech responder with Win 10 and Creator Update experience to comment here.

    In the meantime though, perhaps check out the EA Answers HQ board. Likely others are experiencing this as well and help from that source might be available.
    http://answers.ea.com/t5/The-Sims-3/bd-p/the-sims-3

    Also paging a Sim Guru.
    @Nichaedemus
  • Dusty_BootsDusty_Boots Posts: 236 Member
    @Jordan061102

    First, make sure that you've disabled any potential negative effects of that Creator Update. There's 4 effective steps that I'm currently aware of:

    1 & 2: Disable Game Mode & the Game Bar. This guide shows how/where to access them:
    Windows 10: Turn On or Off Game Mode in Windows 10

    3: Make sure to tick the "Disable fullscreen optimizations" option in the Compatibility Tab of the game's exe, click Apply, then OK.

    4: Disable Night Light if you're having negative visual effects such brightness, gamma ramping, color profiles, etc.
    How to Turn On or Off Night Light in Windows 10

    *This Creator Update can override custom graphics settings. The absolute most important one to check is your in-game FPS. TS3 has no native fps limiter so everyone should see to this regardless of the Update. Too high an FPS and your graphics card suffers a lot of unnecessary wear & tear.
    Thank you @Igazor , I could fix one of the problem, it rest just one problem. When I leave the game the page origin is little and I everytime have to enlarge. It's just annoying me but it's not a big problem. Again thank's.

    It sounds like it could be some effect of Microsoft's extensive & ongoing changes in DPI Scaling API handling. They continue to improve it but not all of the changes are working well out of the box. Make sure to set yours to 100% after you disable the new Creator Game Mode effects. I use Option # 1:

    Windows 10: Change DPI Scaling Level for Displays in Windows 10
  • Dusty_BootsDusty_Boots Posts: 236 Member
    ok I "think" I'm having the same problem my computer did the update last night and everytime I start my game it shuts down and says sims 3 has stoped working>>>>I'm assuming that this is the same issue?? I'm not at all tech savy :blush:

    so what I am asking is this the same problem as what jordan061102 asked??

    As igazor said, if the issue(s) began immediately after installing the Creator Update then sure, that's very likely the cause. You can follow the same advice I gave to Jordan above. There's no harm in it and its easily reversed.
  • Jordan061102Jordan061102 Posts: 844 Member
    Thank you so much @Dusty_Boots ! :smile:
  • Dusty_BootsDusty_Boots Posts: 236 Member
    Thank you so much @Dusty_Boots ! :smile:

    You are completely welcome and I hope that takes care of it. Microsoft is making many frequent changes to Windows 10 so problems can change, appear, or disappear entirely, overnight.
  • mollymegan82mollymegan82 Posts: 627 Member
    I'm sorry to sound dim....but I need to have my "hand held" through this... :( ok steps 1&2 to turn off game mode I hit the windows +G and it will pop up...first question do I need to be in game to have this work cause when I hit those keys and I hit the gear the option for disableing game mode does not show up. I would post a pic of what I see but again....not tech savy
  • mollymegan82mollymegan82 Posts: 627 Member
    another thing when I go to settings and click on that I don't even have a "gaming" option?? is there some reason I am missing that?
Sign In or Register to comment.
Return to top