May 28 - It's time for our Friday Highlights! You can check them out here!
Sul sul Simmers! Join us for the #DreamHomeDecorator Livestream HERE today, May 25, @11 AM PT / 6 PM UTC! 🎉
May 27: Today is patch day! 😃 To read the patch notes, click here!

disk authorization failure.

Comments

  • YouarewonderfulYouarewonderful Posts: 108
    edited July 2009
    I got a reply back when I sent in a report. To the people having problems, if you have something like an iPod or a external hard drive plugged in to your usb port, it gets that error. It helped me at least, I realized that I was charging my iPod and trying to play at the same time, and it didn't like that.

    Hope that helps some of you. ^.^
  • jbohnslavjbohnslav Posts: 1
    edited July 2009
    I just got this same problem. I'm going to try restarting and ejecting the disc- we'll see if it works.
  • Rebecca311Rebecca311 Posts: 8
    edited August 2009
    I've been having the same problem for four days now, but I have a Sony Vaio. It happened right after i installed the new patch. I've taken the disc out several times and tried to start it up again and that still didn't work. I've looked for an error log but couldn't find it. I have no ideal what to do now but wait to see if some one comes up with a fix. This is very frustrating and i would really love to get back to my game. Some one please help.
  • cewtsoulcewtsoul Posts: 143 New Member
    edited August 2009
    Having the same problem. I bought the game when it came out and had no problems but now after i installed the last patch i get "disk authorization failure" im really wondering why only a few seem to be having the problem.
  • ElizabethWynElizabethWyn Posts: 187 New Member
    edited August 2009
    I've experienced this once before. It happened randomly. What did I do? Restarted my macbook, then turned off my internet signals, then it suddenly worked... computers can be random sometimes though, so there's never any surefire rhyme or reason for this, especially with the Sims!
  • YouarewonderfulYouarewonderful Posts: 108
    edited August 2009
    Yes, I take back my reliability on my don't-have-stuff-plugged-into-usb method...that is sometimes the case, but lately I'm getting the error again >.> It's like...if I play with the volume right before the game comes up or I have something sitting on my tablet, it decides to do this. I don't get computers. XD
  • NekkiNekki Posts: 1
    edited August 2009
    I have this problem too
    I have to insert the DVD again to solve this problem
  • samcano21samcano21 Posts: 9
    edited August 2009
    This is weird... it happened to me this morning. I bought a new macbook pro a few weeks ago and the sims has been working fine until this morning. I popped the disk out, cleaned it, then put it back in. It worked after that, but then I just got it a couple minutes ago, looked it up, and it brought me here!
  • ashleyr1192ashleyr1192 Posts: 9
    edited August 2009
    I'm having this same problem too :(
    and i have a compaq laptop with vista...
    i guess ill just have to bookmark this page and hope someone tells me whats wrong...ive tried everything! :(
  • VorpalStormVorpalStorm Posts: 10
    edited August 2009
    I made a thread yesterday about this. Didn't know one already existed.

    I'm having the same problem, but it's always preceded by my game crashing for no reason. As if it just failed an anti-pirating check sum. Which isn't the case, obviously, I paid good money for this game!

    This is a serious problem. If it is indeed a anti-pirating measure check sum that's failing it's job, this really needs to be remedied.
  • AdrianiskoolAdrianiskool Posts: 11
    edited August 2009
    I don't guarantee this will work but it should:

    1: Go to Disk Utility
    2: Select your boot drive
    3: Go to the First Aid tab
    4: Select Repair Disk Permissions.


  • ecb1117ecb1117 Posts: 5
    edited September 2009
    I just started having this problem today. I've had the game since it came out and have played a whole lot. I tried restarting my computer but it's still not working. What is going on?
  • celestejwilliamscelestejwilliams Posts: 24 New Member
    edited September 2009
    It is a known issue with the M A T ❤️❤️❤️❤️ A disk drives (Panasonic) most commonly used in Macintosh computers and Toshiba laptops.

    Despite it being a "known" issue, there is no fix.

    Surprise, no? /sarcasm
  • FunkaayFunkaay Posts: 12
    edited September 2009
    mine does that if i haven't played for a while.
    Usually i just say "okay" and i exit and then i try to launch it again.

    after a couple of times *sigh* it finally works. sometimes even after only one time of trying again
  • SammiBowammiSammiBowammi Posts: 3 New Member
    edited December 2009
    ok so i have not played ts3 for maybe a month or two. i decided to get on it again and the disc authorization error popped up after my game had completely loaded. i looked for the answer and found one from ea games. tried it--failure. tried again with my camera and printer unplugged--failure. tried restarting my computer again and yes, it failed. after reading and finding that i am not alone in my frustration, i am going to try yet again. if i find any little trick that makes the tedious process go faster i will post it.
  • blucherry1120blucherry1120 Posts: 1
    edited December 2009
    I've been having issues with disc authorization as well. It's telling me that it can't verify that may game is valid disc, even though I bought it (I did not pirate it). I had this issue with TS3 once after I downloaded the most recent update; I then installed World Adventures and it worked fine before having this issue again. I am pretty annoyed here - I spent a lot on that game, and the store I bought it from gives me trouble about returns...

    I sent a message to EA and haven't gotten a reply back yet. If I do, I'll post it here. Until then I'll try restarting my computer or something...
  • MstymayMstymay Posts: 111 Member
    edited December 2009
    same problem, there goes $30+ D:
  • SoulpeaceSoulpeace Posts: 23
    edited January 2010
    Every time I first try to play the Sims Disc it comes up with the message that it cannot authorize. I just then click and try again and it works the second time thru all the time. Yes, this must be a clitch. Would be nice if they could fix this for us.
  • firekitty500firekitty500 Posts: 102
    edited January 2010
    Alright, so I have been riding on patch 1.4.7 for a long time and I was afraid to install the new patches for this very reason. I was checking to see if there was any other patches avaliable to fix my baldness problem, of course there werent, but I pressed the install button on accident for this jank patch which now will place a disk authorization failure on my game.

    the patch is the fail... :|
    I shall try to eject the disk and then try again, I don't know why it is being so jank but I want it fixed!!
    I just got this game and I am not ready for it to break yet. ❤️❤️❤️❤️, I haven't gotten WA for this very reason! All these bugs!! They shouldn't have released a broken game if they weren't gonna fix it. :?

    Anyhoo, I shall bookmark this page, please anybody, try and find a fix to this thing.
  • TroubleDokoTroubleDoko Posts: 44 New Member
    edited January 2010
    Don't know if this helps. I got the same thing, it wasn't a problem for me. My main problem is that I can't play the game when I go into a family.
    Anyways, what I did was I noticed that on the screen, there was no icon for the sims 3 disc, so I took out my disc and put it back in and the icon appeared. I went back onto Sims 3 and the authorization failure didn't come up. I don't really know why it does that...but hope that helps some people.
  • MoolofMoolof Posts: 33 Member
    edited January 2010
    This happens to me every once and a while. :?

    For me, clearing the safari cache solves it. If your still having the problem, give that a try.
  • dreamghost240dreamghost240 Posts: 1
    edited February 2011
    it seems this isn't a new problem but there is no generic fix for it... srsly EA pull your finger out! if i wanted to put up with lame errors like this i wouldnt have paid for legit copies of this! ive tried every suggestion ive found so far still no good, guess its back to the abyss of forums for me till i can find someone who gives a **** enough to have found a decent fix because EA is too busy counting our money.
  • gokukarengokukaren Posts: 1,247 New Member
    edited February 2011
    Had this problem. Started going to Finder, then LIBRARY, then COOKIES. Delete cookies before you load your game.
    This seemed to help. Also if you have received this error message, remove your disk and then put back in before removing cookies.
  • Vivian8Vivian8 Posts: 1
    edited February 2011
    After 2 months,i wanted to play my sims 3 again but ofc after the updates i wasn't able to do so 'cause of the authentication problem.
    I didn't download any cracked version.I actually BOUGHT the games about 1.5 years ago and never had this prob. before.
    Now that i try to find a solution to this,it's kinda funny to see that this problem exists since 2009!?! :shock:
    So,that means no more sims 3?
    Is there anything we can do to be able to play the game again?
  • TebeauTebeau Posts: 766
    edited October 2011
    :roll: I have been on with technical people in the chat thingy for a while...no one is helping. I don't know what to do. Hopefully EA will come up with a solution... :wink:
Sign In or Register to comment.
Return to top