October 23 - A small but important update for Mac, here the details!
October 22 - Get ready to go to school with The Sims 4 Discover University Expansion Pack! >> Click here for the orientation video.
October 18 - Take a look at the Friday Highlight and discover some awesim discussions! Click me!
October 10 - A new The Sims 4 update is ready for you on Xbox One and PlayStation 4! Details here

Lag due to June's new Lighting system

2...Next

Comments

  • DOLLDRMS1DOLLDRMS1 Posts: 2,908 Member
    I don't speak much in the technical forum because others are so much more experienced than I am with this stuff. It just caught my eye when you mentioned you had a GTX970 because I do, too. Your CPU is much better than my i5-6600, so it would be thought I'd be the one with the lag issue on large lots but, knock on wood, I run a pretty steady 58-59 fps on large lots and I am using Ultra settings. Of course, I'm not sure exactly what your definition of a typical mansion is. If you mean something like the Villareal estate on the 64x64 lot in WB, then we're on the same page. I also don't mean to suggest that I never ever get a drop in fps because I do but haven't seen a situation drop me below a short lived 45 fps scenario. The only reason I'm so sure of those numbers is because I've pretty much had fps on in game since I got the card about 6 weeks ago.

    I also don't use mods or cc in my game but don't know whether or not that influences my results. I found I got the best results for fps by enabling vsync Adaptive on the global tab of the Nvidia Control Panel. For the in game options I did put 60 into the refresh rate but I don't enable vsync in the in game settings menu. Don't know if those settings will help you, just letting you know what I did in case you want to try them out.

    I, too, recommend running HWMonitor. I've used it for years after finding it recommended by someone on MTS.
  • coolspearcoolspear Posts: 23 Member
    I actually have that HWmonitor, and the accompanying CPU checker by same makers, but I'm just too used to calling them both Cupid (CPUID) I didn't cotton on when you first asked. My head was away, lost in the crazy realms of frame rates and possible problems with GeForce Experience being broken and needing uninstalling on both my newer rig and my old rig. Then Nvidia forcing Experience back on the system with driver updates. It's that Nvidia Stream User Agent nonsence running (Pretty high!) in Task Manager because of Experience that I don't trust either. I recently read that can be easily hacked for easy access onto your system. Anyway, who needs GeForec Experience anyhoot? So just got rid of it and the User Agent malarkey that goes with it.

    I thought I'd reinstall TS4 on my old rig, where it originally began life when first released, - quaint that the same legacy hood was back on the old comp where it first started. i7 CPU 950 @ 3.7GHz - 6GB ram - GTS 450

    I wasn't expecting miracles or anything, but exactly the same lag on exactly the same lots with lighting on high. Though it's true, these lots are a 64bit sight to see, that certainly take the game to the edge of performance. So I'm just going to have to bite the bullet and accept the new lighting system pushes these particular lots over the edge.

    I guess I was just mad at the way Maxis giveth, then Maxis taketh away. Polly put the kettle on, Sookie take it off again. If all this had been sorted from game release, and not going through these beta-like swings and roundabouts, then I'd be conditioned to know just how far I could push the 64bit + Lighting system from the get go. Not let my imagination run away with me, and not have my heart broken now with my best five biggest grand lots being lag central. Well, they're still as good as they ever were with lighting on low. And on the 970, there really isn't that much of a noticeable difference between high or low settings. (Pre new sunlight system.)

    I guess if I want to see the lighting in all its glory, best to start a new hood and restrain my urge to build behemoth builds jam-packed with goodies.
  • luthienrisingluthienrising Posts: 31,775 Member
    coolspear wrote: »
    I am buying a new rig next month with a GTX 1080.. so we will see how that goes. :/
    Have you monitored the cpu and gpu usage with a program like hwmonitor?
    What 970 do you have?

    GTX 970msi

    That 1080 looks tasty. I was reading up on it over on the Nvidia site earlier today.

    Haven't tried the hwmonitor. How much of a difference would that make in terms of what the game reports with fps on to what hwmonitor would report?

    I strongly think this is a data problem with the game producing too much info from too many windows all at once, than it is a lighting effects issues.

    The one thing I have not done is actually rip out all the windows of large lots to see if it ends or even reduces the lag. Think that'll be my next test next time I'm in game.

    A friend of mine is playing on a 1080. It's pretty epic. She says she's got zero lag.
    FAQ: culling relationship decay
    #freethebabies #TeamToasters #TeamPlayableGnomes #TeamFarms #FarmTeam #BouncyCastle!!
  • phoebebebe13phoebebebe13 Posts: 19,400 Member
    coolspear wrote: »
    I am buying a new rig next month with a GTX 1080.. so we will see how that goes. :/
    Have you monitored the cpu and gpu usage with a program like hwmonitor?
    What 970 do you have?

    GTX 970msi

    That 1080 looks tasty. I was reading up on it over on the Nvidia site earlier today.

    Haven't tried the hwmonitor. How much of a difference would that make in terms of what the game reports with fps on to what hwmonitor would report?

    I strongly think this is a data problem with the game producing too much info from too many windows all at once, than it is a lighting effects issues.

    The one thing I have not done is actually rip out all the windows of large lots to see if it ends or even reduces the lag. Think that'll be my next test next time I'm in game.

    A friend of mine is playing on a 1080. It's pretty epic. She says she's got zero lag.

    However if one needs a 1080 to play the sims 4, EA needs to really check into fixing this game :p
  • luthienrisingluthienrising Posts: 31,775 Member
    edited July 2016
    coolspear wrote: »
    I am buying a new rig next month with a GTX 1080.. so we will see how that goes. :/
    Have you monitored the cpu and gpu usage with a program like hwmonitor?
    What 970 do you have?

    GTX 970msi

    That 1080 looks tasty. I was reading up on it over on the Nvidia site earlier today.

    Haven't tried the hwmonitor. How much of a difference would that make in terms of what the game reports with fps on to what hwmonitor would report?

    I strongly think this is a data problem with the game producing too much info from too many windows all at once, than it is a lighting effects issues.

    The one thing I have not done is actually rip out all the windows of large lots to see if it ends or even reduces the lag. Think that'll be my next test next time I'm in game.

    A friend of mine is playing on a 1080. It's pretty epic. She says she's got zero lag.

    However if one needs a 1080 to play the sims 4, EA needs to really check into fixing this game :p

    She's playing other games, too :) Just thought I'd mention what she said about Sims 4 on it since she's not getting the issue sometimes reported with 970s and 980s.
    FAQ: culling relationship decay
    #freethebabies #TeamToasters #TeamPlayableGnomes #TeamFarms #FarmTeam #BouncyCastle!!
  • CinebarCinebar Posts: 30,921 Member
    Wow I had this problem and it never dawned on me that one particular restaurant I downloaded may have been the problem because it was full of huge windows. I may take those out, turn my settings back to high and see if it still lags. I removed my screen shot folder and it helped slightly but was afraid I would have to play without the new lighting. Never thought it might be too many windows overkill. But still TS4 shouldn't require a high end machine at least not yet.
    "Games Are Not The Place To Tell Stories, Games Are Meant To Let People Tell Their Own Stories"...Will Wright.

    https://forums.thesims.com/en_US/discussion/958714/cinebar-custom-content-clothes-updating-links/p1


  • phoebebebe13phoebebebe13 Posts: 19,400 Member
    edited July 2016
    Cinebar wrote: »
    Wow I had this problem and it never dawned on me that one particular restaurant I downloaded may have been the problem because it was full of huge windows. I may take those out, turn my settings back to high and see if it still lags. I removed my screen shot folder and it helped slightly but was afraid I would have to play without the new lighting. Never thought it might be too many windows overkill. But still TS4 shouldn't require a high end machine at least not yet.

    There is something wrong with the game's programing and cpu. We have had people with an i5 processor think they are bottlenecking (where the processor is not strong enough for the video card). It was the game causing bottlenecking like symptoms . You have a lower end CPU so if the i5 is having issues it's going to effect you worse.

    It does not effect everyone. Some people have the cpu issues and some dont but I did mention to you in your thread could be one cause for your issues.

    I hope your issues are something you downloaded that can be fixed easily
  • phoebebebe13phoebebebe13 Posts: 19,400 Member
    coolspear wrote: »
    I am buying a new rig next month with a GTX 1080.. so we will see how that goes. :/
    Have you monitored the cpu and gpu usage with a program like hwmonitor?
    What 970 do you have?

    GTX 970msi

    That 1080 looks tasty. I was reading up on it over on the Nvidia site earlier today.

    Haven't tried the hwmonitor. How much of a difference would that make in terms of what the game reports with fps on to what hwmonitor would report?

    I strongly think this is a data problem with the game producing too much info from too many windows all at once, than it is a lighting effects issues.

    The one thing I have not done is actually rip out all the windows of large lots to see if it ends or even reduces the lag. Think that'll be my next test next time I'm in game.

    A friend of mine is playing on a 1080. It's pretty epic. She says she's got zero lag.

    However if one needs a 1080 to play the sims 4, EA needs to really check into fixing this game :p

    She's playing other games, too :) Just thought I'd mention what she said about Sims 4 on it since she's not getting the issue sometimes reported with 970s and 980s.

    I think its the game's programing and the CPU that is causing the lag. Some people are having issues with CPU. Do you remember that thread, forget the user at the moment. She thought she was bottlenecking. had an i5 and a 960. She changed her CPU from an i5 4000 series to a new i7 skylake and the game ran fine. No one should need a skylake i7 to run this game. Ask @chesterbigbird . Its CPU issues not GPU and the games programing.

    What CPU did your friend pair up with the 1080? I suspect a new skylake. i7 or i5?
  • luthienrisingluthienrising Posts: 31,775 Member
    edited July 2016
    coolspear wrote: »
    I am buying a new rig next month with a GTX 1080.. so we will see how that goes. :/
    Have you monitored the cpu and gpu usage with a program like hwmonitor?
    What 970 do you have?

    GTX 970msi

    That 1080 looks tasty. I was reading up on it over on the Nvidia site earlier today.

    Haven't tried the hwmonitor. How much of a difference would that make in terms of what the game reports with fps on to what hwmonitor would report?

    I strongly think this is a data problem with the game producing too much info from too many windows all at once, than it is a lighting effects issues.

    The one thing I have not done is actually rip out all the windows of large lots to see if it ends or even reduces the lag. Think that'll be my next test next time I'm in game.

    A friend of mine is playing on a 1080. It's pretty epic. She says she's got zero lag.

    However if one needs a 1080 to play the sims 4, EA needs to really check into fixing this game :p

    She's playing other games, too :) Just thought I'd mention what she said about Sims 4 on it since she's not getting the issue sometimes reported with 970s and 980s.

    I think its the game's programing and the CPU that is causing the lag. Some people are having issues with CPU. Do you remember that thread, forget the user at the moment. She thought she was bottlenecking. had an i5 and a 960. She changed her CPU from an i5 4000 series to a new i7 skylake and the game ran fine. No one should need a skylake i7 to run this game. Ask @chesterbigbird . Its CPU issues not GPU and the games programing.

    What CPU did your friend pair up with the 1080? I suspect a new skylake. i7 or i5?

    Nope, it's an older CPU but I can't recall which; she was given the GPU as a gift.
    FAQ: culling relationship decay
    #freethebabies #TeamToasters #TeamPlayableGnomes #TeamFarms #FarmTeam #BouncyCastle!!
  • phoebebebe13phoebebebe13 Posts: 19,400 Member
    coolspear wrote: »
    I am buying a new rig next month with a GTX 1080.. so we will see how that goes. :/
    Have you monitored the cpu and gpu usage with a program like hwmonitor?
    What 970 do you have?

    GTX 970msi

    That 1080 looks tasty. I was reading up on it over on the Nvidia site earlier today.

    Haven't tried the hwmonitor. How much of a difference would that make in terms of what the game reports with fps on to what hwmonitor would report?

    I strongly think this is a data problem with the game producing too much info from too many windows all at once, than it is a lighting effects issues.

    The one thing I have not done is actually rip out all the windows of large lots to see if it ends or even reduces the lag. Think that'll be my next test next time I'm in game.

    A friend of mine is playing on a 1080. It's pretty epic. She says she's got zero lag.

    However if one needs a 1080 to play the sims 4, EA needs to really check into fixing this game :p

    She's playing other games, too :) Just thought I'd mention what she said about Sims 4 on it since she's not getting the issue sometimes reported with 970s and 980s.

    I think its the game's programing and the CPU that is causing the lag. Some people are having issues with CPU. Do you remember that thread, forget the user at the moment. She thought she was bottlenecking. had an i5 and a 960. She changed her CPU from an i5 4000 series to a new i7 skylake and the game ran fine. No one should need a skylake i7 to run this game. Ask @chesterbigbird . Its CPU issues not GPU and the games programing.

    What CPU did your friend pair up with the 1080? I suspect a new skylake. i7 or i5?

    Nope, it's an older CPU but I can't recall which; she was given the GPU as a gift.

    I wonder why some are having better luck with and older CPU and some are not.

    Nice gift the 1080 :D
  • chesterbigbirdchesterbigbird Posts: 8,580 Member
    edited July 2016
    Most (almost all) the threads i have seen about problems with this game seem to be either cpu overheating and bottlenecking.
    Now this game should not be making the cpu heat up as much as it does and you should not need a top of the line cpu either.
    Every single Hwmonitor report i have seen (been a few now.) It is reporting very high cpu temps and usage and low gpu temps and usage.
    And i will enjoy my 1080 (after all it's taken me a while to save for this monster pc i'm going to buy.) But i will not be wasting such as good gpu on such a plum game. My first port of call will be to boot up the witcher 3 and crank up Geralt's hair LOL. Then crank up Lara Croft's hair :D
    i7 6700K
    16GB hyper X fury
    MSI GTX 1080
    MSI gaming M5 mobo
    Evga 750 supernova
    Corsair hydro h110i GT
    Corsair obsidian 750D
    500GB SSD
    6TB Seagate Barracuda Pro
    LG 34" ultra wide


  • CinebarCinebar Posts: 30,921 Member
    Most (almost all) the threads i have seen about problems with this game seem to be either cpu overheating and bottlenecking.
    Now this game should not be making the cpu heat up as much as it does and you should not need a top of the line cpu either.
    Every single Hwmonitor report i have seen (been a few now.) It is reporting very high cpu temps and usage and low gpu temps and usage.
    And i will enjoy my 1080 (after all it's taken me a while to save for this monster pc i'm going to buy.) But i will not be wasting such as good gpu on such a plum game. My first port of call will be to boot up the witcher 3 and crank up Geralt's hair LOL. Then crank up Lara Croft's hair :D

    Yeah, no way I would buy an i5 or i7 for TS4. It would have to be a game I couldn't live without.
    "Games Are Not The Place To Tell Stories, Games Are Meant To Let People Tell Their Own Stories"...Will Wright.

    https://forums.thesims.com/en_US/discussion/958714/cinebar-custom-content-clothes-updating-links/p1


  • phoebebebe13phoebebebe13 Posts: 19,400 Member
    Cinebar wrote: »
    Most (almost all) the threads i have seen about problems with this game seem to be either cpu overheating and bottlenecking.
    Now this game should not be making the cpu heat up as much as it does and you should not need a top of the line cpu either.
    Every single Hwmonitor report i have seen (been a few now.) It is reporting very high cpu temps and usage and low gpu temps and usage.
    And i will enjoy my 1080 (after all it's taken me a while to save for this monster pc i'm going to buy.) But i will not be wasting such as good gpu on such a plum game. My first port of call will be to boot up the witcher 3 and crank up Geralt's hair LOL. Then crank up Lara Croft's hair :D

    Yeah, no way I would buy an i5 or i7 for TS4. It would have to be a game I couldn't live without.

    TS4 requires an i5 or an AMD FX . If they don't fix the cpu issue with this game, as it adds more and more ,you might need an i7 which is ridiculous
  • coolspearcoolspear Posts: 23 Member
    As a means to explain what happening in my game more thoroughly, exactly what is happening in my game with each of the TS4 lighting settings.

    June 2nd patch notes say those players on Very High Lighting will have the new sunlight effect.

    Great, I say. That's me. All settings maxed and problem free prior to patch, even on supermassive, high population lots.

    Start game. Awful lag straight away on these large lots. Tried smaller houses, smaller families. No problems.

    I find some advice saying to put Lighting settings on medium to switch of new sunlight effect. I follow advice. STILL NO GOOD on large lots. Still lag, though reduced - obviously. And camera blur when moving camera around. Which is headache-inducing, being a strain on the eyes in a very short time.

    I even open up GraphicsRules.sgr and switch off new sunlight effect altogether - which as Maxis correctly say is only on Very High settings.

    Still no joy. Since June 2nd I seriously have to play on Low settings (For large lots), nothing else, to end all problems of different increments of lag the higher the lighting settings and that plum camera blur from medium settings and upwards.

    I seriously want to give myself titanic migraine because of the blur, just so I can sue EA for this, for enforcing adverse medical conditions without warning due to sloppy programming.

    So, without a doubt, it is what they have done to the lighting effects overall, preparing for the sunlight at Very High settings. The whole of the lighting effects has been messed with, (poorly) not just a single inclusion of nice sunlight on Very High that you can "easily" switch off.

    So much for "thorough" product testing from the manufacturers. Yes, it all happens on busy, large lots only. But I guess I want to hear the words from Maxis themselves. "Then don't play on large lots."

  • DeKayDeKay Posts: 53,066 Member
    @coolspear
    That's odd. Maybe it has something to do with higher end graphics card? I have a 960m only but I'm not experiencing the things you mentioned here and I can pretty much play on large lots with the 'very high' setting for lighting. :\
    My origin ID: DeKaythePUNK
    b4b8WgM.gif
  • egwarhammeregwarhammer Posts: 5,749 Member
    DeKay wrote: »
    @coolspear
    That's odd. Maybe it has something to do with higher end graphics card? I have a 960m only but I'm not experiencing the things you mentioned here and I can pretty much play on large lots with the 'very high' setting for lighting. :\

    Maybe @coolspear could share with you one he's having issues with, @DeKay? :)
  • DeKayDeKay Posts: 53,066 Member
    edited July 2016
    DeKay wrote: »
    @coolspear
    That's odd. Maybe it has something to do with higher end graphics card? I have a 960m only but I'm not experiencing the things you mentioned here and I can pretty much play on large lots with the 'very high' setting for lighting. :\

    Maybe @coolspear could share with you one he's having issues with, @DeKay? :)

    He is the OP of this thread. He already mentioned it on the first post, unless he has another thread.
    My origin ID: DeKaythePUNK
    b4b8WgM.gif
  • egwarhammeregwarhammer Posts: 5,749 Member
    DeKay wrote: »
    DeKay wrote: »
    @coolspear
    That's odd. Maybe it has something to do with higher end graphics card? I have a 960m only but I'm not experiencing the things you mentioned here and I can pretty much play on large lots with the 'very high' setting for lighting. :\

    Maybe @coolspear could share with you one he's having issues with, @DeKay? :)

    He is the OP of this thread. He already mentioned it on the first post, unless he has another thread.

    No what I meant was, these are HIS BUILDS he's having the most trouble with. Not in game lots. Just wondering if you might spot something in a specific lot of his, if he'd care to give you a copy of it to test. You ARE a tester, right? I could swear I've seen you test things for other players... swiss cheese memory though, so I could be thinking of someone else, too... (sorry).

    No other thread... also no link to any possibly-borked lots. :) (Yeah, I looked again.)
  • DeKayDeKay Posts: 53,066 Member
    DeKay wrote: »
    DeKay wrote: »
    @coolspear
    That's odd. Maybe it has something to do with higher end graphics card? I have a 960m only but I'm not experiencing the things you mentioned here and I can pretty much play on large lots with the 'very high' setting for lighting. :\

    Maybe @coolspear could share with you one he's having issues with, @DeKay? :)

    He is the OP of this thread. He already mentioned it on the first post, unless he has another thread.

    No what I meant was, these are HIS BUILDS he's having the most trouble with. Not in game lots. Just wondering if you might spot something in a specific lot of his, if he'd care to give you a copy of it to test. You ARE a tester, right? I could swear I've seen you test things for other players... swiss cheese memory though, so I could be thinking of someone else, too... (sorry).

    No other thread... also no link to any possibly-borked lots. :) (Yeah, I looked again.)

    Hahah, I'm mostly a player but I do help out here and there and do testing. :P
    My origin ID: DeKaythePUNK
    b4b8WgM.gif
  • egwarhammeregwarhammer Posts: 5,749 Member
    DeKay wrote: »
    DeKay wrote: »
    DeKay wrote: »
    @coolspear
    That's odd. Maybe it has something to do with higher end graphics card? I have a 960m only but I'm not experiencing the things you mentioned here and I can pretty much play on large lots with the 'very high' setting for lighting. :\

    Maybe @coolspear could share with you one he's having issues with, @DeKay? :)

    He is the OP of this thread. He already mentioned it on the first post, unless he has another thread.

    No what I meant was, these are HIS BUILDS he's having the most trouble with. Not in game lots. Just wondering if you might spot something in a specific lot of his, if he'd care to give you a copy of it to test. You ARE a tester, right? I could swear I've seen you test things for other players... swiss cheese memory though, so I could be thinking of someone else, too... (sorry).

    No other thread... also no link to any possibly-borked lots. :) (Yeah, I looked again.)

    Hahah, I'm mostly a player but I do help out here and there and do testing. :P

    Well, yeah. I test MC, in my haphazard way. You test lots (and probably other stuff...) I *knew* it was you with Cinebar and Rosa's Diner. :)

    I was really just trying to hook you and coolspear up... but the patch today is supposed to have fixed the screenshots=LAG thing... maybe it'll accidentally help here? Collateral... that'd be nice.
  • DeKayDeKay Posts: 53,066 Member
    DeKay wrote: »
    DeKay wrote: »
    DeKay wrote: »
    @coolspear
    That's odd. Maybe it has something to do with higher end graphics card? I have a 960m only but I'm not experiencing the things you mentioned here and I can pretty much play on large lots with the 'very high' setting for lighting. :\

    Maybe @coolspear could share with you one he's having issues with, @DeKay? :)

    He is the OP of this thread. He already mentioned it on the first post, unless he has another thread.

    No what I meant was, these are HIS BUILDS he's having the most trouble with. Not in game lots. Just wondering if you might spot something in a specific lot of his, if he'd care to give you a copy of it to test. You ARE a tester, right? I could swear I've seen you test things for other players... swiss cheese memory though, so I could be thinking of someone else, too... (sorry).

    No other thread... also no link to any possibly-borked lots. :) (Yeah, I looked again.)

    Hahah, I'm mostly a player but I do help out here and there and do testing. :P

    Well, yeah. I test MC, in my haphazard way. You test lots (and probably other stuff...) I *knew* it was you with Cinebar and Rosa's Diner. :)

    I was really just trying to hook you and coolspear up... but the patch today is supposed to have fixed the screenshots=LAG thing... maybe it'll accidentally help here? Collateral... that'd be nice.

    Haha who knows? :P If coolspear still has a problem with their lots, then I would check them if they are willing to share them with me.
    My origin ID: DeKaythePUNK
    b4b8WgM.gif
Sign In or Register to comment.
Return to top