Fresh off the press - the April 13 Laundry List! Click here to find out more!
April 16 - It's time for our Friday Highlights! You can check them out here!
Welcome to all NEW SIMMERS joining us on the Sims forum! 🎉 Have fun on the forum and please make sure you check out the forum rules and
the rules about necroposting.
Sul sul Simmers! It's awesim to see that so many of you are starting new and interesting discussions! But please make sure that you do so in the right forum section. Thank you! 🙂

Error message "Failed to find any DirectX 9.0c compatible graphics adapters..."

becks1112becks1112 Posts: 576 Member
I just got a new laptop and TS2 won't open. I get an error message about DirectX 9.0c compatible graphics adapters. Anyone know the fix?

Comments

  • CinebarCinebar Posts: 32,558 Member
    You will need to download and install the Graphics Rule Maker, then follow instructions of how to change the files in Config (can't supply link of those instructions as this site doesn't like the site of actual instructions for some reason) to make the game see a proper video card or chip.
    "Games Are Not The Place To Tell Stories, Games Are Meant To Let People Tell Their Own Stories"...Will Wright.

    https://forums.thesims.com/en_US/discussion/958714/cinebar-custom-content-clothes-updating-links/p1


  • fullspiralfullspiral Posts: 14,652 Member
    Cinebar wrote: »
    You will need to download and install the Graphics Rule Maker, then follow instructions of how to change the files in Config (can't supply link of those instructions as this site doesn't like the site of actual instructions for some reason) to make the game see a proper video card or chip.

    Actually, I just spent some time tonight doing that. All I did was search how to change screen resolution for sims 2 and it shows where in your files to do it. I didn't have to download anything.
  • becks1112becks1112 Posts: 576 Member
    Cinebar wrote: »
    You will need to download and install the Graphics Rule Maker, then follow instructions of how to change the files in Config (can't supply link of those instructions as this site doesn't like the site of actual instructions for some reason) to make the game see a proper video card or chip.

    I tried doing this and it didn't work for me. I got it to work in windowed mode, but it's annoying to not have the full screen, so I'm still looking for another solution.
  • SchneccoSchnecco Posts: 1 New Member
    I am having the exact same issue with Directx 9.0c compatibility in Windows 10. It will open in windowed mode, but I cannot get it to run in higher resolution, even using Graphics Rule Maker or directly modifying the Config files. EA Support was not very helpful about it:

    "Unfortunately Sims 2 games are not discovered for latest version of Windows. Sims 2 is very old game and support for Sims 2 was closed few years ago. To be honest there is no way to play Sims 2 in full screen mode in Windows 10 as Direct X crashes. This is because Sims 2 is not compatible with the graphics designed for windows 10."
  • CinebarCinebar Posts: 32,558 Member
    Since I can't link leefish instructions and I have had this problem on older games on a Win. 10 laptop (not Sim game) here is some instructions I found to help me play an older game on Win 10 other than window mode (full screen).

    These are from MS in case anyone wants to know:

    1. Right Click Properties of Game Icon on desktop.
    2. Under Short Cut Tab: Click Run: Then Click Maximise, Apply, OK.

    This did not work for me as MS claimed it would in one of their answers. This was not a Sim game but a problem with Win 10.

    I had to do the following then reset my resolution on the laptop.

    Because it has an Intel graphic chip (not really for gaming but plays some) it would not play any games I installed other than in window mode.

    I fixed this issue by entering settings in the Intel Graphics Properties, clicking on maximise or something or full screen or something. (Should be found in your graphic properties for the pc or laptop) Of course this made my desktop look bad but easily fixed with reseting the resolution for the pc/laptop. Then when I load the old games they are in full screen. I know this is sketchy but that is how I solved a Win 10 problem for older games after the above instructions didn't work.
    "Games Are Not The Place To Tell Stories, Games Are Meant To Let People Tell Their Own Stories"...Will Wright.

    https://forums.thesims.com/en_US/discussion/958714/cinebar-custom-content-clothes-updating-links/p1


  • becks1112becks1112 Posts: 576 Member
    My solution for now is to run it in windowed mode, but I use this app to make the window full size: http://www.brianapps.net/sizer4/. You can still see the task bar, which is annoying, so I'm still trying to find a different solution, but it's at least playable this way.
  • CinebarCinebar Posts: 32,558 Member
    edited March 2020
    Here are instructions for changing the resolution so you don't have to play in Window Mode if my instructions didn't help anyone. I might have done this years ago when we first got TS2UC in 2014, and forgotten I did it, lol.

    https://simsvip.com/2014/07/20/the-sims-2-ultimate-collection-increase-resolution-guide/
    "Games Are Not The Place To Tell Stories, Games Are Meant To Let People Tell Their Own Stories"...Will Wright.

    https://forums.thesims.com/en_US/discussion/958714/cinebar-custom-content-clothes-updating-links/p1


  • HeyHeyyHeyHeyy Posts: 465 Member
    I had the same problem happen too after updating the game on origin. =( No matter which settings I change it to in compatibility mode, it won't help. Tried new graphics drivers too but no luck. I'm going to be getting a new laptop soon and will use your suggestions if the same problem persists.
    GALLERY: jdm14_xx
    LIKE my page on FACEBOOK. @jm.violetsims14

    <3
Sign In or Register to comment.
Return to top