February 3rd- It's time for our Friday Highlights! You can check them out here!

EIG won't work for me anymore

I started having trouble with EIG last summer. Since I had a lot of store content in the lots I made for the project I was working on at the time, I was making it in parts, intending to combine them when everything was finished. But during test games I ran with what I had in the main part, I kept discovering things I needed to fix, and some lots that needed to be changed. At some point, EIG started crashing if I put even one lot with store content in to the world. Most of the time it crashed while saving, but later on, it started crashing while I was building or editing the lots. Eventually, I decided to take a break and start playing again instead.

For my current game, I am playing in worlds connected with NRaas Traveler mod. I decided I wanted my active household to move to one of the worlds I had previously made in CAW. So I set up the world in the game, adding in a base camp, and removing a few community lots I don't need, to add in ST lots, which I had not placed in it when I built it, and populating it. But when I moved my sims there, the game took them to the unedited world. In the process, I discovered a lamp post out in the middle of a grove of trees, so I decided to take it back into CAW to fix that, add a base camp, and populate it. But every time I take it into EIG, when I save it, it crashes.

Nothing I have tried to add has any store content at all. I've even removed all store based lots, like the bakery and archery range I made, and replaced store world rabbitholes I had originally used with ones from the base game, or EP's. Then I placed the base camp, which is totally made of the base game log cabin blueprints, so no store content. EIG crashed while saving, and has every time I've tried to do anything.

I don't understand why this is happening. I had no trouble at all when I originally made the world. I've even uninstalled CAW and reinstalled it with a fresh download, in case the program had somehow gotten broken along the way. But it still crashes.

Does anyone have any ideas of what I could do to fix this problem?

Comments

  • Rflong7Rflong7 Posts: 36,482 Member
    Hi :)

    EIG doesn't like store stuff. There comes a point when there are too many lots with any amount of store stuff install, and EIG won't work.

    I had to find a way to allow CAW's EIG to work with all my Store Stuff - which I never did. It just won't.
    The more you fiddle, the quicker it will hit that breaking point.

    Make a backup save of your CAW files, then mess around with them...
    https://forums.thesims.com/en_US/discussion/737094/only-testing-adding-lots-when-eig-will-only-crash-from-store-limit/p1
  • IreneSwiftIreneSwift Posts: 6,234 Member
    Thank you, @Rflong7. Those instructions look pretty complicated, but I think I can follow them one step at a time as I work on my project. I'm glad you didn't give up, and that you are so willing to share your methods with the rest of us.
  • IreneSwiftIreneSwift Posts: 6,234 Member
    I am now playing Sims 3 exclusively on my laptop, and have just started working in CAW on it as well. I've generated a game folder just for CAW, with no store content, because I couldn't use EIG at all, right from the start of the project, with no lots installed. I read in an older thread that the amount of store content installed in the game can overload EIG just from trying to load it all. If I wait to install any store content into that folder until I'm ready to add the lots that use it, and only add in a few such lots at a time, would that be more likely to allow me to eventually get everything into my world that I want? I won't be using anywhere near all of it in this world anyway.
Sign In or Register to comment.
Return to top