JUNE 19 - It's Patch Day for The Sims 4 on PC/MAC Patch notes here.
Friday Highlights for June 15th are here! Head over here to check them out!

Issues launching game/extreme lag since patch release.

Since downloading the two recent patches for sims 4 I have experienced problems with the launcher timing out when I try opening up the game to a point I have to close it and retry one to two more times before it opens smoothly. This problem I had before the most recent patch and though it doesn't bother me too much it makes going into sims 4 a hassle because I know this isn't my computer having trouble loading.

The second issue is odd, sporadic lag, this I experienced yesterday and this morning since updating again to the patch released a few days ago. it's not a game breaker but it's similar to that horrible problem everyone had shortly before City Living was released, the sort of lag that makes the world and sims feel like they're in a time warp and makes you feel sick if played for more than 10 minutes.

Before logging these I'd like to add that my computer is routinely defragged because of how much sims can do to it and the files within, I clear caches and don't use mods to a fault so there is no conflict between software and the like, I also have sims in its own file to itself out of the way of other things on my laptop which in itself is made for harder to process things like sims and other big games, all of the above is how I know these problems are the patches as everything was fine before them and my computer can handle a good amount, even sims itself pretty plum easily.

I hope logging this helps others with the same or similar issues with their game right now and perhaps before said patches.

Have a nice day everyone

Comments

  • rosemowrosemow Posts: 131,077 Member
    Hello
    I am sorry that you are having these issues,
    Repairing the game may help. To do that, go to games library in Origin, right click on the sims 4 picture and click repair

    Try resetting your sims 4 folder, starting a new save game file, and testing to see if it occurs there also . To do that, move your sims 4 folder ( that is in Documents -Electronic Arts - then the sims 4 folder is there ) to the desktop. Then start the game, and a new sims 4 folder will be generated.
    Start a new game and test to see if the issue is in that new save game.
    Exit the game and then copy back the "options.ini" or "options" file and the "saves" , "screenshots" "tray" "custom music " and "mods" folders from the desktop sims 4 folder to the new sims 4 folder, replacing the new generated file/ folders with the old file/folders from the desktop sims 4 folder.

    Try turning off origin in-game and see if that helps. To do that, go to Game Library in Origin . Right click on The Sims 4 picture. Click on “Game Properties”. Then untick the box that enables origin in-game

    Make sure that your graphics drivers are uptodate.
  • GodleyjeansGodleyjeans Posts: 151 Member
    rosemow wrote: »
    Hello
    I am sorry that you are having these issues,
    Repairing the game may help. To do that, go to games library in Origin, right click on the sims 4 picture and click repair

    Try resetting your sims 4 folder, starting a new save game file, and testing to see if it occurs there also . To do that, move your sims 4 folder ( that is in Documents -Electronic Arts - then the sims 4 folder is there ) to the desktop. Then start the game, and a new sims 4 folder will be generated.
    Start a new game and test to see if the issue is in that new save game.
    Exit the game and then copy back the "options.ini" or "options" file and the "saves" , "screenshots" "tray" "custom music " and "mods" folders from the desktop sims 4 folder to the new sims 4 folder, replacing the new generated file/ folders with the old file/folders from the desktop sims 4 folder.

    Try turning off origin in-game and see if that helps. To do that, go to Game Library in Origin . Right click on The Sims 4 picture. Click on “Game Properties”. Then untick the box that enables origin in-game

    Make sure that your graphics drivers are uptodate.

    I repaired the game twice, once last night and then again this morning to reshuffle anything that might have gotten corrupted, files have been moved and I opened a new save to no avail so I reopened the old one just now in a fresh boot and the lag seems to have disappeared for now, even the launch is smoother (A little bit but it's noticeable).

    What's confusing me is nothing worked this morning, not even the new save showed improvement but now after opening the old save and accidentally leaving it for 20 minutes to run errands, the lag has vanished for now. I'm not confident it'll stay that way but is it possible some files just sorted themselves out?

    Everything on my computer is up to date, the sims files are clean as a whistle and I keep the game on the easier to handle settings to help flow.

    Forgot to mention that I bought and installed My First Pet last night, could that have fuelled the problem before whatever within got to repairing it?

    I'm sorry to bother you, I'm just very frustrated and confused after hours of trying to repair my game only to forget about it and have magic happen.

    Thank you for your help, though. I am extremely appreciative
Sign In or Register to comment.
Return to top