February 3rd- It's time for our Friday Highlights! You can check them out here!

Won't Recognize My Disc Anymore?

So I was playing Sims 3 LITERALLY two days ago and it was working perfectly fine. YAY. But I tried it both yesterday and today, several times, and every time I open the game it says there is no game disc inserted. Now, I've installed all the updates for the game, all of them for my Macbook, all of them for my virus software, the disc isn't scratched, I cleaned it and it's about as clean as an almost-2-year-old game disc ever is, and have restarted my computer several times. When I put it in the drive, the picture of the disc pops up, but as soon as I click to enter the game it disappears, and so all I get is the opening intro and then when I get to where you pick a family it says "No Game Disc Found".

I really don't know what's up. The last time this happened (with Nightlife on my PC) I had to buy an entirely new game disc, which I just don't have the money for right now. Any other ideas?

Comments

  • AlexRoz9AlexRoz9 Posts: 309 New Member
    edited June 2011
    There are a couple of things that you can try, if you haven't done so already:

    1. Repair your permissions: "Go" --> "Utilities" --> "Disk Utility" and then verify/repair disk permissions.

    2. Invest in a cleaning disc; you can buy them at Staples for about $10 dollars. A CD lens cleaner works fine (there are ones for CD and DVD players, either one will do the job, which is to clean the lens.) These are special discs with "brushes" built into them that will remove dust/dirt/oil/other gunk from your lens. Follow the instructions the disc gives you once you load it into your Superdrive. Try playing the game after that, if it works, your lens was dirty.

    3. This is where things get ugly; insert some other discs and see if they work correctly; if they don't, your laser may be burning out/burned out, and you may need to replace your Superdrive. Contact an Apple Authorized Service Provider and have them look at your machine. This isn't exactly cheap, but new Superdrives never are. If you have Applecare, and are still covered by it, this will be a free repair.

    Hope this helps; sorry I can't be of more assistance.
  • MelindaKelseyMelindaKelsey Posts: 17 New Member
    edited June 2011
    It's not your disc. I'm having the same problem. I uninstalled/reinstalled Generations and it worked again. But only for one play. For some reason every time the game gets turned off, it just stops working and tells me there's no disc inserted the next time. :/ I'm hoping EA will release a patch that fixes this because I paid for my games.. I want to play them! Try uninstalling and reinstalling and see if it works.
  • katieKaylakatieKayla Posts: 4
    edited September 2012
    i need help! i bought the sims 3 supernatural and it won't work! when i start the game and i get to the main menu, a notice comes up that says "disc authorization Failure" and then it says my disc is not found and to please insert it. i spent a lot of money on this game and i want to play it! i've tried a lot of things, but none of them work. i have a mac and none of the stuff people say to do is working. HELP!
  • amjoieamjoie Posts: 3,492 Member
    edited September 2012
    After you insert the disk in the drive, and after you open the launcher, BUT before you start the game, try relaunching the finder.

    To do that, go to the "apple" menu in the upper left corner, choose "force quit," then highlight "finder" and click on the "relaunch" button. That will probably help the game recognize the game DVD in the drive.
  • jellybabies1234jellybabies1234 Posts: 18
    edited September 2012
    Same happened to me, it says you have inserted a blank disc, and when i click play sims 3 it says no disc inserted, i have been waiting like a month to play! :!: :cry:
  • allisondsallisonds Posts: 11
    edited September 2012
    Having the same issue..Supernatural (not downloaded from Amazon, but a disc bought from EA)
    Early 2009 MacBook
    Mac OS X Mountain Lion.

    One time it worked after I reset the SMC/PRAM as I saw suggested on EA's help page, but since then that hasn't worked.

    I'm not sure what to do..please help! :( :?: :shock:
  • allisondsallisonds Posts: 11
    edited September 2012
    Relaunching the finder didn't work either.. :?
  • katiekelly47katiekelly47 Posts: 1
    edited September 2012
    Hey guys i have a macbook pro bought early in the year and i have the problem also.
    However i found somewhat of a solution. If it pops up after the game loads, as in you choose to play the family and then it says error no disk found or whatever. Restart your computer, like turn it off then back on. Try again. Also make sure if you have downloaded anything from the sim store or exchange, or opened the sims at all restart your computer and then open it up.
    Oh and you absolutely have to sit through the entire into thing.
    Mine works perfectly fine as long as i do all that.
    Hope it helps for the mean time. :)
Sign In or Register to comment.
Return to top