August 22 - It's patch day for The Sims 4 on console! Read the patch notes here.
August 23 - Ready for the Friday Highlight? Check it out here!
August 15 - We have updated the forum rules. Learn more here.

Merging packages?

Hey everyone, hope you're well.

I recently just heard about the ability to merge packages to speed your game up. The only problem seems to be that I have nearly 14gb of CC. When I import all of the packages to be merged in S4PE, I get an error code that aborts. In Sims 4 Studio, I get so far and then the program crashes. I have tried splitting my CC up into batches, but I still have issues.

Does anyone know what the problem is or perhaps even if there is another way of merging packages?

Thanks and have a great weekend! :smile:

Comments

  • pboxpbox Posts: 630 Member
    What is the error code you are getting there in s4pe?

    Also, is this a recent version? The current release is here: https://github.com/s4ptacle/Sims4Tools/releases

    First thing I'd try is merging them in smaller batches, depending on what machine you have .. if you don't have a lot of RAM I guess 14GB might be a bit much at once.
    Stuff for TS2 · TS3 · TS4
  • maccajack94maccajack94 Posts: 26 New Member
    Hi, thanks for the reply.

    The code I get is:

    Could not import all resources - aborting.
    (RK: 0xAC16FBEC-0x80000000-0xD2BA9B574EAEE7F7)

    == START ==
    Source: s4pi.Package
    Assembly: s4pi.Package, Version=1412.28.57.34111, Culture=neutral, PublicKeyToken=null
    Unrecognized compression format
    at s4pi.Package.Compression.UncompressStream(Stream stream, Int32 filesize, Int32 memsize)

    at s4pi.Package.Package.GetResource(IResourceIndexEntry rc)

    at s4pi.WrapperDealer.WrapperDealer.GetResource(Int32 APIversion, IPackage pkg, IResourceIndexEntry rie, Boolean AlwaysDefault)

    at S4PIDemoFE.MainForm.importPackagesCommon(String[] packageList, String title, DuplicateHandling dups, Boolean compress, Boolean useNames, Boolean rename, List`1 dupsList, AutoSaveState autoSaveState, IList`1 selection)
    -----
    == END ==
  • pboxpbox Posts: 630 Member
    Which s4pe version is this?
    Stuff for TS2 · TS3 · TS4
  • maccajack94maccajack94 Posts: 26 New Member
    I've tried the most recent version and a previous version, to check it wasn't just a specific bug, but both provide the same result.
  • pboxpbox Posts: 630 Member
    edited February 2016
    By "most recent" you mean 0.4.3-release? I'm asking because it has moved a few times, and sometimes people think an age old version is the current one since they don't see that newer ones exist.

    If you use 0.4.3-release it would be interesting to know what compression this is, seeing as it's complaining about one particular resource (0xAC16FBEC-0x80000000-0xD2BA9B574EAEE7F7). Can you find out what package that is in? It must be some CAS part (0xAC16FBEC is a RegionMap).
    Stuff for TS2 · TS3 · TS4
  • maccajack94maccajack94 Posts: 26 New Member
    It's 0.4.3. I split my CC into ten folders, but each folder when added to s4pe brings a different error code, so I don't think it's one specific package causing issues. :(
  • pboxpbox Posts: 630 Member
    edited February 2016
    Is that error always about the same type of resource?

    Actually, can you post about it here please: http://modthesims.info/showthread.php?t=572510 ? Or on github if you prefer, https://github.com/s4ptacle/Sims4Tools/issues . Not everyone working on s4pe has an account here.

    For this kind of error it would be useful to add the name of the package, maybe we can do that (because then the user can just remove that one package). But it would be good to have a few examples of resources where this is happening, so if you could post a few of the errors you get, that would be helpful (plus maybe an accurate description of how exactly you are importing these packages -- drag + drop? Import > From Package? Something else?)

    Thanks!
    Stuff for TS2 · TS3 · TS4
  • pboxpbox Posts: 630 Member
    Okay, an interim version that should give you a more useful error message is posted here: http://modthesims.info/showthread.php?p=4979915#post4979915 -- this reports the package name / file path, in addition to the resource name.
    Stuff for TS2 · TS3 · TS4
  • _orangemittens__orangemittens_ Posts: 505 Member
    Hi @maccajack94, it's my understanding from the SimGuru's post HERE that the maximum size the game can accept for .packages is 2GB. You should definitely break up your content into multiple .packages or else the resulting .package will cause the game to not work. When you work with smaller quantities of content does Sims 4 Studio still crash? If so does it give you an error message? If you aren't getting an error message pop up an error might be being logged in your Documents/Sims 4 Studio/Logs folder. It would have the date/time of whenever the crash occurred.
Sign In or Register to comment.
Return to top