This site has entered read-only mode as of July 18th. The new Forums.EA.com are now live.

Done with The Sims 3 and this Franchise (resolved?)

1235...Next

Comments

  • Options
    shadowmel333shadowmel333 Posts: 83 Member
    edited June 2013
    piddlesim wrote:
    To the OP: I had a laptop do the exact same thing after a windows update. The sims 3 stopped using the high performance dedicated video card.

    Here are instructions to reset it if you need them in the future:

    You have to whitelist the game

    In the NVIDIA Control Panel, under the 3D Setting > Manage 3D Setting

    On the right side of the screen

    Select the Global Setting tab
    under "Prefer graphic processor" Select "High Performance NVIDIA Processor"

    Now click on the Program setting tab

    click on "Add" and navigate to wherever directory your game is installed and select the exe file for your game.

    Then click on "Open" and after you done the adding, under the 2. Select prefer graphic processor for this program select "High Performance NVIDIA Processor" then click "Apply"

    This link explains it much better and has pictures.

    http://www.howtogeek.com/136123/htg-explains-what-you-need-to-know-about-nvidia-optimus/

    You're right.

    OP : The sims 3 seems to dislike Nividia optimus technology. I had a hard time forcing the game to play on my dedicated geforce as well, because of optimus. Keeping the nvidia control pannel under control every time you install a new game will most likely resolve the "wrong gpu" problem. Hope this fixes your crashes for good.
  • Options
    Glic2003Glic2003 Posts: 2,933 Member
    edited June 2013


    Hm, interesting! Thanks for the update Weealbet.
    simsig_willwright.gif



    "We've been attributing the state of The Sims 4 to greed but I think it's time to give sheer incompetence another look."
    -Honeywell
  • Options
    KarritzKarritz Posts: 21,942 Member
    edited June 2013
    Thank you Weealbet. I am glad you are having some success with getting your graphics card recognised.

    Here is a link to how to do it if it is missing from the sgr file in your game bin.

    http://simswiki.info/wiki.php?title=Game_Help:Getting_new_graphics_cards_recognized_by_the_game

    There is another link somewhere that I will try to track down that tells you how to force a laptop to use the correct card for playing Sims 3.

    There is no need to reinstall anything to do this successfully. I am sorry you have gone to so much trouble to fix what is really a simple thing to do.

    This thread contains instructions on how to get your laptop to recognise the correct card.

    http://forum.thesims3.com/jforum/posts/list/678657.page
    Post edited by Unknown User on
Sign In or Register to comment.
Return to top