The latest update addressed the crashing issue that some of you have been experiencing, Click here to found out more!
November 27 - Everyone ready for the Friday Highlight? It's ready for you here.
You are browsing an archived read-only section of the forums. Looking for The Sims 3 Help Center? Click here!

Can't download CC due to needing a software update?

Hey guys! has anyone had this issue before??

My game was working perfectly until my computer got sent away for repair so it got completely wiped. When I re installed everything I re uploaded a back up from my memory stick, I could no longer install all my CC from the launcher. It says..

"Please make sure your game has the latest software updates and try again"

This has been an ongoing problem for months now! I haven't been able to solve it. All my games are up to date.. and as far as I can see, my computer is too. My Sims walk around with missing CC and hair with black faces because the skin is no longer installed.

Any ideas? I feel like I've tried everything but wondered if anyone else has issues.


  • igazorigazor Posts: 18,730 Member
    Are you on Patch 1.67 or an Origin controlled 1.69?

    Regardless though, as a test if you pull your TS3 user game folder out of Documents for safekeeping thus forcing a new game folder to form in its place on the next startup, can you download and install one test CC item that has been giving you trouble on the new, no-content game folder?

    Also, does any of this CC require an EP/SP, installed world, or store content item that is now also missing or not loading for whatever reason?
    NRaas has moved!
    Our new site is at
  • cianeciane Posts: 16,618 Member
    If you just need the latest store patch...
    The store update isn't available on this site any more. If you have 1.69, it's included through Origin.

    If you need the 1.67 version, you may have the file you need in an old sims 3 contentpatch folder. If you installed the same way as before, then you just copy over that folder (or just the contentpatch.package file). Otherwise, there are also a few kind souls who shared their content patch on the internet.

    If you need a steam version:
  • ShimmeringBloodShimmeringBlood Posts: 49 Member
    Hi guys, sorry for my slow reply, I have been working on trying to fix the issue!

    According to my game it's on 1.69. Some downloads will install and some won't! it's very bizarre. I managed to get my stuff back so people aren't walking around topless any more lmao! (this is a really long story how I got it back!)

    My new issue is now Save Error 12. I've been clutching onto this game so much and I finally fixed it and now another problem! why do we do this to ourselves? lol - I literally change 2 peoples outfits and I get the save error so I can't play much for more than 10-15 mins :'(

    I'm finding it hard to let it go because I have been playing this since 2013, I have so many legacy families so I never give up when there's issues and just keep trying to fix it. :s

  • igazorigazor Posts: 18,730 Member
    Error 12 means that the game is out of usable resources at the time it is trying to run a Save. TS3 is a 32-bit only application and as such cannot use more than 4 GB of RAM (the actual hard limit is about 3.7) no matter how much we have on our systems. Since we cannot get the game to use more than that, the goal becomes finding out why it is calling for so much.

    Could be "bad CC" throwing things into a loop, or it could be an overpopulated town, sims carrying too much history and scrapbook memories, online features of the game getting in the way of performance, a world that is just too complex to play for any reason. We have a host of tips here as to how to improve the game's performance and reduce its calls for more resources than it can really use. Some are mod related, others are not.

    To help make things more measurable, what I usually do is check the game's RAM usage using Task Manager (in GBs, not %s) at the time it starts up and the game clock begins moving forward and then again pretty frequently throughout play. If your game save is trying to level off at somewhere way above 3 GB, or not leveling off on RAM usage at all, then something bad is likely to happen before too long.
    NRaas has moved!
    Our new site is at
  • ShimmeringBloodShimmeringBlood Posts: 49 Member
    It's just crazy how I'm suddenly having issues when I've been playing it for months without any issues (Until my computer got a repair!)

    I've tried to play and it's literally just unplayable at the moment. *sigh* It is a 64 bit computer too (I have a gaming computer) I'm wondering if I'm going to have to move them all to a smaller neighborhood. If so, I've got my work cut out for me moving all their houses etc and putting their family tree connections back.

    Thanks for replying to me.
  • puzzlezaddictpuzzlezaddict Posts: 1,579 Member
    Have you checked the game's RAM use, as igazor suggested, while you're playing that particular save? What world are your sims currently living in? How many sims currently live in the household, and how many in the world? Are you running NRaas StoryProgression or any other heavy mods? (The other NRaas mods are fine.) There are many reasons why a save would run into repeated Error 12s, and some of them are more easily fixed than others.

    On that note, do the suggestions on the NRaas page about better game performance help? Once you have an idea of how much memory your save is using right now, with no interventions, it should be easy enough to see whether these tips are helping. Just put TS3 in windowed mode and then bring up the Task Manager. The game's RAM use is easy enough to spot. (If it's showing in percentages, right-click on the column header to change it to absolute values.)

    You might find that a few adjustments, perhaps the ones that NRaas mods enable, make this save playable again. Or there might be nothing you can do, especially if you're currently playing in a world that's too large or too broken. But if you're invested in this particular save in this particular world, maybe it's worth it to you to investigate a bit.

    P.S. If you do need to move the sims to a new world, NRaas Porter makes that a lot easier. Sims packed together will retain their relationships to each other, as will extended family if the remains of the ancestors in the shared family tree come along for the ride.
  • ShimmeringBloodShimmeringBlood Posts: 49 Member
    I use a downloaded world. It's an updated version of sunlit tides. No matter what household I play, big or small, I'm getting the error 12. I have a few Nraas mods. I don't have story progression though. I have overwatch which cleans things up at 3am. Someone mentioned trying error trap?? :S and I have a few other bits.

    Before my computer got repaired I had error 13. If I played for 3 hours or longer I wasn't able to save, I could cope with that though because that's more than enough game play for me in the day. I'm not exactly 13 any more with lots of hours to play lol

    but since I re installed everything and tried playing again, it's 12 and I can't even get 15-20 minutes never mind 3 hours.

    I will have a look definitely. When I've been playing I've just been looking at percentage and it's been like 50% ram used and after being in cas it's hitting like 67% onwards! ouch :'(

    I definitely want to save it. These families I've been playing since 2013, so their family tree is amazing as you can probably imagine!

    Nraas porter I've used a few times, the families were in sunset valley to begin with, then island paradise and then sunlit tides. (All done over the course of the years) I'm very invested in them lmao!

    I tried to save their houses and families into the library to just suck it up and move them to a new neighborhood (I love the one they're in! :'( ) and one house, it basically just got stuck on trying to save it into the bin so that was a bust!
  • ScottDemonScottDemon Posts: 497 Member
    edited December 2019
    "Please make sure your game has the latest software updates and try again"
    This is caused when the CC in question was made on a lower patch level and the Launcher can't read the Manifest XML. Or for some reason the Manifest XML is either missing or got broken somehow.
    I use a downloaded world. It's an updated version of sunlit tides.
    Would that be the one made by Jacks Creations by any chance?
    I'm just a little bit crazy LOL
    Okay actually I'm totally and completely nuts LOL :p
Sign In or Register to comment.
Return to top