May 28 - It's time for our Friday Highlights! You can check them out here!
Sul sul Simmers! Join us for the #DreamHomeDecorator Livestream HERE today, May 25, @11 AM PT / 6 PM UTC! 🎉
May 27: Today is patch day! 😃 To read the patch notes, click here!
You are browsing an archived read-only section of the forums. Looking for The Sims 3 Help Center? Click here!

No UI/"Green Box" Glitch on Every Save I Load

InfraGreenInfraGreen Posts: 6,584 Member
edited October 2019 in The Sims 3 Bugs & Issues
If you're unfamiliar with the bugs: green box, no UI

I am going to admit that I haven't tried every solution but hear me out as to why: literally zero of my saves are loading correctly. They load with no UI, I find a way to restore it (through switching to another household and then back again, or evicting and replacing via edit town), and then the green boxes show up. I have backups from when my current elder heir was just a baby and they are all facing this issue, as far as I'm aware, even if I was able to successfully load them before. Some notes:

- I haven't traveled recently at all
- I can switch to another household and there is no green box bug
- I did a full reinstall to troubleshoot, as well as loading saves in a "factory reset" file (no dice). Since they're in Sunlit Tides, I also reinstalled that world itself.
- In my most recent batch of backups, the same three sims and dog are affected. One of them is pregnant in the most recent save but not pregnant in the others, with no change in how she's affected.
- no mods were being used. Obviously I'm open to them as a fix but I wonder if it will solve everything being unable to load.

Any ideas? God I wish I could open a good backup and be done with this!
A thousand bared teeth, a thousand bowed heads

outrun / blog / tunglr


  • InfraGreenInfraGreen Posts: 6,584 Member
    edited October 2019
    Morning updates:

    - ErrorTrap cannot recover my sims successfully (!!!)
    - Moving to a new town (using EA's regular move function) makes everyone playable again, but I'm not ready to move.
    - Remembered to delete world caches, no dice either.
    - The most recent file that I didn't open yet took me back a whole sim week but loading it in a factory reset folder seems to have worked.

    Anyways this stunk, 0/10 would not recommend for you or even an enemy.
    Post edited by InfraGreen on
    A thousand bared teeth, a thousand bowed heads

    outrun / blog / tunglr
  • k_reeser1k_reeser1 Posts: 153 Member
    same issue everytime i load a game,they appear in a few moments.

  • InfraGreenInfraGreen Posts: 6,584 Member
    @k_reeser1 do you have a backup? Also while NRaas ErrorTrap didn't really work for my specific case, it might be worth a shot for you. And here's how to make a factory reset folder. This stinks though! :(
    A thousand bared teeth, a thousand bowed heads

    outrun / blog / tunglr
Sign In or Register to comment.
Return to top