The latest update addressed the crashing issue that some of you have been experiencing, Click here to found out more!
November 27 - Everyone ready for the Friday Highlight? It's ready for you here.
You are browsing an archived read-only section of the forums. The Sims 4 Help Center can now be found here.

Sims 4 Not Responding Before Opening for Gameplay?

simuellesimuelle Posts: 100 Member
edited February 2018 in Mac - Technical Discussions
So, when I open Sims 4 for gameplay, my screen goes black like it's loading up, then it brings me to my desktop with rainbow disc of despair. Eventually, Sims 4 loads up with no problem. I'm just confused and slightly concerned about this problem. It doesn't affect gameplay itself, but it's kinda annoying. I'm uninstalled, reinstalled, and even repaired the game a couple of times. The only thing I haven't tried is restarting my laptop, so I'll give that a go and update later.

In the meantime, any suggestions?

UPDATE: I restarted my Mac, and opened from the shortcut rather than from Origin, and it still happened. Then I opened from Origin, and it happened at again.
tumblr; punchella origin id; liujiaxie
NNePthn.png

Comments

  • Tremayne4260Tremayne4260 Posts: 3,123 Member
    edited February 2018
    Restart your laptop and see if it still occurs. One question. Do you start the game directly from Origin or from the shortcut? It could be your internet connection is taking the time to log into Origin, taking time to do so and then once verified the game starts.
    Second Star to the Right and Straight on 'til Morning.
  • simuellesimuelle Posts: 100 Member
    @Tremayne4260 I start it directly from Origin.
    tumblr; punchella origin id; liujiaxie
    NNePthn.png
  • southaltansouthaltan Posts: 152 Member
    It’s been happening since I updated to High Sierra. It eventually opens but takes a few minutes.
  • Tremayne4260Tremayne4260 Posts: 3,123 Member
    One other question, do you have a lot of CC/Mods in your game? That slows down the loading time as well. I play a mostly vanilla game and am updated to High Sierra.
    Second Star to the Right and Straight on 'til Morning.
  • simuellesimuelle Posts: 100 Member
    @Tremayne4260 That might be it, I added a lot of CC hair and clothes because I don't have all the packs yet.
    tumblr; punchella origin id; liujiaxie
    NNePthn.png
  • simgirl1010simgirl1010 Posts: 18,488 Member
    edited February 2018
    Same thing is happening in my game. I was ready for a fresh start anyway so I uninstalled the game. Uninstalled Origin. Reinstalled. Still get the not responding before it finally loads.

    Oops, just realized this is for Mac discussions. It's happening to me on PC.
    Always believe that something wonderful is about to happen. 😊
  • couttsie_3couttsie_3 Posts: 6 New Member
    Hello,, I really need help. Basically my sims4 won't open, i can get on origin and click on the play button but then my screen goes black, lags me off then tells me "the sims4 has quit unexpectedly". It started when i tried to download a house from the gallery which ended up too big for the lot so i went back to the gallery clicked on a house then a big loading sign popped up on my screen and froze my laptop which meant all i could do was shut it down, It was working fine earlier and i have repaired it and shut down my laptop multiple times,, please help :(
  • couttsie_3couttsie_3 Posts: 6 New Member
    It may be my connection, i will try later but any other suggestions would really help, (if its really complex please do step by step)
  • elram76elram76 Posts: 60 Member
    Mine does the same thing. Occasionally when my OS updates it will stop but it eventually comes back. Not a big deal but annoying.
  • BluebellFloraBluebellFlora Posts: 7,089 Member
    Disable Origin in-game.
    apple-signature.png
  • simuellesimuelle Posts: 100 Member
    @BluebellFlora Holy ❤️❤️❤️❤️, it worked! Thanks so much!
    tumblr; punchella origin id; liujiaxie
    NNePthn.png
  • BluebellFloraBluebellFlora Posts: 7,089 Member
    simuelle wrote: »
    @BluebellFlora Holy plum, it worked! Thanks so much!

    ;)

    apple-signature.png
  • Dino_GaminzDino_Gaminz Posts: 8 New Member
    hello there this is happening to me as well, my game says it isn't responding, but it isn't just a wait a couple seconds/minutes deal, it never leads seriously! I have over 2000 mods so I deleted a BUNCH I now only have 1400 mods (lol still a lot) and deleted some content that seems to be bugged with the game, but it still won't load, I tried going into fullscreen mode as well, that didn't work, I restarted it uninstallededit, repaired it but nothing has worked. please help.
  • Dino_GaminzDino_Gaminz Posts: 8 New Member
    @BluebellFlora how do you do that?
  • Tremayne4260Tremayne4260 Posts: 3,123 Member
    edited July 2018
    @Dino_Gaminz, start Origin like normal. Start the game like normal. Once you're in the Start Area, go into Options and turn off Origin there. You also may want to remove your CC/Mods before starting up the game and seeing if that helps.
    Second Star to the Right and Straight on 'til Morning.
  • Dino_GaminzDino_Gaminz Posts: 8 New Member
    @Tremayne4260 thank you I removed a lot of my cc and it worked, I just wish that I could play with cc, I think I will be fine though.
  • BluebellFloraBluebellFlora Posts: 7,089 Member
    @Dino_Gaminz

    To turn off Origin in-game open Origin, hover over your name in the bottom left corner and click on Application Settings in the menu that appears. Then click on Origin in-game from the options at the top of the window and disable Origin in-game.
    apple-signature.png
  • af02af02 Posts: 18 Member
    Hey guys! Sorry I'm a new member so I can't start a discussion so I'm sorta hijacking this cause it's been added to recently if thats ok :# - I'm glad your issue got fixed!

    Basically I've been having some weird & specific issues with the gallery. I'm fine to download households and lots from the gallery, and I'm fine to save my households to my library BUT I can't save lots to my library or upload households to the gallery (or lots, since I can't even save them.) I've been having the issues with lots for at least a few months but never figured out how to fix it, but it just tells me it's unable to save the lot. Then a few days ago I discovered I couldn't upload to the gallery (which I'd never tried to do before) because of 'server error.' I know there's quite a lot of similar discussions but I've tried everything that seems to have fixed their problems. I don't use CC, I've repaired my game, I've put my game back to factory settings and checked my firewall & antivirus and they don't seem to be the issue especially since I can download just fine. I also use a mac if that changes anything. Is there something stupid I'm missing?

    I know this is long and I'm sorry for commenting it on here I just don't know what else to do! Luckily it's not a major issue but kind of sucks losing all my lots furnishings whenever sims move out.
Sign In or Register to comment.
Return to top