The latest update addressed the crashing issue that some of you have been experiencing, Click here to found out more!
November 20 - Everyone ready for the Friday Highlight? It's ready for you here.
You are browsing an archived read-only section of the forums. The Sims 4 Help Center can now be found here.

[Solved] Is Origin down?

«1
loubyloulouloubyloulou Posts: 4,205 Member
I'm just getting the circle of death when I try to sign in. Thought it was me so have reinstalled, but still getting the same issue.
Post edited by EA_Mai on

Comments

  • alanmichael1alanmichael1 Posts: 4,201 Member
    Yes it's down.
  • EA_MaiEA_Mai Posts: 1,800 EA Staff (retired)
    edited February 18
    Yes, log into Origin, log into the forums and some other EA services are having issues at the moment. We are working on resolving the issue as soon as possible so you can get back into Origin and the game.
    Post edited by EA_Mai on
  • loubyloulouloubyloulou Posts: 4,205 Member
    EA_Mai wrote: »
    Yes, log into Origin and some other EA services are having issues at the moment. We are working on resolving the issue as soon as possible so you can get back into Origin and the game.

    Thanks for confirming it's you, not me :D Hope it gets fixed soon.
  • simmertje1981simmertje1981 Posts: 13 New Member
    Ah thank, Ive got the same problem. I'm releaved that I'not the onky one. And now I know Why I can't going online on origin or sign in on the origin website.
  • HestiaHestia Posts: 1,997 Member
    Yep. I can confirm that this is not only The Sims or Origin but EA’s server database. Maybe someone spilled some coffee on the server or a server hamster fell asleep. :)
    wB2Zykl.jpg
  • DeafSimmerDeafSimmer Posts: 2,867 Member
    I have this problem, too. Tried updating my PC and this still happens. Looks like I won't be able to access TS4 gallery for quite some time.
  • Lbphart3Lbphart3 Posts: 22 Member
    Console players can’t seem to get the gallery to come up.
  • alanmichael1alanmichael1 Posts: 4,201 Member
    I'm completely surprised that players always re-install Origin or update their computers when this happens ;). Just be patient, it's never ever your fault.
  • Atreya33Atreya33 Posts: 1,645 Member
    I just tried to download a lot from the gallery with my browser to have it in my game next time but the gallery does not seem to be working either. I can't log in.
  • BMSOBMSO Posts: 3,002 Member
    I was wondering what was going on and while it was taking 5 minutes for the Connection EA overlay to go away. Thought it was my laptop at first until I ran origin as administrator and it allowed me to log in but said log in failure. At least now I know what's going on.
    Thanks @EA_Mai for the update! :3
    Bmso85's emporium - mysims4studios

  • 12JEREMIA12JEREMIA Posts: 2,472 Member
    No! No! No! Nooooooooooo!!
    My Sims 4 radio station wishlist
    Latin, Hip Hop, R&B, Reggae
    Nim2f7Q.png
  • NikolaiBanksNikolaiBanks Posts: 144 Member
    EA_Mai wrote: »
    Yes, log into Origin, log into the forums and some other EA services are having issues at the moment. We are working on resolving the issue as soon as possible so you can get back into Origin and the game.

    Honestly I thought the issue was in my area due to weather problems via rain, rain does mess with internet connections from time to time in my area. Hope things are sorted out soon.
    "Ooh... why does life have to be so ironic?!" Sweetie Belle in One Bad Apple.

    1280710__safe_edit_edited+screencap_screencap_starlight+glimmer_to+where+and+back+again_animated_boop_boop+edit_cropped_cute_female_finger_frown_gif_gl.gif
  • loubyloulouloubyloulou Posts: 4,205 Member
    OK, well it seems to be back up and running for now :)
  • EA_MaiEA_Mai Posts: 1,800 EA Staff (retired)
    We are not considering this resolved yet, but you might want to give it another try, I'm starting to see some members starting to log in. :)
  • DeafSimmerDeafSimmer Posts: 2,867 Member
    Origin still isn't letting me log in so I could play my game.
  • RainesimsRainesims Posts: 901 Member
    My paranoid mind always thinks i've been hacked when this stuff happens. thankfully i was already on sims and its still working for me / origin is still open and didnt say anything was wrong. I only found out something was up because the gallery wouldn't connect :') glad to know its not a me problem ahah
    QWO48ni.jpg

    gallery: RainesimsUwU
  • MiaSkywalkerMiaSkywalker Posts: 3,254 Member
    edited February 18
    Oh noes! It's the end of the world! I can't play Sims! :bawling:

    Just kidding. I hope you get it resolved soon. :) Thank you for letting us know!

    Edit: Seems to be working now, though. At least, I didn't have a problem.
  • BecksdereBecksdere Posts: 1 New Member
    I'm able to log in, just can't use the gallery yet ^^;!
  • EA_MaiEA_Mai Posts: 1,800 EA Staff (retired)
    The issue has been resolved. Thanks everyone for your patience!

    If you are having issues to connect to the Gallery, please, try to restart your game, making sure you are not offline on Origin.
  • divanthesimmerdivanthesimmer Posts: 1,371 Member
    Yep, I have the same problem. Except I've been having it for several weeks now. I finally brought it up to the gurus earlier today, which may have made them aware of the issue. Hoping it gets fixed soon.
    phULnBI.png
    Check out my SimLit blog here: https://ageekylegacy.wordpress.com/
    Follow me on Twitter @divanthesimmer
    Follow me on Tumblr: https://www.tumblr.com/dashboard/blog/divanthesimmer
    Origin ID: divanthesimmer
  • EA_MaiEA_Mai Posts: 1,800 EA Staff (retired)
    @divanthesimmer If you have been unable to connect to the Gallery since before this topic that’s a different issue. You might want to look into this thread instead: https://answers.ea.com/t5/Technical-Issues-PC/CURRENT-ISSUE-Cannot-connect-to-Gallery/td-p/8663540/page/10
  • DeafSimmerDeafSimmer Posts: 2,867 Member
    edited February 19
    What should I do about the "Hold up! An Update is Required" pop-up?

    Never mind, found a workaround.
    Post edited by DeafSimmer on
  • divanthesimmerdivanthesimmer Posts: 1,371 Member
    edited February 18
    EA_Mai wrote: »
    @divanthesimmer If you have been unable to connect to the Gallery since before this topic that’s a different issue. You might want to look into this thread instead: https://answers.ea.com/t5/Technical-Issues-PC/CURRENT-ISSUE-Cannot-connect-to-Gallery/td-p/8663540/page/10

    I'm not having issues connecting to the Gallery - just the forums. Once in a while I get logged out automatically and when I try to log in, a window pops up saying something along the lines of "choose a username to connect with on the site". When I type in my username and password, it says "You don't have a password associated to your account yet" and I'm unable to log in again. Also, that window seems to be the wrong one, since a completely different one is supposed to pop up (with a white and purple background). It first happened on my PC, then my Internet app on my phone and now the Chrome app on my phone. I can solve this by going incognito and logging in from there, but it's really bothersome to have to do that every time.
    phULnBI.png
    Check out my SimLit blog here: https://ageekylegacy.wordpress.com/
    Follow me on Twitter @divanthesimmer
    Follow me on Tumblr: https://www.tumblr.com/dashboard/blog/divanthesimmer
    Origin ID: divanthesimmer
  • tinahjalmartinahjalmar Posts: 1,576 Member
    I'm having issues with the 'That didn't go as planned'. I did try to restart my laptop and it didn't work for me
  • EA_MaiEA_Mai Posts: 1,800 EA Staff (retired)
    EA_Mai wrote: »
    @divanthesimmer If you have been unable to connect to the Gallery since before this topic that’s a different issue. You might want to look into this thread instead: https://answers.ea.com/t5/Technical-Issues-PC/CURRENT-ISSUE-Cannot-connect-to-Gallery/td-p/8663540/page/10
    I'm not having issues connecting to the Gallery - just the forums. Once in a while I get logged out automatically and when I try to log in, a window pops up saying something along the lines of "choose a username to connect with on the site". When I type in my username and password, it says "You don't have a password associated to your account yet" and I'm unable to log in again. Also, that window seems to be the wrong one, since a completely different one is supposed to pop up (with a white and purple background). It first happened on my PC, then my Internet app on my phone and now the Chrome app on my phone. I can solve this by going incognito and logging in from there, but it's really bothersome to have to do that every time.
    Ah! Really strange - I'll send you a DM @divanthesimmer
    I'm having issues with the 'That didn't go as planned'. I did try to restart my laptop and it didn't work for me
    @tinahjalmar this is on Origin, right? If it hasn't recovered by now, and restarting Origin doesn't help, please, open a new topic here: https://answers.ea.com/t5/Origin-Client-Web-Technical/bd-p/origin-technical-issues-en
This discussion has been closed.
Return to top