August 16 - Ready for the Friday Highlight? Check it out here!
August 16 - Guru Garage day! SimGurus are ready to continue with the Guru Games - details here!
August 15 - We have updated the forum rules. Learn more here.

Is anyone else having random crashes since downloading Island Living? Just wanting to know

I've played a vanilla game and my game still crashes BUT only in build mode. When I try to add walls or rotate the screen, it will go black....then come back up...I try again and it will go black and stop. I will wait and then it comes back up. I've gone to tech support and tried all they said, so what I want to know is if anyone else is having problems.

Comments

  • izecsonizecson Posts: 903 Member
    Seems like gpu issue to me, maybe your gpu is out of vram.
  • KatzcKatzc Posts: 471 Member
    @izecson--Thanks for answering. Any suggestions on what I should do? Grateful for any help/advice.
  • BeardedgeekBeardedgeek Posts: 3,233 Member
    Nope, only regular crashes.
    I've learned to live with that the game always crash when I exit it. Because it always manages to save first.
    Origin ID: A_Bearded_Geek
  • BeardedgeekBeardedgeek Posts: 3,233 Member
    Katzc wrote: »
    @izecson--Thanks for answering. Any suggestions on what I should do? Grateful for any help/advice.

    A few questions:
    1. Does your computer fulfill minimum specifications for compatibility with the sims?
    2. If yes, how long has it been acting up?
    3. Is it very warm? If a laptop, is it almost burning hot somewhere? If it's not a laptop, does the fans go crazy?
    Origin ID: A_Bearded_Geek
  • KatzcKatzc Posts: 471 Member
    @Beardedgeek--PC and it does fulfill minimum specs. I bought it specifically for The Sims. I do have lots LOTS of CC. I have been trying to paring down on it. It started a few days after I added Island Living. In CAS, the game is perfect. I can make Sims all day with no problems. When I go into build mode is when the problem happens. I haven't even PLAYED the game yet!! I have been hearing my fan a lot more lately though on PC.
  • BeardedgeekBeardedgeek Posts: 3,233 Member
    edited July 10
    Katzc wrote: »
    @Beardedgeek--PC and it does fulfill minimum specs. I bought it specifically for The Sims. I do have lots LOTS of CC. I have been trying to paring down on it. It started a few days after I added Island Living. In CAS, the game is perfect. I can make Sims all day with no problems. When I go into build mode is when the problem happens. I haven't even PLAYED the game yet!! I have been hearing my fan a lot more lately though on PC.

    Well my suspicion is the CC, since you have so much of it.
    If you move ALL the CC out of the mod folder and then start a brand new game, does it still crash?

    If not, add the cc back one at a time and try to start the game. Pain in the plum, but best way to check.
    Origin ID: A_Bearded_Geek
  • EIisabettaEIisabetta Posts: 5,588 Member
    It's also possible you have a bad bit of CC. What Beardedgeek suggested will help, if it doesn't crash with all your CC removed. It's a pain but often necessary.

    Do this. Rename your Sims 4 folder but don't delete it (I rename mine something like Sims 4 Backup). Then start a new game. That will help you start absolutely fresh with no cache files clogging anything up. If the game runs fine, put back in half your CC. If it doesn't crash. Take it out and put in the other half. If it crashes, then start eliminating from there (half at a time, they call it the fifty/fifty method, speeds things up a bit). If it doesn't crash, there may have been something else going on. I can't tell you how many times simply creating a new Sims 4 folder fixed things for me, though.
    moxiegraphix on Origin
  • KatzcKatzc Posts: 471 Member
    I did that. Renamed to Saves Old/Mods Old/Tray Old and the game generated new files. It worked for a minute, then stopped. I finally played the game and it worked for a while but glitched again. Thinking of saving my files to outside source and resetting to factory specs. I'm desperate!
  • izecsonizecson Posts: 903 Member
    edited July 10
    Katzc wrote: »
    I did that. Renamed to Saves Old/Mods Old/Tray Old and the game generated new files. It worked for a minute, then stopped. I finally played the game and it worked for a while but glitched again. Thinking of saving my files to outside source and resetting to factory specs. I'm desperate!

    To alleviate the out of vram issue, try reducing the texture quality, view distance and antialiasing option from whatever it is you currently set and set it to low.
  • catloverplayercatloverplayer Posts: 84,327 Member
    Nope, only regular crashes.
    I've learned to live with that the game always crash when I exit it. Because it always manages to save first.

    That's an issue with Origin. At one time they had fixed that in an update. Seems to be back.

  • catloverplayercatloverplayer Posts: 84,327 Member
    Katzc wrote: »
    I did that. Renamed to Saves Old/Mods Old/Tray Old and the game generated new files. It worked for a minute, then stopped. I finally played the game and it worked for a while but glitched again. Thinking of saving my files to outside source and resetting to factory specs. I'm desperate!

    Try posting in this thread so SimGuruNick and Arvin can have a look.
    https://answers.ea.com/t5/Bug-Reports/bd-p/The-Sims-4-Bugs

  • SelinaKylesSelinaKyles Posts: 534 Member
    Op, are you playing on a overheated laptop? Definitely recommend anyone playing on a laptop to use a fan. Also recommend what Cat said.
  • EA_RtasEA_Rtas Posts: 1,751 EA Moderator
    May be an idea to post this over to The Sims 4 AHQ as was pointed out by the very helpful Catloverplayer. You should be able to get a bit more help there as we don't do technical or bug support on these forums anymore. Hope you're able to get the issue sorted.
This discussion has been closed.
Return to top