The latest update addressed the crashing issue that some of you have been experiencing, Click here to found out more!
November 20 - Everyone ready for the Friday Highlight? It's ready for you here.
You are browsing an archived read-only section of the forums. Looking for The Sims 3 Help Center? Click here!

University Life Bug thread


  • Bunnie610Bunnie610 Posts: 5
    edited November 2013
    Well, I bought University Life and installed it, and the family I was playing with had a teen so I waited for him to age up, graduate, and then I added his girlfriend to the family and had to buy the university welcome kit because the mascot never came. They took the aptitude test then I sent them to university and they weren't there so after reading a whole bunch, ended up having to get my first mod, nraas traveler, got it set up, and it worked! Both of them got there, and I chose them to live in the Malan Hall dorms and then I pressed the 'rent' button then the little check button that says "Start playing with this household!" and now that button is grayed out. I can click on other dorms and 'rent' them and it does the same thing! I have restarted my game and re-tried but it did the same thing.. Does anyone know what to do to solve this issue?? I was so looking forward to play University! :(
  • EsseilteEsseilte Posts: 7 New Member
    edited November 2013
    I'm having an issue where my sims go through their time at the University and wake up on Saturday and get their grades. They get the notice that the graduation ceremony is going to be the next day and do they want to invite anyone. Then the graduation ceremony happens about an hour later, not on the next day. Once, my sims went and only one made it into the ceremony, so out of three sims only one got the extra trait and moodlet. This latest time, my sims popped into the annex and immediately popped out and both were sent home with 48 credits, no extra trait and no moodlet. I play totally vanilla, no mods, no custom content. Driving me crazy!
  • KingismyhorseKingismyhorse Posts: 3
    edited November 2013

    So I'm tired so I probably just couldn't find the answer to this- I tried searching but nothing came up.

    So I have expansions up until University Life and I've played with it a bit. So this time around I had a new sim and sent him off to University- brand new sim. It was great, fun, yadadadada, he got turned into a plantsim. Cool. So he goes back home to Sunset Valley and I want to send him back to Uni so he can finish his degree.

    But, he. Won't. Go. Back. I try to use the phone to re-enroll and he talks on the phone, laughs, and then makes a disgust noise and hangs up. He did this a few times and then I made him use the computer- but again, nothing happens. I made him take the aptitude test and try again- nope. ResetSim didn't work, waiting for the next day didn't work.

    Any ideas as to what my problem could be? Thanks!
  • kensei0samakensei0sama Posts: 4 New Member
    edited December 2013
    I'm suddenly having an issue with my Sim being unable to go to lecture. She arrived went in for barely a moment and came out again before the lecture ended.

    I have no mods or cc I don't even have store items. Is there a fix or am I just going to have to erase my game?
  • vhahnovsmilevhahnovsmile Posts: 21
    edited December 2013
    I moved my sims to Uni and the game told me to pick a new household once a got there.
  • SkyzhemaSkyzhema Posts: 47
    edited December 2013
    I'm unable to create families now that I've installed University and Pets packs.

    1. Are you using any Custom Content or mods ? I uninstalled and reinstalled it.
    2. If you are using mods, are you using any of the 'big ones' like Awesome Mod or Twallan’s mods? No, nothing major.
    3. If you're not using mod, did you never use them or did you take them out for the EP (as you are supposed to do)? I removed them.
    4. Did you update the mods you put back with a compatible version ? I think so?
    5. Do you have Seasons or just the Patch ? Just the patch?
    6. Which Patch Level are you at ? The latest, as Steam updated it for me.
    7. Did you start a new game or are you playing an existing ones ? An existing map, but when I create new ones it still happens.
    8. Did you transfer an existing Sim over or are they new/Pre-Made ? I *tried* to make new ones. Premades work but it crashes when loading a new family.
    9. What town are you currently playing ? EA or Custom ? Uhm, Twinbrook I think?
    10. What is your Operating System (Mac, XP, Vista, Win 7) Win 7 32-bit.
    11. Do you have the download or DVD Version of the game. Steam Version--however I've heard it happens in the DVD version as well.

    Basically, I create the family and when I hit the checkmark to go to the family portrait it never finishes loading. I've waited over an hour before with no luck. There is no crash report and I am forced to force-close the game via Task Manager.
  • vhahnovsmilevhahnovsmile Posts: 21
    edited January 2014
    I got it fixed! Thanks!
  • ouTTie914ouTTie914 Posts: 1
    edited January 2014
    I got it fixed! Thanks!

    How did you fix this? I'm having the same issue.
  • SmartiezSmartiez Posts: 5
    edited January 2014
    hey im having a similar issue i tried deleting the nhd files but when i went back to my game my family as i knew it was gone and id come pretty far from then .....was wondering could anyone help please as when i try to get back to the household it keeps me stranded in edit town saying you cannot change active household whilst editing a world :/ when all i wanted to do was send my sim to uni ended up losing a whole household seriously sucks
  • chopin27chopin27 Posts: 763 Member
    edited February 2014
    I just noticed that the option for the funny "study with..." interaction is missing. :(

    Here is one of my old pics.
  • ClisairClisair Posts: 33 Member
    edited March 2014
    I moved my sims to Uni and the game told me to pick a new household once a got there.

    Soi far the only way I can get to Uni is if I delete the uni world files from the save. Mean that the uni world has to be recreated every time you sen someone to school.
  • julz2qtjulz2qt Posts: 1 New Member
    edited April 2014
    I did all the work finish top off class degree never came.
  • ShannenShannen Posts: 2,809 Member
    edited May 2014
    I am also having the same problem as julz2qt. I have sent my witch sim to university, she first studied Business and then went on to the Technology degree. On both degrees, she earned an A and passed her exam with flying colours and was on the Dean's list both times. However just after the exams, a pop up comes up saying to invite family and friends. The first time, I didn't bother but the last time, I had my sim invite two of her friends from back home. I also get another pop up on the Saturday saying that graduation is the following day, which is odd as I am always sent home late Saturday night. So in the end, my sim never gets a chance to attend graduation and she never gets her degree. Even though in the studies part of the menu, she as the golden coloured degree information. I am really confused as to why I am having this problem as she got 48 credits for both degree, in a way it's not a big deal but it would of been nice to see her degree.

    Also as anybody experienced the infinite loop music whilst at University? No matter what my sim does, it constantly played and it got to a point that I had to mute my gameplay until I got her back home and I could save and quit. I haven't played the sims today, so I'm not sure if it will be a sticking problem with my gameplay or just a temporary problem like I had with the constant phone ringing. I will update this post, when I know more.

    Edit: It seems that it was a temporary issue with the looping music.
    Post edited by Unknown User on
  • lovejess2lovejess2 Posts: 3,049 Member
    edited May 2014
    ouTTie914 wrote:
    I got it fixed! Thanks!

    How did you fix this? I'm having the same issue.

    Same here help would be very appreciated.
  • Akari1812Akari1812 Posts: 6
    edited June 2014
    Just installed University and to my frustration it will not let me save or edit my town. It claims you can't save your game or edit your town when your in travel mode and I haven't even gone anywhere!!!

    Please help.
  • AmaltheeaAmaltheea Posts: 3
    edited June 2014
    So... I am completely disappointed so far with this expansion pack. I literately can't play it. So MANY bugs:

    1. After arrival everything is ok, in the first 1-2 days. After that my social interactions are messed up: if i try to Greet a new sim, it never happens and that sim is sort of reset and is displayed a bit further from my sim. If I try to interact with a friend sim nothing happens (let's say I'm using the phone to set a date, I pick the place, the Sim-date says YES, we meet there... and none of my social interaction are working.)

    2. After few days of playing I started to get information about a random sim, Karri somewhat. Ok... odd. Then... she was displayed as a new Sim which I could control. I had my original sim, from my original family and this new sim... What the hell?!

    3. When finals were over and i was sent home... it crashed.


    - I have all the expansion packs installed, except Into The Future (the original games, registered etc.)
    - I have NO mods
    - I tried University for 3 times (I never saved, because I didn't want to ruin my so far game), every time I had this problems (only the last time I had patience to wait for my sim to be sent home, so the crashing game happened only the last time)
    - I have my game up to date (patch 1.67.2)

    So... what can I do? It's completely unplayable.
  • plaaymateplaaymate Posts: 5
    edited June 2014
    Hi. I started a thread but didn't get any answers so gonna try here instead.

    I got University life some time ago and immidietly discovered the known problem of sims that are sent to the university town does not always show up. Anyway, it happened when I sent one of my sims there, and I just got to the university town and could choose to create household, selecting households, etc. so I thought I was gonna ignore the Sim that I sent to uni because I was mostly just eager to play a student. So I created a new household containing one person and moved in a house in the uni city, and saw that she was not studying anything, it just said "the semester was over and it was time to go home". Then chose to "jump off the university" and thought she would go to Appaloosa Plains (where the Sim I first tried to send to the university came from) but the only thing that happens is that Appaloosa Plains just loaded to the end, but nothing happends after, it just loads and loads.

    When I realised I couldn't "go home" in that way, I killed my sim hoping to go back to Appaloosa, then the same thing happened, it was just loading again. And since it is not possible to change the household when you are at uni, I cant go that way either. I uninstalled university life and tried to start the game again but now I cant even start that one particulary saved game because of that I dont have university life anymore.

    I just want my world back with all my families I played in several generations! Does anyone know how I can fix this ? I tried to restore my computer to an earlier time but something happened so I couldn't and nothing changed. Appreciate all the help!
  • ivory18ivory18 Posts: 32 Member
    edited June 2014
    Hi. My sims did not get their diplomas and i was wondering if someone can help me with this issue, please and thank you. :)
  • SesedotcomSesedotcom Posts: 1
    edited July 2014
    My game keeps freezing. This began after I installed sims3 university. I already have the sims 3 pets expansion pack as well as the sims 3 generations expansion pack. I even re-installed sims 3 university.
  • KohlErikKohlErik Posts: 11 New Member
    edited July 2014
    Since a few sim days there's been an invisible sim on my lot and it won't leave. I know it's there because sometimes I hear a voice that is neither of my sims voices. I've been looking all around the lot and in the surroundings but I can't find it. I tried to reset all the sims in the town and the lot with mastercontoller and fix invisible sims with debugenabler but it still won't go as I still hear his voice sometimes. It started when my sims went to classes during the second week. I have 4 days left before they leave so I could just live with it and reset the university after I leave, but I'd like to get rid of it. Any solutions?
    (sorry for any mistakes, english's not my main language)
  • KohlErikKohlErik Posts: 11 New Member
    edited July 2014
    Left the uni, problem solved. This was a weird bug.
  • TadOlsonTadOlson Posts: 11,379 Member
    edited August 2014
    I've had this awful bug where the Ul protests were happening in the homeworld and should only be autonomous on campus.I did some experimenting to find a solution for this that would work to solve it for those playing rotational games where they switch between multiple households in one world in the same game and there's something to fix it for the rotational games HERE.
  • LavenderZayLavenderZay Posts: 710 Member
    edited August 2014
    Sometimes, my Sim doesn't carry a laptop with them. Meaning, there is not a laptop in their inventory. This happens to me pretty often.
  • RoseCake64RoseCake64 Posts: 3 New Member
    ‎01-17-2016 11:00 AM
    After leaving University and returning home, my Sim's household does not load. Its says I have no Sims and it says I have no money.

    My Sim's major was Technology. I was there for two terms getting 12 credits. When I was done I had 42 out of 48 which means I did not graduate. The truck picked me up to go home but when the loading screen finally loaded the truck or any of my members in the household weren't there. It said I had $0 and no household members. I tried clicking Edit Town and moving them but it still isn't loading. I also tried switching households but my original household Sim's were still not loading. Another thing I tried was exiting the game without saving, playing everything again, and the result is still my household members are not loading. Has any of this happened to you? If so what do you do to fix it?
  • JessiebrumJessiebrum Posts: 21 Member
    I had a bug that my sims didn't arrive at university and it caused me a lot of hard work, but I finally solved it! I will post here what I've done, cause this topic help me a lot and hope it help someone else
    When I send them to university and the bug happened, I have installed the nraas mod and the oportunity call fix. I tried to send them to travel some WA world, but the UI was missing. So, I've installed the overwatch mod, sell all my family inventory stuff, made my two sims talk a lot, made sure they had a high school diploma in their inventory and it works!
    Sorry for my English but I hope it can help you the same as it help me!
Sign In or Register to comment.
Return to top