October 11 - It's Friday, and that means Friday Highlight is here! Check it out!
October 10 - A new The Sims 4 update is ready for you on Xbox One and PlayStation 4! Details here
October 3 - Patch day for The Sims 4 on PC/Mac! Find the details here.
Playing on macOS Lion (10.7)? Please, read this before updating your game.

Sims 4 Lagging for Absolutely No Reason

Comments

  • rosemowrosemow Posts: 148,849 Member
    @rosemow are bloated saves still an issue?

    Hello @phoebebebe13 Bloated saves can cause issues. Dafadolly has tested with new save games and the issue remains, so it is isn't causing the cause here, but bloated saves can cause problems.
  • phoebebebe13phoebebebe13 Posts: 19,400 Member
    rosemow wrote: »
    @rosemow are bloated saves still an issue?

    Hello @phoebebebe13 Bloated saves can cause issues. Dafadolly has tested with new save games and the issue remains, so it is isn't causing the cause here, but bloated saves can cause problems.

    Ok thanks . Was not sure if I missed anything but you seem to have covered all suggestions
  • dafadollydafadolly Posts: 1,215 Member
    @rosemow @dekay I finished uninstalling and reinstalling and it seems to have helped a little. I started a new save and placed the sim on an empty lot (still haven't added back in my saves, tray, or mods folders) and it's only lagged a few times between 8 and 12pm (sim time) not sure if this will stay or revert back to how it was before, but it's at least playable for me at this level.

    And thank you for responding @phoebebebe13 I haven't tried opening any other game since this problem started. I'm going to try opening another game unrelated to sims and see if it lags too. And then maybe I'll try sims 3 too and see how it works :)

  • phoebebebe13phoebebebe13 Posts: 19,400 Member
    dafadolly wrote: »
    @rosemow @dekay I finished uninstalling and reinstalling and it seems to have helped a little. I started a new save and placed the sim on an empty lot (still haven't added back in my saves, tray, or mods folders) and it's only lagged a few times between 8 and 12pm (sim time) not sure if this will stay or revert back to how it was before, but it's at least playable for me at this level.

    And thank you for responding @phoebebebe13 I haven't tried opening any other game since this problem started. I'm going to try opening another game unrelated to sims and see if it lags too. And then maybe I'll try sims 3 too and see how it works :)

    Is your sims 3 added to your nvidia control panel? You need to add the game to nvidia control panel and use vsync. let me know if you need help doing that but do test other games.
  • rosemowrosemow Posts: 148,849 Member
    dafadolly wrote: »
    @rosemow @dekay I finished uninstalling and reinstalling and it seems to have helped a little. I started a new save and placed the sim on an empty lot (still haven't added back in my saves, tray, or mods folders) and it's only lagged a few times between 8 and 12pm (sim time) not sure if this will stay or revert back to how it was before, but it's at least playable for me at this level.

    And thank you for responding @phoebebebe13 I haven't tried opening any other game since this problem started. I'm going to try opening another game unrelated to sims and see if it lags too. And then maybe I'll try sims 3 too and see how it works :)

    I am glad that the game is playing better now. :) I hope that the lagging issues don't return to how they were,
  • ByondTime89ByondTime89 Posts: 1,505 Member
    I seem to be having the same issue :\ and I've also tried everything you've suggested to the OP and it doesn't seem to help me either. My game was running perfect a month or so ago, then I stopped playing for a while and then recently did a refresh of my computer and then reinstalled Sims 4 and now I seem to be having lag for some reason. So not sure what to do either XD
    Gallery & Origin ID: ByondTime89
  • rosemowrosemow Posts: 148,849 Member
    I seem to be having the same issue :\ and I've also tried everything you've suggested to the OP and it doesn't seem to help me either. My game was running perfect a month or so ago, then I stopped playing for a while and then recently did a refresh of my computer and then reinstalled Sims 4 and now I seem to be having lag for some reason. So not sure what to do either XD

    Hello @ByondTime89
    If you haven't already done so, try doing the following which has helped other simmers .
    SOLUTION:
    Untick: Online Features + Share user data

    Shut down your computer completely. Then restart the computer and see if that helps.

    Move your mods folder to the desktop. Start the game and test to see if that helps.

    Try resetting your sims 4 folder and see if that helps. To do that, move your sims 4 folder ( that is in Documents -Electronic Arts - then the sims 4 folder is there ) to the desktop. Then start the game, and a new sims 4 folder will be generated. Exit the game and then add back the "options.ini" file and the "saves" , "screenshots" "tray" "custom music " and "mods" folders from the desktop sims 4 folder to the new sims 4 folder, replacing the new generated file/ folders with the old file/folders.

    Try switching back to 32 bit mode and see if that helps.
    Right click on The Sims 4 tile in Origin.
    Select “Game Properties”
    Change the “When launching this Game” setting to “The Sims 4 32-bit”

    Try testing with a new save game and seeing if the lagging continues in the new game too.

    Try uninstalling and reinstalling origin.
  • ByondTime89ByondTime89 Posts: 1,505 Member
    @rosemow Thanks, I've done most of those. I don't use mods (so nothing to delete/move there), cleared my cache, tried x32, tried windowed mode, and I've tried reinstalling origin. How do I turn the Online Feature thing off? Where is that at?
    Gallery & Origin ID: ByondTime89
  • phoebebebe13phoebebebe13 Posts: 19,400 Member
    @rosemow Thanks, I've done most of those. I don't use mods (so nothing to delete/move there), cleared my cache, tried x32, tried windowed mode, and I've tried reinstalling origin. How do I turn the Online Feature thing off? Where is that at?

    http://sims4.crinrict.com/en/2014/09/deactivate-origin-in-game/
  • rosemowrosemow Posts: 148,849 Member
    @rosemow Thanks, I've done most of those. I don't use mods (so nothing to delete/move there), cleared my cache, tried x32, tried windowed mode, and I've tried reinstalling origin. How do I turn the Online Feature thing off? Where is that at?

    Hello @ByondTime89 .
    It is in game options, under Other.
    Try turning off :
    Online Notifications , Auto-Reconnect, Share User Data.

  • DeKayDeKay Posts: 52,923 Member
    dafadolly wrote: »
    rosemow dekay I finished uninstalling and reinstalling and it seems to have helped a little. I started a new save and placed the sim on an empty lot (still haven't added back in my saves, tray, or mods folders) and it's only lagged a few times between 8 and 12pm (sim time) not sure if this will stay or revert back to how it was before, but it's at least playable for me at this level.

    And thank you for responding phoebebebe13 I haven't tried opening any other game since this problem started. I'm going to try opening another game unrelated to sims and see if it lags too. And then maybe I'll try sims 3 too and see how it works :)

    Glad to know it's working a bit better now. I just want to check something with you. You said it seems to lag especially when you move your camera around a lot. Some of us have this problem too (including me). There also is an fps drop if you zoom out a bit.

    Can you just go to your test save and open the cheat box (ctrl + shift+ C) and type fps on? At the bottom left hand corner, you will see the framerate. Try to monitor it and when it's lagging, take note of the fps number. For me, it could go down to around 30-40 if I move around a lot but will go back to 60 if I stay still. On zoom out and still, it will be around 40. I just wanted to know how bad your lag is. If it is around mine as well, then I think it's just the game. My game also has a bit of lag at 9pm and 5am when the outdoor lights turn on and off, but I'm not too sure why yours happen between 8am-12pm.
    My origin ID: DeKaythePUNK
    WXoUl2i.gif
  • dafadollydafadolly Posts: 1,215 Member
    @dekay My lag doesn't only happen between those hours, but thats only as long as I tested that specific save. I added back my saves, tray, and mods folder today and loaded up one of my old saves and the lag wasn't as nonexistent as before, but still a tiny bit better (enough so that I didn't drive myself mad trying to deal with the lag). I'm gonna test out to see if one of those folders contributed heavily to the lag, or if maybe it was all of them. It might just have been the fact that it was a full family with tons of history though, and the one I'd previously tested that ran smooth was only 1 sim on an empty lot in a brand new save.

    I'll go back in game and check the fps too! And I'll also try to take note of the time of day it happens and see if there are any patterns.

  • dafadollydafadolly Posts: 1,215 Member
    dafadolly wrote: »
    @rosemow @dekay I finished uninstalling and reinstalling and it seems to have helped a little. I started a new save and placed the sim on an empty lot (still haven't added back in my saves, tray, or mods folders) and it's only lagged a few times between 8 and 12pm (sim time) not sure if this will stay or revert back to how it was before, but it's at least playable for me at this level.

    And thank you for responding @phoebebebe13 I haven't tried opening any other game since this problem started. I'm going to try opening another game unrelated to sims and see if it lags too. And then maybe I'll try sims 3 too and see how it works :)

    Is your sims 3 added to your nvidia control panel? You need to add the game to nvidia control panel and use vsync. let me know if you need help doing that but do test other games.

    Yes I have both ts4.exe and ts4_x64.exe set to use the nvidia card. I have no idea what you mean by using vsync though, could you please explain?

    And I tried to test the only other non-sims game I currently have on my laptop last night and it didn't work. The game is Alice Madness Returns and I haven't played it in over a year and half. I started it up and clicked enter to start the game but it just froze. I had to restart my laptop to get out of it. Not sure if it had to do with the fact that I use windows 10 now, but I'll try the game again. Do you think these issues could be connected?

  • rosemowrosemow Posts: 148,849 Member
    It may be best to start a new game, and place your sims from the other save games in it. Save games that have been played for a while and/or have many sims family relationships in it can become bloated and cause lagging issues. Also having a lot of mods/cc may cause issues too.
  • rosemowrosemow Posts: 148,849 Member
    Also go to Windows Update on your computer, and check to see if your computer is up to date with updates.
  • DeKayDeKay Posts: 52,923 Member
    dafadolly wrote: »
    dafadolly wrote: »
    @rosemow @dekay I finished uninstalling and reinstalling and it seems to have helped a little. I started a new save and placed the sim on an empty lot (still haven't added back in my saves, tray, or mods folders) and it's only lagged a few times between 8 and 12pm (sim time) not sure if this will stay or revert back to how it was before, but it's at least playable for me at this level.

    And thank you for responding @phoebebebe13 I haven't tried opening any other game since this problem started. I'm going to try opening another game unrelated to sims and see if it lags too. And then maybe I'll try sims 3 too and see how it works :)

    Is your sims 3 added to your nvidia control panel? You need to add the game to nvidia control panel and use vsync. let me know if you need help doing that but do test other games.

    Yes I have both ts4.exe and ts4_x64.exe set to use the nvidia card. I have no idea what you mean by using vsync though, could you please explain?

    And I tried to test the only other non-sims game I currently have on my laptop last night and it didn't work. The game is Alice Madness Returns and I haven't played it in over a year and half. I started it up and clicked enter to start the game but it just froze. I had to restart my laptop to get out of it. Not sure if it had to do with the fact that I use windows 10 now, but I'll try the game again. Do you think these issues could be connected?

    Okay, do take note of the fps in your game. :)

    It also sounds like you might have a hardware issue there since your other game didn't open at all.

    Did you upgrade from another OS to Windows 10 or did you do a fresh install? If you upgraded to it, did you download the Windows 10 version of your Nvidia driver?
    My origin ID: DeKaythePUNK
    WXoUl2i.gif
  • dafadollydafadolly Posts: 1,215 Member
    edited March 2016
    @DeKay Alright so I started up a new game and placed the sim on a starter lot. My fps was wild and all over the place but I caught the numbers in general.

    When the game was paused:

    Zoomed in - Around 90 (Extended from 80 to 110 but stuck around 90 the most) It also randomly dropped to the single digits and then stuck around 30 for a little.
    Zoomed out - As I zoomed it out it dropped from 90 down to about 5 and then rose back up to 30 and stuck around there.

    Live mode:
    Averaged out at about 30.30.
    Walking - Stuck at about 20/25.
    Sitting down watching tv - 25/30.
    Just standing there - About 30.30 and would randomly sky rocket to 90 and drop to 15.

    When I would turn the camera it would drop to 20/15 and then go back to 30. It would sometimes hit 5 when I was turning and zooming the camera at the same time (which I do a lot when I play the game).

    The only time the number would stop moving it would be at 30.30 and sometimes 30.40.

    I can test it some more if you need me to!

    Edit: I upgraded from windows 8.1 to windows 10 and had it keep all my old information so I don't think it was a fresh install. I've updated my driver since and I'm pretty sure it said something about it being for windows 10. Should I have done more than this?

    And the game did open. It loaded to the screen that says the name of the game and tells you to press enter to start. After I pressed enter it just froze there for a while. I'm gonna test it again right now to see if it does the same thing.

  • DeKayDeKay Posts: 52,923 Member
    dafadolly wrote: »
    @DeKay Alright so I started up a new game and placed the sim on a starter lot. My fps was wild and all over the place but I caught the numbers in general.

    When the game was paused:

    Zoomed in - Around 90 (Extended from 80 to 110 but stuck around 90 the most) It also randomly dropped to the single digits and then stuck around 30 for a little.
    Zoomed out - As I zoomed it out it dropped from 90 down to about 5 and then rose back up to 30 and stuck around there.

    Live mode:
    Averaged out at about 30.30.
    Walking - Stuck at about 20/25.
    Sitting down watching tv - 25/30.
    Just standing there - About 30.30 and would randomly sky rocket to 90 and drop to 15.

    When I would turn the camera it would drop to 20/15 and then go back to 30. It would sometimes hit 5 when I was turning and zooming the camera at the same time (which I do a lot when I play the game).

    The only time the number would stop moving it would be at 30.30 and sometimes 30.40.

    I can test it some more if you need me to!

    Edit: I upgraded from windows 8.1 to windows 10 and had it keep all my old information so I don't think it was a fresh install. I've updated my driver since and I'm pretty sure it said something about it being for windows 10. Should I have done more than this?

    And the game did open. It loaded to the screen that says the name of the game and tells you to press enter to start. After I pressed enter it just froze there for a while. I'm gonna test it again right now to see if it does the same thing.

    Okay, those fps are really bad. You shouldn't be getting those with your computer specs.

    I didn't upgrade my laptop to Windows 10, I bought one with a clean install of it, so I don't know. But I think yo have to download the Windows 10 version instead of doing a normal update.

    You can download the Windows 10 version here. http://www.nvidia.com/download/driverResults.aspx/86510/#axzz41izHu5YP
    and then update it to the new one. The current version is 362.
    My origin ID: DeKaythePUNK
    WXoUl2i.gif
  • DeKayDeKay Posts: 52,923 Member
    Oh and also turn on V sync in game options. If you turn this on, you won't get 90fps. Maybe that might help.
    My origin ID: DeKaythePUNK
    WXoUl2i.gif
  • dafadollydafadolly Posts: 1,215 Member
    @dekay I did a clean install of that and still nothing has changed. Tried removing the tray, saves, and mods folders one by one and then all together and the game performed exactly the same each time :( fps hasn't changed too. It still sticks around 25/30 and drops to single digits constantly.:(

  • dafadollydafadolly Posts: 1,215 Member
    Just tested the vertical sync. It was already lagging the second it started and kept on :(

  • rosemowrosemow Posts: 148,849 Member
    I am so sorry that you are having this issue :(
    Did you check in Windows Update that your computer is up to date with updates?
    Try clean booting your computer then launching the game, and see if the issues remain.
    http://help.ea.com/en/article/how-to-clean-boot-your-pc/
  • DeKayDeKay Posts: 52,923 Member
    I hope clean booting your computer will help. I really can't think of anything else that could cause the lag. Do you have any other games you could test on?

    If other games are fine, maybe try reinstall the TS4 again. Uninstall it via Windows Programs & Features instead of Origin. And see if that changes anything.
    My origin ID: DeKaythePUNK
    WXoUl2i.gif
  • phoebebebe13phoebebebe13 Posts: 19,400 Member
    edited March 2016
    dafadolly wrote: »
    dafadolly wrote: »
    @rosemow @dekay I finished uninstalling and reinstalling and it seems to have helped a little. I started a new save and placed the sim on an empty lot (still haven't added back in my saves, tray, or mods folders) and it's only lagged a few times between 8 and 12pm (sim time) not sure if this will stay or revert back to how it was before, but it's at least playable for me at this level.

    And thank you for responding @phoebebebe13 I haven't tried opening any other game since this problem started. I'm going to try opening another game unrelated to sims and see if it lags too. And then maybe I'll try sims 3 too and see how it works :)

    Is your sims 3 added to your nvidia control panel? You need to add the game to nvidia control panel and use vsync. let me know if you need help doing that but do test other games.

    Yes I have both ts4.exe and ts4_x64.exe set to use the nvidia card. I have no idea what you mean by using vsync though, could you please explain?

    And I tried to test the only other non-sims game I currently have on my laptop last night and it didn't work. The game is Alice Madness Returns and I haven't played it in over a year and half. I started it up and clicked enter to start the game but it just froze. I had to restart my laptop to get out of it. Not sure if it had to do with the fact that I use windows 10 now, but I'll try the game again. Do you think these issues could be connected?

    This is for the sims 4

    aa03762d-0b8a-48ab-a6cf-9eca2c446f24_zpsr3imjd8n.png

    For the sims 3

    You must be in full sceen for vsync to work

    what patch are you on? 1.69 or 1.67

    If on 1.67 use the TS3w file. If on 1.69 use the ts3.exe file

    add the sims 3 game to your Nvidia control panel. Under 3d settings/program setings click browse to find the TS3w file

    in your Nvidia control panel under 3d settings click add then browse. Then you will be clicking on a bunch of files to get to the TS3W file which runs the game. computer C, to program files X 86 file, to origin games file, to the sims 3 file, to the game file, to the bin file. In the bin file you will find the TS3W file. Add that to control panel and put vsync on adaptive or on if you dont have adaptive. This game must have vsync on or it will run your fps way to high. Also remind yourself every time you have an nvidia card update make sure it does not reset your vsync before playing. Nvidia card updates will also reset your game launcher settings every time.

    make sure lot details is on low due to a patch it causes stutter on high. Keep memories turned off and the store loading in CAS turned off
  • dafadollydafadolly Posts: 1,215 Member
    rosemow wrote: »
    I am so sorry that you are having this issue :(
    Did you check in Windows Update that your computer is up to date with updates?
    Try clean booting your computer then launching the game, and see if the issues remain.
    http://help.ea.com/en/article/how-to-clean-boot-your-pc/

    Checked and my computer had an update so I updated it but after it was finished and I'd started up sims 4, it was still running slow. Same with the clean boot. Neither worked :(
    DeKay wrote: »
    I hope clean booting your computer will help. I really can't think of anything else that could cause the lag. Do you have any other games you could test on?

    If other games are fine, maybe try reinstall the TS4 again. Uninstall it via Windows Programs & Features instead of Origin. And see if that changes anything.

    I'm gonna do this after testing out to see if sims 3 lags too!

    This is for the sims 4

    aa03762d-0b8a-48ab-a6cf-9eca2c446f24_zpsr3imjd8n.png

    For the sims 3

    You must be in full sceen for vsync to work

    what patch are you on? 1.69 or 1.67

    If on 1.67 use the TS3w file. If on 1.69 use the ts3.exe file

    add the sims 3 game to your Nvidia control panel. Under 3d settings/program setings click browse to find the TS3w file

    in your Nvidia control panel under 3d settings click add then browse. Then you will be clicking on a bunch of files to get to the TS3W file which runs the game. computer C, to program files X 86 file, to origin games file, to the sims 3 file, to the game file, to the bin file. In the bin file you will find the TS3W file. Add that to control panel and put vsync on adaptive or on if you dont have adaptive. This game must have vsync on or it will run your fps way to high. Also remind yourself every time you have an nvidia card update make sure it does not reset your vsync before playing. Nvidia card updates will also reset your game launcher settings every time.

    make sure lot details is on low due to a patch it causes stutter on high. Keep memories turned off and the store loading in CAS turned off

    For some reason I don't have the same options as you. Here's what shows up when I do that:

    rjjo5c.png

    I turned off vsync after my most recent test in game... Maybe that's why the adaptive option doesn't show up?

Sign In or Register to comment.
Return to top