The latest update addressed the crashing issue that some of you have been experiencing, Click here to found out more!
November 27 - Everyone ready for the Friday Highlight? It's ready for you here.

Jerky animation after a while?

I've noticed in two of my saves after amassing a high number of friends and having become a vampire for both saves my sims animations start to go a bit jerky.

I'm not sure what's causing it, it doesn't make my game unplayable, doesn't actually lag anything or the like but it's a bit of an eye sore. I tried turning the graphics down to see if that would help but it didn't. Is anyone else noticing this? I've never had my sims make a lot of friends before so I don't know if that's whats causing it or if its happening because they are vampires.

Both saves worked just fine before I had a lot of friends.

Comments

  • West_WindsWest_Winds Posts: 305 Member
    edited October 2010
    It's got to be the friends. I've placed a copy of one of the families into a new town and they don't have jerky animations there. They don't know anyone there. Can anyone help me?
  • lizjordanuklizjordanuk Posts: 219 Member
    edited October 2010
    I had this response from EA. I haven't tried it yet...


    Hello there,

    Thank you for contacting Electronic Arts.

    I'm sorry to hear that you are experiencing technical issues while playing the game. However, in order to resolve it I'm providing some steps that you may try. As you are experiencing lagging issue while running The Sims 3, we recommend trying to run the game in Windowed Mode. While this fix is temporary, it might help resolve most crashing or freezing issues. To run your game in Windowed Mode, follow the steps below:

    * Launch The Sims 3.
    * Click on the '...' blue Options button on the lower left-hand side of the screen.
    * Click on the 'Options' menu item.
    * The 'Graphics' tab should be opened by default.
    * Uncheck the 'Enable Fullscreen Mode' button.
    * Click on the blue Check Mark button on the lower right-hand corner to save changes.
    * Re-start The Sims 3.

    Once you're in Windowed Mode, you can adjust the game's resolution to make the Window smaller or bigger as you see fit. The resolution can be changed from the same 'Graphics' tab location above.

    If you start the game and only see a black screen (and thus can't switch to Windowed Mode from the Options menu), you can force the game to start in Windowed Mode by following the instructions below:

    * Press 'Alt' plus the 'Enter' key on your keyboard.
    * Pressing this combination of keys should toggle Windowed Mode. If pressing 'Alt' plus 'Enter' does not set your game to Windowed Mode, you can proceed to edit the game's settings.
    * From the 'Start' menu on the Windows Taskbar, click on 'My Documents.'
    * Double-click on the 'Electronic Arts' folder.
    * Open 'The Sims 3' folder.
    * Locate the 'Options.ini' file.
    * Right-click on the 'Options.ini' file and select the 'Open with' option.
    * Select 'Notepad' as the application to open the 'Options.ini' file.
    * Search for the line 'fullscreen=1.'
    * Change the value of 'fullscreen' to the number zero: 'fullscreen=0.'
    * Save the changes you made to the 'Options.ini' file.

    Note: If you are prompted to overwrite the file, click 'OK.' Make sure you save the modified 'Options.ini' file to the same location as the original file.
  • West_WindsWest_Winds Posts: 305 Member
    edited October 2010
    Thanks a lot. Tried that suggestion but it's still the same. Hoping they will address this soon. Can't really play the sims this way. Takes the enjoyment out of it.
  • ChrisOldfieldChrisOldfield Posts: 140 Member
    edited November 2010
    I have this issue too. It may not be the friends. It could be like the game Oblivion. If you play the game a while some bug happens in the game. In Oblivion the game runs fine, but if you play it 100+ hours or so the animation starts going very bad. It seems the same thing is happening, after a certain amount of game hours spent the animation goes bad. It seems about 10-20 hours or so...

    I also have a computer that is way, way above the recommended specs. If there is a problem it is NOT the hardware. Not with a custom built $2,000 machine with top of the line parts....and yes, the graphics card is compatible, I checked the list.
  • mofursmofurs Posts: 87 New Member
    edited November 2010
    Having the same problem, Everything was fine yesterday, and now when I load it up animations are jerky. Adjusted all my settings and nothing helped, other saved games are fine. Kinda agree with the first poster I have more friends than ever on my jerky save because of his Stardom/Charisma/Traits and I have played for over a year and never had this problem until now.

    **Update**

    I downloaded a mod called Twallan's Overwatch and it fixed my jerky animation by cleaning my game.
    Post edited by Unknown User on
  • kthickskthicks Posts: 1
    edited November 2010
    I had the same problem too. My game got so bad that it was unplayable. I thought it was because of my system but it turns out, it wasn't my computer at all! After doing some research, I found out that there are many bugs in Late Night. One of the main ones is that the game never deletes the vehicles and they are sitting around town taking up memory. Here's the full explanation and the download link for the mod that fixes this problem.

    http://www.gamespot.com/pc/sim/thesims3latenightexpansionpack/show_msgs.php?topic_id=m-1-57021296&pid=999286&page=0

    Since I've installed the mod, no more stuttering or jerky animation!!! However, a lot of people reported problems with the mod so a suggestion would be to use the mod to delete the cars then get rid of the mod until you need it again. I haven't had any problems with it though.

    I hope this helps!
Sign In or Register to comment.
Return to top