We have a new survey live for you to provide feedback on the new EA forums! Click here to read more.
Forum Announcement, Click Here to Read More From EA_Cade.

Can't build my own spa

For some reason I can't find the spa venue to build my own spa, can someone help me out? Yes, I do have the game pack installed.


  • stilljustme2stilljustme2 Posts: 25,082 Member
    edited July 2015
    Do you have any of the other items in your game?

    It should be the last venue listed on the pull-down menu in Build Mode (where you select venue type etc.). You might need to scroll down a bit.
    Check out my Gallery! Origin ID: justme22
    Fun must be always -- Tomas Hertl (San Jose Sharks hockey player)
  • FizzstixFizzstix Posts: 990 Member
    Not sure what you mean by other items in my game.. but if you mean the other game packs.. etc.. yes, I have all the game packs, expansion pack and stuff packs. I have scrolled all the way down and it isn't there.
  • FizzstixFizzstix Posts: 990 Member
    I do have the cinema mod. I will take it out and see if that fixes it.
  • Java_JoeJava_Joe Posts: 21 Member
    Yeah I was having the same issue as Fizzstix. Apparently there is some conflict with the Cinema mod that removes the Spa venue from the venue options list. I removed the Cinema mod and the Spa venue is now an option, however I am getting a strange "disabled for special venues" errror message now when I attempt to change the venue type while in build mode. Changing the venue type while in neighborhood mode doesn't seem to be an issue.

    Have fun :)!
  • FizzstixFizzstix Posts: 990 Member
    I have removed the cinema mod and have since been able to build my own spa. :) I am not sure about the error that Java_Joe has gotten. I haven't seen that one.
  • Sid1701D9Sid1701D9 Posts: 4,718 Member
    Disabled only appears in venues your current sim is in or they own.
    Sid1701d-"I love my life, live my life and live to play, laugh and have fun."

    "Love will Fight, Love will Win and Love will Survive."
Sign In or Register to comment.
Return to top