❄️ The official gameplay trailer for Snowy Escape just dropped! ❄️ You can watch it here.
October 23 - Everyone ready for the Friday Highlight? It's ready for you here.

@simgurumodsquad: March 26 Patch

2...Next

Comments

  • kampffenhoffkampffenhoff Posts: 149 Member
    I had the mystery baby that can't be seen. I moved my couple into another lot and then moved them back to their original house again. All their furniture was in their inventory and their baby was in the yard fully visible in its bassinet.
  • BerrySim79BerrySim79 Posts: 51 Member
    I really hope that this new patch is out before the first EP is released. I thought that I was tripping when I put my CC back in my game after the update. I didn't update when the patch was first released on the 26th but just updated today/tonight. Maybe I should have continued to wait had I known this was going on. I didn't play the game however to notice if anything else is happening with it but I'm more concerned about the CC and it's categorizing.
  • GoddessKarmaGoddessKarma Posts: 52 Member
    Still no fix for the broken CC??
  • iheartdinosx3iheartdinosx3 Posts: 895 Member
    My CC hasn't messed up since the update. That's weird..
  • phoebebebe13phoebebebe13 Posts: 19,400 Member
    Still no fix for the broken CC??

    You might check the first page of this thread SimGuru posted this

    Update: We have a fix and it will be in the next update. As always, I cannot comment on specifically when this patch will arrive.
  • The1WizzardThe1Wizzard Posts: 1 New Member
    edited April 2015
    Hello fellow simmers.
    There is a fix for this problem but I don't think your going to like it. First some background this problem comes from the new "Get to Work" expansion pack. QA at EA missed a bad package that is clearly marked BETA. Anyway on to the fix. You will need a package editor I use Sins 4 Studio "S4S" works great. You will need to edit all of your custom content the worst are the Tops, Bottoms, Shoes and Hair in each package file you will need to mark the category of occult to human and make sure you change it for each swatch S4S has a button in the category to do this. Once this is done the bad thumbnails will be gone. This will also give you a chance to "FIX" some of your custom content that is not categorized correctly when it was made.
    So from what I see they named this expansion pack correctly so "GET TO WORK" and fix your Costume Content.

    Make sure you clear the thumbnail cache file "localthumbcache.package" when you load after deleting this file is rebuilt and the Thumbnails will show right. Also for those of you who don't seem to have this problem delete the file above and see what happens to your thumbnails once the file is rebuilt.
    Post edited by The1Wizzard on
  • John4626John4626 Posts: 155 Member
    Hello fellow simmers.
    There is a fix for this problem but I don't think your going to like it. First some background this problem comes from the new "Get to Work" expansion pack. QA at EA missed a bad package that is clearly marked BETA. Anyway on to the fix. You will need a package editor I use Sins 4 Studio "S4S" works great. You will need to edit all of your custom content the worst are the Tops, Bottoms, Shoes and Hair in each package file you will need to mark the category of occult to human and make sure you change it for each swatch S4S has a button in the category to do this. Once this is done the bad thumbnails will be gone. This will also give you a chance to "FIX" some of your custom content that is not categorized correctly when it was made.
    So from what I see they named this expansion pack correctly so "GET TO WORK" and fix your Costume Content.

    They already have stated on the first page of this thread that a fix is incoming, so it may be jumping the gun to fix a bunch of content when they plan on releasing a fix for it.
    Banner_zpsa6d528fe.png
  • BerrySim79BerrySim79 Posts: 51 Member
    edited April 2015
    @The1Wizzard With the patch that was released on the 26th of March, caused CC to show up every where. For example: shirt will show up in blouse, Sweater, jacket and etc and the same for the pants. The CC hair is showing up in all; short medium and long hair sections. So picking a hair or a certain shirt and etc all you gotta do is go into one section and pick whatever shirt, hair pants you want. The men can now have a bra and panty category. So not right! With the new EP for some CC (In all categories) it is a thumbnail of alien wear in it's place. So GTW...so far only got messed up thumbnails but the update from the 26th is what caused CC to be all over the place.
  • kampffenhoffkampffenhoff Posts: 149 Member
    Hello fellow simmers.
    There is a fix for this problem but I don't think your going to like it. First some background this problem comes from the new "Get to Work" expansion pack. QA at EA missed a bad package that is clearly marked BETA. Anyway on to the fix. You will need a package editor I use Sins 4 Studio "S4S" works great. You will need to edit all of your custom content the worst are the Tops, Bottoms, Shoes and Hair in each package file you will need to mark the category of occult to human and make sure you change it for each swatch S4S has a button in the category to do this. Once this is done the bad thumbnails will be gone. This will also give you a chance to "FIX" some of your custom content that is not categorized correctly when it was made.
    So from what I see they named this expansion pack correctly so "GET TO WORK" and fix your Costume Content.

    This does not work. My custom content is already categorized as human yet it still has the alien icon.
  • ceejay402ceejay402 Posts: 24,557 Member
    Hello fellow simmers.
    There is a fix for this problem but I don't think your going to like it. First some background this problem comes from the new "Get to Work" expansion pack. QA at EA missed a bad package that is clearly marked BETA. Anyway on to the fix. You will need a package editor I use Sins 4 Studio "S4S" works great. You will need to edit all of your custom content the worst are the Tops, Bottoms, Shoes and Hair in each package file you will need to mark the category of occult to human and make sure you change it for each swatch S4S has a button in the category to do this. Once this is done the bad thumbnails will be gone. This will also give you a chance to "FIX" some of your custom content that is not categorized correctly when it was made.
    So from what I see they named this expansion pack correctly so "GET TO WORK" and fix your Costume Content.

    This does not work. My custom content is already categorized as human yet it still has the alien icon.
    sism4studio has added a fix see orangemittens posting here http://forums.thesims.com/en_US/discussion/825229/why-is-some-of-my-cc-showing-up-as-alien-clothing#latest
  • DarklingDarkling Posts: 6,327 Member
    I just noticed that a patch was released--RL has not been kind lately. :/ I'm sorry if this has been asked and answered already but in the April 13 patch notes SimGuruCoop said that it "fixed a few unintended issues on our side that caused problems with certain types of CAS Custom Content."

    Does this mean that all the CC that was borked by the previous patch has been fixed and is showing up/working properly?
    14785081519_9e388018bc_o.jpg
  • AmiutzaAmiutza Posts: 1,796 Member
    Darkling wrote: »
    I just noticed that a patch was released--RL has not been kind lately. :/ I'm sorry if this has been asked and answered already but in the April 13 patch notes SimGuruCoop said that it "fixed a few unintended issues on our side that caused problems with certain types of CAS Custom Content."

    Does this mean that all the CC that was borked by the previous patch has been fixed and is showing up/working properly?

    Yup, categorization and thumbnails work again.
    hhHD2XB.png
    My tumblr - A world of clutter and color
  • DarklingDarkling Posts: 6,327 Member
    Amiutza wrote: »
    Darkling wrote: »
    I just noticed that a patch was released--RL has not been kind lately. :/ I'm sorry if this has been asked and answered already but in the April 13 patch notes SimGuruCoop said that it "fixed a few unintended issues on our side that caused problems with certain types of CAS Custom Content."

    Does this mean that all the CC that was borked by the previous patch has been fixed and is showing up/working properly?

    Yup, categorization and thumbnails work again.

    Caught this as I was on my way out the door. Looks like I might go ahead and update my game tomorrow once I also track down and update my mods. Thanks for the reply! :)
    14785081519_9e388018bc_o.jpg
  • _A__A_ Posts: 55 Member
    @SimGuruModSquad thanks for fixing this :) There is still a problem however with Full Body CC showing up for aliens even though it is only tagged for humans. This only happens when the high bit is set on the group and instance of the CAS Part resource. Can this be fixed on your end in the next patch? We have started using the high bit again since the last patch was supposed to fix it, but it seems the fix was incomplete.
  • SimGuruModSquadSimGuruModSquad Posts: 597 SimGuru
    Hey guys, sorry for not updating this thread recently. With the release of 1.5.149 on 4/13 I believe we have address the main issues with CC introduced on 1.5.139. Namely, the two big issues fixed were CC being incorrectly categorized in the catalog, and CC thumbnails being generated as aliens if the "Get to Work" EP is installed.

    Please let me know of any other fallout from 1.5.139 that has not been corrected.

    @_A_ We will take a look at the problem you report with Full Body CC showing for aliens even though it is tagged only for humans. If you could provide a sample asset that exhibits the problem, would help ensure we are looking at the exact problem you are reporting.

    Thanks, SGMS
  • _A__A_ Posts: 55 Member
    @SimGuruModSquad
    Here is an example:
    https://www.dropbox.com/s/s8ajf8t756k7qid/AlienBugs.zip?dl=1
    This package was cloned with the latest patch DeltaBuild files. In the zip is one version that sorts correctly (no high bit), and a copy of that same CAS item with the high bit set on the group and instance that erroneously sorts into the alien category even though neither of them are tagged as aliens.

    Thanks for looking into it :)
  • SimGuruModSquadSimGuruModSquad Posts: 597 SimGuru
    OK here's the deal!

    In the current build (1.5.149) it is indeed working as you have described.

    In the NEXT patch, the determination of availability of a CAS part for occults has changed, as follows:
    • We have bumped the CASP (0x034AEECB) resource to version 31.
    • Any CASP resources with less than version 31 will automatically be available for all occult types (i.e. Humans and Aliens), regardless of tags. Also the high bit will no longer have any impact on availability.
    • Occult tags will now only be used to determine if the part should appear for that occult type when randomizing.
    • There is a new bitfield in the CASP resource that allows you to disable the part for specific occults.

    A new BT file will be provided when the patch is released. As always I cannot comment as to when this patch will arrive. Sorry for the churn, the addition of occults required some big changes.

    -SGMS
  • _A__A_ Posts: 55 Member
    Thanks @SimGuruModSquad. That will give us some viable options that don't involve renumbering which is always good.
  • SimGuruModSquadSimGuruModSquad Posts: 597 SimGuru
    Hi there. The new patch has been released, and BT file posted here.
  • _A__A_ Posts: 55 Member
    Thanks @SimGuruModSquad. I've updated my code to the new specifications and will let you know if any other unintentional side effects are discovered.
Sign In or Register to comment.
Return to top