August 19th- It's time for our Friday Highlights! You can check them out here!

Issues With Store Content

Hi, everyone!
So, I'm trying to play Sims 3 on my Mac (obviously). I'm on a MacBook Pro (14-inch, 2021) and can give more specs if needed.
My issue is the game won't load if I have my store content installed. It loads just fine without the content; I can demonstrate this by moving the DCBackup and DCCache files out of the The Sims 3 folder. But whenever I install my content, the game just shows a blank white screen while the loading cursor (the rainbow one) spins. At first I thought it might be CC, but I removed all CC from my Downloads folder and haven't reinstalled any of it, but the issue still happens whenever I try the game with my store content. (And to be clear, the content is all downloaded directly from the store into the launcher).
The weird thing is that the game was loading with my store content yesterday, but nothing in the Downloads folder has changed since then. Nonetheless, even if I remove my Mods folder and my Saves and everything else, the game won't load if I have my store content installed.

Comments

  • puzzlezaddictpuzzlezaddict Posts: 1,861 Member
    If you install one new store item, does the game work? If it doesn't, please try in a clean folder as well, as in, move the entire Sims 3 folder to the desktop and open the launcher to create a new one.

    Another possible cause is iCloud Drive, specifically if it syncs your Documents folder with cloud storage. If it does, try disabling that function: open System Preferences > Apple ID, click Options next to iCloud Drive, and uncheck the box next to Desktop & Documents folders. You may then need to redownload the Sims 3 folder from cloud storage, so if you don't want to deal with that, make a copy of it and drop it in Downloads before starting. That folder doesn't get synced.
  • cooldood555cooldood555 Posts: 82 Member
    I'd already tried a clean folder, and it works fine. I then put my mods and saves and saved Sims back in and it worked fine. It wasn't until I put the Downloads folder back and installed the items that it stopped working. I also don't have iCloud Drive active.

    Per your suggestion, I tried installing just one store item and the game loaded! So that likely means one of the store items itself. I tried emptying my Downloads folder, redownloading all the items from the store, then installing them, but the game wouldn't load after that, so I guess I'll have to go one-by-one until the game won't load, then delete the problem file.
Sign In or Register to comment.
Return to top