September 18 - Everyone ready for the Friday Highlight? It's ready for you here!

The Sims 4 stuck on loading screen...Xbox One

Well, I played the Sims 4 on my Xbox earlier today and it was fine. I saved and exited. I am trying to play again and it is stuck on loading. The title screen comes up fine. I press "A" on my controller to start. I choose my gamertag and the progress bar starts and then just stops and hangs. I have tried deleting the reserved space. I have done a hard restart (shutting down by button, unplugging, waiting 30 seconds and restarting). I have even deleted my saved data and let it sync with cloud save. Nothing is working.

Has anyone experienced this or is any experiencing this today?

Comments

  • Rhi_TheDino04Rhi_TheDino04 Posts: 1 New Member
    Ah me as well. Mine won’t load to even half the bar:(
  • KorglyKorgly Posts: 33 Member
    in the same boat.. must be something with the cloud saves today : / game loads to 25%.. tried hard reset and reinstalled the game
  • KorglyKorgly Posts: 33 Member
    well after about 15 min of waiting my game finally loaded after many restarts.. wondering if the op is just experiencing really long loading times aswell? I added some dlc sims to my world earlier..
  • RouensimsRouensims Posts: 2,359 Member
    My game just got stuck on the loading screen between Batuu worlds.
    Ooh Be Gah!! Whipna Choba-Dog? Whipna Choba-Dog!! :smiley:
  • YamsisimsYamsisims Posts: 80 Member
    I saw on EA Answer HQ that Sims 4 players were reporting this yesterday also. They said when they took their network connection offline that it loaded. Appeared to be something with Xbox Live was the consensus. I haven't tried this morning yet.
  • KorglyKorgly Posts: 33 Member
    yah It is back to working normal today and definitly was just a hiccup.. now back to just the normal bugs
  • eternalrainneternalrainn Posts: 100 Member
    Also for anyone experiencing this in the future, I was told (Xbox One S) that cold starts of the console can cause this. I used to have to reload it twice before it would fully load in to the DLC menu. I just wait a few minutes now to start the game and it's worked so far.
Sign In or Register to comment.
Return to top