July 3 - No Friday without a Friday Highlight! Find this week's highlighted discussions here.
June 27 - Let's pick our Best of Simming for June 2020!

WHAT IS HAPPENING HERE!??!?! help!

Sorry for the dramatic subject line, but this is serious (by simmers standards lol) What is happening? I put my sims retail store right in the middle where that container home used to be in Port Promise. This keeps happening everytime I send my sim back to his retail store. The game in itself still works fine but the neighborhood is completely glitched out! I even left the game and went back in. Still happening! HELP!!


1HnDBpa.png

Ix6uqml.png

Comments

  • SimmerGeorgeSimmerGeorge Posts: 476 Member
    If this is also happening with mods disabled a would report it in AnswersHQ
    Where's my Sims 5 squad at?
  • LaBlue0314LaBlue0314 Posts: 16,871 Member
    I have also seen this happen in my game in the town that comes with ECO. Also mod free at the time.
  • aaronrulzaaronrulz Posts: 3,624 Member
    Everything was working fine. It was so sudden. I removed a recent mod I put in assuming that was the issue but it wasn't. I wonder if it has anything to do with it being a retail lot?
  • DoloresGreyDoloresGrey Posts: 2,506 Member
    edited June 28
    Wow. It is disturbing. Looking at it gives me a weird feeling... Almost like anxiety.
    Have you tried repairing your game?
  • LaBlue0314LaBlue0314 Posts: 16,871 Member
    It does not have anything to do with being a retail lot, because when I saw it I was playing a residental lot, in that location.
  • SimmerGeorgeSimmerGeorge Posts: 476 Member
    You guys should really report this ASAP.
    Where's my Sims 5 squad at?
  • catloverplayercatloverplayer Posts: 86,681 Member
    I've had this happen in Glenbrook on a residential lot but fortunately it fixed it when I restarted my pc.

  • RedShoe7RedShoe7 Posts: 119 Member
    I saw images like this posted to the forum when the pack first came out. I can't remember what reason was given for this happening. You might want to see if you can find the post and definitely go to Answers HQ.
  • logionlogion Posts: 1,180 Member
    edited June 28
    Hopefully you have made backup saves.

    This reminds me of the errors that they posted about when you tried to modify the apartments in Evergreen Harbor, things could glitch out. If that's the case, then you probably have to load an older save.

    I'm just guessing here, but it looks like the game thinks that your lot is placed lower in the world as intended as the textures from the ground are invisible which they are if you are looking at them from another view like below. Perhaps the lot where the store was created was not even and somehow the game placed the lot below the world? What happens if you bulldoze the lot? Including the ground?

    I would try placing that store in another world where the ground looks even, save it, and then try and place it back in Evergreen Harbor again.

    It could also be an LOD issue (but I don't think it is), do you have any build/buy cc on that lot?
  • kusurusukusurusu Posts: 658 Member
    And the terrain didn't come back after some time?
    Super Sim Sona Ali now available on the Gallery (same ID) and on MTS
  • aaronrulzaaronrulz Posts: 3,624 Member
    @logion no, I don't use build/buy mode cc except bunk beds but they aren't on the lot. I wanted the store in Port Promise so my sims can dumpster dive in the two dumpsters in the world. yup, I save! Honestly, I'm not too attached to this particular save any more so if I lost it, I wouldn't even be that upset. Imagine running a retail store when you have 4 kids at home. It's maddening! lol

    @kusurusu nope, it didn't. I'm going to load up my game this morning and see what's happening
  • aaronrulzaaronrulz Posts: 3,624 Member
    RedShoe7 wrote: »
    I saw images like this posted to the forum when the pack first came out. I can't remember what reason was given for this happening. You might want to see if you can find the post and definitely go to Answers HQ.

    trying to find but I don't know what words to put in the search bar. lol. Someone else could have explained it differently
  • aaronrulzaaronrulz Posts: 3,624 Member
    edited June 29
    I am convinced now this is a retail lot issue. Port Promise looks completely normal until I "open for business" and then it will glitch out just like the pictures I posted in the first post. This happened three times after returning to the home lot and back to the retail lot. I'm going to move my sims store to Magnolia Promenade. This is a bummer because I wanted to be near the garbage dumpsters because my sim always goes diving after a work shift to acquire more items because they fill up. But it's fine.
  • DOLLDRMS1DOLLDRMS1 Posts: 2,910 Member
    @aaronrulz Did you have the Modern Development N.A.P. enacted? There is a bug report on AHQ you can read and see if it applies to your experience: https://answers.ea.com/t5/Bug-Reports/NEEDS-INPUT-ECO-GTW-CD-DO-Business-breaks-Lot-with-Modern/td-p/9183079

    If you think you were a victim of the same problem, it would be good if you could take the time to at least click the "me too" button. Not many have indicated they have also had the problem and I always feel the bugs complained about the most get some priority for fixes.

    For now, it seems that the Modern Development and possibly a Green Initiative that would create the overlay to appear should be avoided in an Evergreen Harbor neighborhood where one wants to place retail, restaurant or vet clinic.
  • aaronrulzaaronrulz Posts: 3,624 Member
    Thanks @DOLLDRMS1 , yes I cheated the Modern Development. I clicked "me too"! I moved my store to magnola promenade and i'm all good. It's a little laggy though but nothing too terrible. My game usually doesn't lag.
Sign In or Register to comment.
Return to top