December 6 - It's Friday. What does it mean in The Sims forums? Time to highlight some awesim discussions!
December 5 - It's patch day for The Sims 4 on console! Read the patch notes here.

Fresh install; game does not produce documents folder; game unplayable

2...Next

Comments

  • FirandeFirande Posts: 725 Member
    Hi there. I recently changed my default installation folder to my D drive and re-installed TS4 on there, and I've had no issues - I forgot to delete the Documents TS4 folder, but then when I launched the game it actually launched with all of my stuff right back on, so it still uses the C/Documents folder for the save files and screenshots and all that jazz, but it uses the D/Program Files for the game files itself.

    When I go to Origin's Application Settings, I see two settings: one is the general game library location. The other is the "legacy game installers." I'd assume you have looked at this already but since I haven't seen it mentioned yet, I thought I would just to be sure.

    klxrEwe.png
    My game library location is changed to my D drive; however, I kept the legacy game installers at the default, which has this location. It would seem that older games have different rules to go with installation, so that's probably why you're experiencing these issues with TS2 and not TS3 and TS4.

    One person suggested removing the TM. They specifically said to do this while you have the game uninstalled - from your response, I was a bit worried you did this while you had the game installed and that's why it wouldn't have been able to launch anymore. But I do see that you tried again and again with completely uninstalling the game, so hmm... You said you tried to move the folder that somehow ended up in C/documents to Program Files manually. This is honestly something I'd try as well hehe. Have you tried this again when after a completely clean install it still didn't work?

    This probably goes without saying but I figure I'd say it anyway just to be entirely sure hehe, but I just thought I'd do a rundown here. You have tried tackling this issue in a lot of different ways. Have you tried just taking a deep breath, completely uninstalling the game, using CC Cleaner to uninstall each and every remaining TS2 file, and then, with everything absolutely gone and uninstalled, have you gone into Origin's Application Settings and changed the locations for both the game installer and the legacy game installer to the defaults (the legacy one being the one shown here in my picture)? Then, with everything uninstalled and the game installations in the right folders, reinstall TS2 completely. Open the game immediately when it's done re-installing and save it so that it generates a TS2 folder in Documents. Idk how it is with TS2, but I know TS4 will only generate a folder in Documents after you've launched the game for a first time and saved a save file. I'd assume you have launched the game after every install to see about those neighborhoods, but I'm just being absolutely sure here. :sweat_smile:
    Origin ID: Fierande | Simlit | Tumblr

    fgQIHTb.png
  • thesimmer14thesimmer14 Posts: 231 Member
    edited October 16
    Hey! I took a break from this for a few days.
    On the 14th, I opened up my C/Docs folder to see an EA Games folder magically appear! However... it is incomplete.

    iH3cZ9Z.png

    Starting the game didn't generate the other files, either. So, it's there, but it's not giving me the files I need to produce hoods.


    @Firande I didn't try that. I could, but honestly I'm afraid to touch the sacred scrap of half-baked folder I was magically granted. :D
  • thesimmer14thesimmer14 Posts: 231 Member
    Took a break, but am back to this.


    Could someone please inform me:

    1. if TS2 generates the EA Games folder BEFORE the first launch, or AFTER the first launch
    2. how big the EA Games folder is by default?

    I noticed I'd been getting the "you are running low on disk space and may encounter problems with the game" during launch. I have 3.42 GB free on the disk it's installed, so I figured, "3 GB is enough space for a Docs folder to generate, right? This game is from 2004 anyways, so I don't think the size requirement would be more than that."

    @Rflong7 since you have it installed [I assume], do you mind lending me some info about the size of your folder?
  • Seera1024Seera1024 Posts: 3,364 Member
    Not Rflong7, but I just generated a brand new Sims 2 folder and it is 867 MB on my computer. I have The Sims 2 Ultimate Collection installed on the computer.
  • thesimmer14thesimmer14 Posts: 231 Member
    Whoa! It's been a while since I tackled this, but I found out what was causing the issue.
    For future reference, in case anyone else has a similar issue: My system was set to a different locale, which prevented the game from generating. Switching it back to United States helped. (:
Sign In or Register to comment.
Return to top