September 20 - Friday Highlight is here! Check it out!
September 17 - We just released a small patch for The Sims 4 on PC/Mac - click here for more details.

Fresh install; game does not produce documents folder; game unplayable

thesimmer14thesimmer14 Posts: 193 Member
Hello!

This is my third time installing TS2 UC on my PC. I installed it several years ago on my C drive, then uninstalled it to free up space. Last week, I installed it again on my D drive. However I learned the game was not built to handle multiple drives, so it didn't generate a Documents folder.

Then, I uninstalled the game, and installed it back to my C drive under the assumption it'd produce one there. I ran into the same issue I had when it was installed under my D/; drive.
The game boots perfectly fine, however, the main menu does not display any hoods.

YRNhXTf.png

ehMLoev.png

Help would be appreciated. :)

Comments

  • EllupelluelluEllupelluellu Posts: 71 Member
    Only thing that comes to my mind this fast is, did you make sure all the junk was removed after you uninstalled the game from your D drive?

    I have had mine always at C, and I have had the EA games folder in My Documents every time. BUT it is been known that even after uninstaller, it sometimes does not delete all registery entries from previous installation well.
  • thesimmer14thesimmer14 Posts: 193 Member
    Err, yeah. That's probably it ^^;

    How do you remove the registry entries?
  • NoogsterNoogster Posts: 621 Member
    edited September 8
    How do you remove the registry entries?

    Hi there, sorry for bumping this but I see you haven't gotten an answer.

    You'll want to click 'Start' on your taskbar and search for 'run' and when open, type in regedit, confirm the administrative permissions, and your registry (editor) will open. The pathway you may find the files are in Computer\HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\EA GAMES

    If you're running TS2 Ultimate Collection, I think the pathway will be similar to Computer\HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Origin or \Origin Games

    A reason for the game not producing a new documents folder is likely because of there being duplicates, or if you're on The Sims 2 Ultimate Collection has the trademark in the title. I would personally recommend deleting all instances of The Sims 2 (with the game uninstalled), or possibly perform a repair in Origin and try to start the game again and see if it persists.

    I can't really explain it, but if the TM symbol is the case, you can check out one of the replies from this thread
    JULES1111 wrote: »
    Go to "Run" or press Windows + R then type "regedit" and open HKEY_LOCAL_MACHINE and then select SOFTWARE

    For 32-Bit: Find "EA GAMES" folder and open "the sims 2" double-click on the Display Name then you will see the pop-up. Delete "™" from Value Data text field and the problem will solved.

    For 64-Bit: Open "Wow6432Node" then Find "EA GAMES" folder and open "the sims 2" double-click the Display Name then you will see the pop-up. Delete "™" from Value Data text field and the problem will solved. The Sims 2 "tm" Ultimate Collection Is listed on the right hand side next to display name, after opening the Sims 2.

    I hope I could help. :)

  • thesimmer14thesimmer14 Posts: 193 Member
    Thank you! I'm going to try this later. :)
  • EllupelluelluEllupelluellu Posts: 71 Member
    @thesimmer14
    Ouch, sorry, I simply did not got any notification that you answered untill now , after @Noogster replied. But yes just as they said. :)
  • mandyssims93mandyssims93 Posts: 79 Member
    Thanks, this helped me too. :)
    Casual player :)
Sign In or Register to comment.
Return to top