January 18 - Friday Highlight is here, waiting for you to check it out!

Sims 2 Won't Load My SavedSims

So I got a new PC, finally installed everything, mods are there etc. but My saveSims ain't! I do a sims series on youtube I wanted to get back into is why I'm very upset I can't get them to come up! I have 2 back ups on my harddrives! but when I move the neighborhood folder to new one and load game it just does not come up at all!

any other ideas! I have tried a few! deleted and re added folder etc. but still nothing!

Comments

  • EvermoreRocksEvermoreRocks Posts: 83 Member
    EDIT: I got it to show up in game, but keeps crashing every time I try to load it! is it because I got windows 10? I don't have the ultimate collection because origin wouldn't give it to me.
  • ClassicalSimClassicalSim Posts: 1,449 Member
    Here's a thread with links that might help. Others with windows 10 have said it works. I have Win 8 instead of 10, but this worked for me too.

    https://forums.thesims.com/en_US/discussion/882846/installing-the-sims-2-on-windows-10/p1

  • StormkeepStormkeep Posts: 5,024 Member
    edited January 2
    Just reinstalled TS2 on Windows 10 myself last week and had similiar problems at first, @EvermoreRocks. I did get it to work properly after a day of google searching and trying various ideas of my own though, so keep at it!

    I have an nvidia card, which also has various other problems that I had to work out. But here are some things that ultimately ended up working for me (I have played for 6 hours non-stop without an issue since I did these things):
    • Getting the graphicsrules files set up correctly is the first step, for sure: https://www.simsnetwork.com/tools/graphics-rules-maker
    • Adding the correct Cpu count to the sims 2 executable. Whichever exe file that is used to launch the game, in windows go to properties and add this to the end of the Target where x is how many cpu cores you have: --CPUCount:x
    • For the above, I saw forum posts where people suggested using 1 regardless of actual CPUs...But I just used my actual number of cores.
    • If you want to run in windowed mode, also add -w the the command line for it.
    • Still in the properties for the sims program, under Compatibility, select "Change High DPI Settings" and at the bottom click to Override High DPI Scaling behaviour and select to have scaling performed by "System: Enhanced"
    • If you have the shadow issue where sim shadows look like blocks, download and install this mod: http://modthesims.info/d/569585/sim-shadow-fix-updated-2-jan-16.html

    Quite a few google searches also suggested setting the game to run in Vista SP 2 compatibility mode, but for me that made NO difference, so I am not running with any other compatibility settings besides the one I indicated. Ymmv; you may want to try the Vista SP2 setting and see if it helps you.

    Last thing I did, which may or may not have made a difference (I did it so the game looked better) was to get Reshade working with the game by following these instructions: https://www.moresims2tales.com/2018/getting-reshade-to-work-in-sims-2-uc/

    Good luck, I hope you have as much luck as I eventually did getting the game to work well. It plum...it took hours...but I did get it.
    This post will be edited by StormKeep at some point.
    tumblr_nasnc4uUHi1tkpp11o1_500.png
    The Winters family Chronicle
Sign In or Register to comment.
Return to top