Friday Highlights for November 17th are here! Head over here to check them out!
November 13 - It's Patch Day for The Sims 4 on PC/MAC Patch notes here.

Help with frame rate and screen tearing

My question is about the Sims Medieval, but since its similar to the Sims 3 hopefully someone can help. When I play my game my fps is over 200. I tried to cap it with the NVIDIA control panel, but it doesn't work. I managed to cap it at 60 with Rivatuner, but now I get awful screen tearing. I don't get screen tearing if I don't limit my fps. But I think its bad to let my fps get over 200 all the time. I've also tried playing in windowed mode and the screen tearing is still happening. I want to play my game, but I can't with the screen tearing. Can someone help?

Comments

  • igazorigazor Posts: 16,205 Member
    Which graphics card do you have? Some of them are more stubborn than others to get capped. If this happens to be a laptop with dual graphics, are you certain that the game is using the Nvidia one and not integrated?

    If you are using the GeForce Experience program, be sure not to "optimize" the settings, this can make a mess on older games and can get in the way of fps capping. The option can be undone if it's already invoked.

    I use Rivatuner also (on an AMD card), but the usual tool to add in if the Nvidia Control Panel is not going to work alone is Nvidia Inspector and explicitly set its frame cap to 60. Also try 59 or 61 to see if those help (this is assuming a 60 Hz monitor/screen, that's pretty standard but some of them can run higher).
    786acphb0viikee4g.jpg
    NRaas has moved!
    Our new site at http://nraas.net is not yet fully operational, please have patience with us.
  • Evie0602Evie0602 Posts: 463 Member
    My graphics card is Nvidia GTX 1050 ti and I've checked that the game is using the right card. How do I know if I optimized the settings in Geforce Experience? I don't think I did that, but I'm not sure.

    I didn't use Nvidia inspector because I got confused about which one I was supposed to download.
  • igazorigazor Posts: 16,205 Member
    That would be this one, I believe.
    https://www.guru3d.com/files-details/nvidia-profile-inspector-download.html

    On the GeForce Experience optimization question, this post (under the Spoiler) shows where to look and what to undo ("Revert") if it's done.
    https://forums.thesims.com/en_US/discussion/comment/16167888/#Comment_16167888
    786acphb0viikee4g.jpg
    NRaas has moved!
    Our new site at http://nraas.net is not yet fully operational, please have patience with us.
  • Evie0602Evie0602 Posts: 463 Member
    @igazor I tried using nvidia inspector instead of rivatuner. I downloaded it, but there was no option for the sims medieval. So I went under the sims 3 and set vertical sync to "force on", but it didn't help to cap the frame rate probably because its not the same game.
    Also I checked and none of my games have been optimized with geforce experience.
  • igazorigazor Posts: 16,205 Member
    Evie0602 wrote: »
    @igazor I tried using nvidia inspector instead of rivatuner. I downloaded it, but there was no option for the sims medieval. So I went under the sims 3 and set vertical sync to "force on", but it didn't help to cap the frame rate probably because its not the same game.
    Also I checked and none of my games have been optimized with geforce experience.
    On Inspector, as with RTSS, you have to explicitly set the frame cap to 60 as well. Am flying blind here though because my card is AMD.

    @SimplyJen - Do you see the executable for TSM listed along with those for TS3 on Inspector? Or any other suggestions on the screen tearing?
    786acphb0viikee4g.jpg
    NRaas has moved!
    Our new site at http://nraas.net is not yet fully operational, please have patience with us.
  • Evie0602Evie0602 Posts: 463 Member
    I can't find an option to set it at 60. I just tried playing the sims 3 though, and I have the same problem where my fps is over 200. So I guess nvidia inspector doesn't work for me at all.
  • igazorigazor Posts: 16,205 Member
    edited September 13
    Look under the second spoiler in this post.
    https://forums.thesims.com/en_US/discussion/comment/16122442/#Comment_16122442

    The setting in Inspector is the first one on top in Section 2, Sync and Refresh, and it's called Frame Rate Limiter. You may not be able to set it to 60 exactly, so try 58.8 or whatever you see that is close to 60, if you can find the setting.
    786acphb0viikee4g.jpg
    NRaas has moved!
    Our new site at http://nraas.net is not yet fully operational, please have patience with us.
  • Evie0602Evie0602 Posts: 463 Member
    I changed it to 60 and I also changed vertical sync tear control to adaptive. Now the sims 3 mostly works. It's capped at 60 and there's only a small line at the bottom of my screen that goes weird when I move the camera, but I think I can live with it like that. The sims medieval still doesn't work though. And that's the game I really want to play :(
  • igazorigazor Posts: 16,205 Member
    edited September 14
    Can you try making the same settings changes to the Global Base Profile on Inspector since you cannot get TSM to show up as a profile option? Sorry, am flying blind on this one as I don't have Nvidia or TSM installed myself but am surprised there is no way to "Browse" to an app that isn't pre-listed on the pulldown menu, most of these apps have that function. If that's not the right answer, there must be a button or function that will allow you to add the TSM executable, again by browsing to it, to the TS3 profile you created. Or to create a new profile and add TSM to that. (TSM = The Sims Medieval)

    The next tool to try if this isn't going to work out is RivaTuner Stats Server (RTSS) but you already tried that one first.

    As for the line/tear at the bottom of the screen, does this now happen in both full screen and windowed? If windowed works out better for either game, you may want to try Windowed Borderless Gaming as it helps mitigate Win 10 specific issues that keep getting in the way for many who get these.
    https://westechsolutions.net/sites/WindowedBorderlessGaming
    786acphb0viikee4g.jpg
    NRaas has moved!
    Our new site at http://nraas.net is not yet fully operational, please have patience with us.
  • Evie0602Evie0602 Posts: 463 Member
    Changing the base profile worked! The frame rate is capped now on both games. I'm still getting a little bit of screen tearing in the sims medieval, but it goes away in windowed mode. I'm trying to use windowed borderless gaming because I don't like how windowed mode looks, but when I try to add the sims medieval, it says that it can't be added. Is there any other way to make windowed mode look like it's full screen?
  • igazorigazor Posts: 16,205 Member
    Seems surprising that you can't add TSM to Windowed Borderless. Maybe a post on the Windowed Borderless forum board might help find someone who knows why and if something can be adjusted to allow it.
    786acphb0viikee4g.jpg
    NRaas has moved!
    Our new site at http://nraas.net is not yet fully operational, please have patience with us.
  • Evie0602Evie0602 Posts: 463 Member
    Thank you for all of your help. :) Everything is working now and I can play my game again.
Sign In or Register to comment.
Return to top