Friday Highlights for August 17th are here! Head over here to check them out!
August 16 - It's Patch Day for The Sims 4 on PC/MAC Patch notes here.

Solved

NeyMessiNeyMessi Posts: 33 Member
Hey all,

I bought Sims Medieval a couple years ago, probably around 2015 or 2016. I haven't played it in quite some time & decided I wanted to play today. However, I started up the game, it updated, erased my files with the update (which is fine by me, I was going to start on a clean slate anyway), and hit play. When I hit play, nothing happens. The game doesn't load and when I click play again, it says it is already running. The screen for the game tells me it can't connect to the page, but I have Internet and am posting this on the same computer. On Task Manager, it doesn't appear as an App, but as a Background Process.

I really want to be able to play this game again. Can anyone help?

My computer is Windows 10 and the game is a CD, not purchased through Origin.

Thanks!


My boyfriend fixed it.
Post edited by NeyMessi on
tumblr_njb7xiN4R21th8zu1o1_250.gif

Comments

  • CinebarCinebar Posts: 28,584 Member
    It might help others if you can maybe explain how he fixed it or was it Origin? Especially since you have Windows 10. Happy you can play! I really loved TSM.
    "Games Are Not The Place To Tell Stories, Games Are Meant To Let People Tell Their Own Stories"...Will Wright.

    TS4 without Terrian Tools is like Windows 8 or 10 without the Start Menu.


  • SimburianSimburian Posts: 2,742 Member
    Cinebar wrote: »
    It might help others if you can maybe explain how he fixed it or was it Origin? Especially since you have Windows 10. Happy you can play! I really loved TSM.

    If I were the boyfriend I wouldn't explain, just wallow on the glory of being indispensable!
  • NeyMessiNeyMessi Posts: 33 Member
    I'll edit this comment later with how he did it.
    tumblr_njb7xiN4R21th8zu1o1_250.gif
Sign In or Register to comment.
Return to top