January 8 - Is everyone ready for the Friday Highlights? Check them out here.
Welcome to all new Simmers joining us over the holiday season! 🎉 Have fun on the forum and please make sure you check out the forum rules and
the rules about necroposting.
December 22 - It's the time of year again: Join the 12 Days of Simsmas! 🎄

Sims 3 Dark screen while in full screen

Does anyone know how to fix dark screen issues with the sims 3, this only happens when the game is in full screen it does not happen when the game is in window mode, this never happened with my old laptop so im not really sure what is causing it. Here are some screenshots are what it looks like in full screen compared to window mode.[img][/img]24piijs.jpg
[img][/img]2jac3h5.jpg

Comments

  • SimplyJenSimplyJen Posts: 13,833 Member
    Are you running the game in compatibility mode? If so, try turning it off then launch the game to see if it's worked.
    Formerly known as Simasaurus09

    i7-7700K • 16GB • GTX 1070
    S3 simblr: http://simplysimming.tumblr.com/
    S4 simblr: http://simlogic.tumblr.com/
  • phoebebebe13phoebebebe13 Posts: 19,400 Member
    You don't have full screen mode enabled in the launcher. You also have the wrong resolution. It should read 1080p and screen refresh rate should be set at 60 hz
  • Christopher69BChristopher69B Posts: 159 Member
    SimplyJen wrote: »
    Are you running the game in compatibility mode? If so, try turning it off then launch the game to see if it's worked.

    Just tried turning it off but it’s made no difference is still dark while it’s on full screen.
  • Christopher69BChristopher69B Posts: 159 Member
    You don't have full screen mode enabled in the launcher. You also have the wrong resolution. It should read 1080p and screen refresh rate should be set at 60 hz

    Even with it set to 1080p and 60hz it’s still dark when it’s in full screen, it doesn’t do this when it’s in window mode. [img][/img]ojdy4k.jpg

  • phoebebebe13phoebebebe13 Posts: 19,400 Member
    Have you checked that your actual computer is set at 1080 and lighter? I don't know if this is a windows 10 issue. I don't have windows 10.
  • Christopher69BChristopher69B Posts: 159 Member
    Have you checked that your actual computer is set at 1080 and lighter? I don't know if this is a windows 10 issue. I don't have windows 10.

    I’ve just checked that, it says my resolution is set to 1920x 1080 on the display settings.
  • phoebebebe13phoebebebe13 Posts: 19,400 Member
    @igazor any ideas? Thanks
  • Christopher69BChristopher69B Posts: 159 Member
    @igazor any ideas? Thanks

    I also never had this issue on my old computer and that was also windows 10, so not really sure why it’s doing it on this one.

  • SimplyJenSimplyJen Posts: 13,833 Member
    Make sure you completely quit the game before turning off compatibility mode then launch the game again.

    I know you said it didn't work but it's important that the game is not running when you make the change. It seems an Origin update caused this for TV users.
    Formerly known as Simasaurus09

    i7-7700K • 16GB • GTX 1070
    S3 simblr: http://simplysimming.tumblr.com/
    S4 simblr: http://simlogic.tumblr.com/
  • Christopher69BChristopher69B Posts: 159 Member
    SimplyJen wrote: »
    Make sure you completely quit the game before turning off compatibility mode then launch the game again.

    I know you said it didn't work but it's important that the game is not running when you make the change. It seems an Origin update caused this for TV users.


    The game wasn’t running when I turned it off, I launched the game after turning it off. I don’t play the game on Origin I play it on steam so I know Orgin wouldn’t be the problem.
  • phoebebebe13phoebebebe13 Posts: 19,400 Member
    SimplyJen wrote: »
    Make sure you completely quit the game before turning off compatibility mode then launch the game again.

    I know you said it didn't work but it's important that the game is not running when you make the change. It seems an Origin update caused this for TV users.


    The game wasn’t running when I turned it off, I launched the game after turning it off. I don’t play the game on Origin I play it on steam so I know Orgin wouldn’t be the problem.

    When you changed your game settings to 1080p full screen 60 hz, Did you quit the game and restart it after? Also go into the game and change options in game, not in the initial launcher.
  • igazorigazor Posts: 18,838 Member
    edited June 2018
    1 - This is a laptop? Sorry, I'm straining to see the system tray icons in one of the screenshots, but by any chance is it running on battery when this happens or does that not make any difference?

    2 - More likely though, this is a recent Win 10 Creators Update related thing. One way to get relief from what I've read is to always be in Windowed Mode but use the Widowed Borderless Gaming app.
    https://steamcommunity.com/groups/WindowedBorderlessGaming
    http://westechsolutions.net/sites/WindowedBorderlessGaming
    786acphb0viikee4g.jpg
    NRaas has moved!
    Our new site is at http://nraas.net
  • Christopher69BChristopher69B Posts: 159 Member
    igazor wrote: »
    1 - This is a laptop? Sorry, I'm straining to see the system tray icons in one of the screenshots, but by any chance is it running on battery when this happens or does that not make any difference?

    2 - More likely though, this is a recent Win 10 Creators Update related thing. One way to get relief from what I've read is to always be in Windowed Mode but use the Widowed Borderless Gaming app.
    https://steamcommunity.com/groups/WindowedBorderlessGaming
    http://westechsolutions.net/sites/WindowedBorderlessGaming


    It’s the same when it’s running on the battery, plus it’s been like this since I got my laptop well back in October 2017 and have never known how to fix the problem.
  • phoebebebe13phoebebebe13 Posts: 19,400 Member
    igazor wrote: »
    1 - This is a laptop? Sorry, I'm straining to see the system tray icons in one of the screenshots, but by any chance is it running on battery when this happens or does that not make any difference?

    2 - More likely though, this is a recent Win 10 Creators Update related thing. One way to get relief from what I've read is to always be in Windowed Mode but use the Widowed Borderless Gaming app.
    https://steamcommunity.com/groups/WindowedBorderlessGaming
    http://westechsolutions.net/sites/WindowedBorderlessGaming


    It’s the same when it’s running on the battery, plus it’s been like this since I got my laptop well back in October 2017 and have never known how to fix the problem.

    You can't game on battery. you need more power while gaming and have to game plugged in ,
  • Christopher69BChristopher69B Posts: 159 Member
    igazor wrote: »
    1 - This is a laptop? Sorry, I'm straining to see the system tray icons in one of the screenshots, but by any chance is it running on battery when this happens or does that not make any difference?

    2 - More likely though, this is a recent Win 10 Creators Update related thing. One way to get relief from what I've read is to always be in Windowed Mode but use the Widowed Borderless Gaming app.
    https://steamcommunity.com/groups/WindowedBorderlessGaming
    http://westechsolutions.net/sites/WindowedBorderlessGaming


    It’s the same when it’s running on the battery, plus it’s been like this since I got my laptop well back in October 2017 and have never known how to fix the problem.

    You can't game on battery. you need more power while gaming and have to game plugged in ,


    It’s always plugged in when I’m gaming on it, so it won’t run out during gaming and to get the maximum performance.
  • phoebebebe13phoebebebe13 Posts: 19,400 Member
    paging @chesterbigbird since we don't have windows 10.
  • igazorigazor Posts: 18,838 Member
    edited June 2018
    The Win 10 Creators Updates aren't recent as in last week, the earlier ones were rolling out at the time you acquired your laptop. Have you tried Windowed Borderless yet?
    igazor wrote: »
    2 - More likely though, this is a recent Win 10 Creators Update related thing. One way to get relief from what I've read is to always be in Windowed Mode but use the Widowed Borderless Gaming app.
    https://steamcommunity.com/groups/WindowedBorderlessGaming
    http://westechsolutions.net/sites/WindowedBorderlessGaming

    786acphb0viikee4g.jpg
    NRaas has moved!
    Our new site is at http://nraas.net
  • Christopher69BChristopher69B Posts: 159 Member
    igazor wrote: »
    The Win 10 Creators Updates aren't recent as in last week, the earlier ones were rolling out at the time you acquired your laptop. Have you tried Windowed Borderless yet?
    igazor wrote: »
    2 - More likely though, this is a recent Win 10 Creators Update related thing. One way to get relief from what I've read is to always be in Windowed Mode but use the Widowed Borderless Gaming app.
    https://steamcommunity.com/groups/WindowedBorderlessGaming
    http://westechsolutions.net/sites/WindowedBorderlessGaming

    I’ve just tried that window borderless gaming app, and it seems to have put the game in full screen mode and has made it alot brighter now, I will have to use that until I can find a fix. It only does this on sims 3, it doesn’t do it on any other games.
  • igazorigazor Posts: 18,838 Member
    edited June 2018
    Good, glad that helped. And it might very well be the only solution for TS3 right now, which is why it's so popular with Win 10 users as of sometime in the middle of last year. It's not like EA is rolling out TS3 patches to account for things like this as Win 10 changes over time, since the last meaningful patch we got was well over four years ago before Win 10 was released in any form.
    786acphb0viikee4g.jpg
    NRaas has moved!
    Our new site is at http://nraas.net
  • Christopher69BChristopher69B Posts: 159 Member
    igazor wrote: »
    Good, glad that helped. And it might very well be the only solution for TS3 right now, which is why it's so popular with Win 10 users as of sometime in the middle of last year. It's not like EA is rolling out TS3 patches to account for things like this as Win 10 changes over time, since the last meaningful patch we got was well over four years ago before Win 10 was released in any form.

    After loading up my game save and taking a few screenshots it seems alot brighter compared to the other screenshots from earlier. [img][/img]33b350n.jpg
Sign In or Register to comment.
Return to top