January 21: Today is patch day! 😃 To read the patch notes, click here!
January 22 - Is everyone ready for the Friday Highlights? Check them out here.
Welcome to all NEW SIMMERS joining us on the Sims forum! 🎉 Have fun on the forum and please make sure you check out the forum rules and
the rules about necroposting.

[SOLVED] Mod causing infinite loading screen

Emmy_SimsEmmy_Sims Posts: 318 Member
edited March 2016 in Mods Bugs & Issues
I was bored with the very few names available in my game language, so I decided to go on an adventure to The Modding World™. Everything went okay, it's a very simple mod to make (it's only boring). I did everything just like @Julyvee94 said on this tutorial because it's my first mod and I have no frikkin idea what I'm doing :)

Now when I put the .package file on the \The Sims 4\Mods folder and load a save (or start a new one), I can't play on any household because the loading screen never goes away. The only problem (at least the only part of the problem I was able to check) is the loading screen after I click to play on the household, or as I would say, the loading screen before the actual game.
And yes, I made sure that the problematic .package was my mod.

So please, if any patient soul with some free time and good knowledge of this Modding World could help, I'd be very pleased.

EDIT: Actually, I think I know what the problem is, but still can't solve it or check if it's really a problem or not. After editing the XML file and the DATA file, I went to S4PE, dragged and dropped the files to finally make the package....

BUT

uhoWwmP.png

I noticed that the tag for the XML file should actually be ITUN instead of XML, or at least it's how it's shown on the video.
But I can't change the tag, even if I save the file as a .ITUN file instead of XML.

sytSCOX.png
I can't press ok

Io1SttF.png


So, maybe I found out the problem, but still can't solve it :/
Post edited by Emmy_Sims on
Jar Jar Binks is a Sith Lord

Comments

  • Emmy_SimsEmmy_Sims Posts: 318 Member
    @SimGuruModSquad, can you help me?

    PS: Maybe the Technical Discussions category was more appropriate?
    Jar Jar Binks is a Sith Lord
  • Julyvee94Julyvee94 Posts: 6,584 Member
    @Emmy_Sims hm that is really weird normally you should be able to change it to ITUN manually. And that might in fact be the problem as the file should be ITUN. When I tested it, it was ITUN automatically. Did you try to repeat the instructions again and see if it changes to XML again?
  • Emmy_SimsEmmy_Sims Posts: 318 Member
    Julyvee94 wrote: »
    @Emmy_Sims hm that is really weird normally you should be able to change it to ITUN manually. And that might in fact be the problem as the file should be ITUN. When I tested it, it was ITUN automatically. Did you try to repeat the instructions again and see if it changes to XML again?

    I saw that in the video and that's why I'm confused :D I would have tried again, but I was late to a doctor appointment. When I get home and my pupils are normal again (I'm going to see an ophthalmologist) I will repeat the process!
    Jar Jar Binks is a Sith Lord
  • Emmy_SimsEmmy_Sims Posts: 318 Member
    @Julyvee94 yes it changes to XML again :tired_face: aaaaaaaaahhh
    Jar Jar Binks is a Sith Lord
  • pboxpbox Posts: 630 Member
    edited March 2016
    Whether that particular type will be named ITUN or _XML depends on which version of s4pe you use, but that difference is only cosmetic -- it won't break or fix your mod. (I changed it from ITUN to _XML recently because the ITUN tag was carried over from s3pe; in TS4 there's a lot more XML types and they all export as .xml, so for consistency I also named that one _XML.)

    For anyone to help you with your mod you would need to post your actual code / package.

    For questions/issues about s4pe you should better post in the actual s4pe feedback threads: here or here. For questions on a tutorial maybe post in the tutorial thread?
    Stuff for TS2 · TS3 · TS4
  • Emmy_SimsEmmy_Sims Posts: 318 Member
    pbox wrote: »
    Whether that particular type will be named ITUN or _XML depends on which version of s4pe you use, but that difference is only cosmetic -- it won't break or fix your mod. (I changed it from ITUN to _XML recently because the ITUN tag was carried over from s3pe; in TS4 there's a lot more XML types and they all export as .xml, so for consistency I also named that one _XML.)

    For anyone to help you with your mod you would need to post your actual code / package.

    For questions/issues about s4pe you should better post in the actual s4pe feedback threads: here or here. For questions on a tutorial maybe post in the tutorial thread?

    Thanks for the enlightening! I posted on a MTS thread and attached the package to the post, perharps someone will take a look. I don't know how to do this here, maybe a download link?
    Jar Jar Binks is a Sith Lord
  • Emmy_SimsEmmy_Sims Posts: 318 Member
    It worked! Thank you @pbox for helping me here and on the MTS forum (you are plasticbox on MTS, right?). The issue was indeed some broken tags I missed while editing the XML.
    Jar Jar Binks is a Sith Lord
Sign In or Register to comment.
Return to top