December 13 - It's Friday, and that means Friday Highlight is here! Check it out!
December 12 - It's Patch Day for The Sims 4 on PC/MAC. Patch notes here.
December 5 - It's patch day for The Sims 4 on console! Read the patch notes here.

can't figure out a fix for S2 Ultimate Collection!

I've read so many help threads on various problems with getting it to run, and yet nothing seems to be working for me.

I get the error message about not having enough space (this, despite having plenty of free space), and then if I continue anyway, the game crashes before I can get started. I've cleared out even more space, though that hasn't helped. Somewhere there was a tip about going in and removing the 'TM' to prevent certain problems, but I seem to already not have that added in-- or if I do, I don't know where it might be. My files don't seem to all be in the same places as things are for the walkthroughs that I've read about how to fix it.

Comments

  • Rflong7Rflong7 Posts: 35,793 Member
    edited January 2016
    Hi :)

    I'll probably not be of much help since I have no idea about it...

    I guess, first off, You're on a Windows OS?

    Where is your game installed?
    Mine is -> C:\Program Files (x86)\Origin Games\The Sims 2 Ultimate Collection

    My Save files are -> C:\Users\My Old Laptop\Documents\EA Games\The Sims™ 2 Ultimate Collection

    *I have mine set to Run as administrator from the Start up.exe shortcut on my desktop.
  • GlasgowSmilesGlasgowSmiles Posts: 209 Member
    I've got no save files, I don't think, having never had the opportunity to save anything before a crash. But yeah, that's where I'm installed.
  • LadysimPlayer8LadysimPlayer8 Posts: 770 Member
    Hello GlasgowSmiles
    Is your windows operating system Windows 10?
    If so, are you running as administrator and have set compatibility mode to Windows XP or Vista?
    When playing Sims2, you have to turn off all other running programmes especially anti-virus (go off-line).
  • JULES1111JULES1111 Posts: 4,490 Member
    Hi try following this

    Go to "Run" or press Windows + R then type "regedit" and open HKEY_LOCAL_MACHINE and then select SOFTWARE

    For 32-Bit: Find "EA GAMES" folder and open "the sims 2" double-click on the Display Name then you will see the pop-up. Delete "™" from Value Data text field and the problem will solved.

    For 64-Bit: Open "Wow6432Node" then Find "EA GAMES" folder and open "the sims 2" double-click the Display Name then you will see the pop-up. Delete "™" from Value Data text field and the problem will solved.

    Before: The Sims 2™ Ultimate Collection
    After: The Sims 2 Ultimate Collection


    The: The Sims 2 "tm" Ultimate Collection Is listed on the right hand side next to display name, after opening the Sims 2. I went in to look and found it just as the instructions said. Hope you can get it working for you. Happy Simming! :)

    Oh and you do NOT have to play offline nor do you have to shut down any programs while running it. I never had to, and never heard of anyone else needing to either.
  • GlasgowSmilesGlasgowSmiles Posts: 209 Member
    @JULES1111
    Oh gosh thank you! That's exactly the path I needed to take, I've probably been looking under the wrong -bit path this whole time, confused over why I couldn't find it, knowing me.
  • JULES1111JULES1111 Posts: 4,490 Member
    @GlasgowSmiles

    You are very welcome. I am glad that was of help to you. Happy Simming! :)
Sign In or Register to comment.
Return to top