The Sims 2 Windows 7-10 Fixes

Comments

  • slynnskislynnski Posts: 2,313 Member
    @Rflong7 True — and I am known to assume too much. :D


  • Rflong7Rflong7 Posts: 35,447 Member
    slynnski wrote: »
    @Rflong7 True — and I am known to assume too much. :D

    Me, too... I assumed they counted them all and you assumed they didn't count the first. :lol: They should know now. ;)
  • Simsfan99111Simsfan99111 Posts: 1,260 Member
    The only problem ive come across on Windows 10 is. Slowness when flipping through things in build buy mode like objects and floor/wallpaper When you click the arrow To go to the next page it takes ages to load.
  • JULES1111JULES1111 Posts: 4,487 Member
    The only problem ive come across on Windows 10 is. Slowness when flipping through things in build buy mode like objects and floor/wallpaper When you click the arrow To go to the next page it takes ages to load.

    That is caused by Securom. If you remove it build/buy will load a lot quicker. We can't post the link just google remove securom leefish. The instructions are there.
  • Rhiannon58Rhiannon58 Posts: 595 Member
    luvmebby wrote: »
    anyone still around? I managed to get mine to play with ultimate collection on windows 10 without changing anything. other than a black rectangle under sims in create a sim.

    Upon a suggestion here I changed the shadow distance from high to medium and it fixed my problem.
  • TheHarbinger_51TheHarbinger_51 Posts: 1,702 Member
    Thank you! This fixed the flickering for me in TS2 <3 o:)

    Now I can enjoy this nostalgic fave @US_Marshall42
    **old account**
    moved on to other** by request.
  • horseypotatohorseypotato Posts: 23 Member
    sorry if im being silly but i cant seem to change my shadows setting like all the options are greyed out and its stuck on high and im having issues with the black boxes for shadows :(
  • JULES1111JULES1111 Posts: 4,487 Member
    sorry if im being silly but i cant seem to change my shadows setting like all the options are greyed out and its stuck on high and im having issues with the black boxes for shadows :(

    Not silly at all. Did you run the graphic rules? It can be found here: https://www.simsnetwork.com/simpedia/the-sims-2/editions/the-sims-2/specials/graphics-rules-maker-improve-compatibility-with or on Leefish (not allowed to link there)

    If the only issue you have is with the black boxes, there is a mod you can use to get rid of them. http://www.modthesims.info/download.php?t=569585

    I know that sometimes if you have a higher end graphics card, the graphic rules might not effect the shadows option. I also have my shadows stuck on high and greyed out with my latest card, it worked on all my past cards, but the mod gets rid of the black boxes. Just download and extract it, then put it in your Downloads folder.
  • horseypotatohorseypotato Posts: 23 Member
    JULES1111 wrote: »
    sorry if im being silly but i cant seem to change my shadows setting like all the options are greyed out and its stuck on high and im having issues with the black boxes for shadows :(

    Not silly at all. Did you run the graphic rules? It can be found here: https://www.simsnetwork.com/simpedia/the-sims-2/editions/the-sims-2/specials/graphics-rules-maker-improve-compatibility-with or on Leefish (not allowed to link there)

    If the only issue you have is with the black boxes, there is a mod you can use to get rid of them. http://www.modthesims.info/download.php?t=569585

    I know that sometimes if you have a higher end graphics card, the graphic rules might not effect the shadows option. I also have my shadows stuck on high and greyed out with my latest card, it worked on all my past cards, but the mod gets rid of the black boxes. Just download and extract it, then put it in your Downloads folder.

    Thank you, the mod worked! But now Im having issues trying to sort the resolution as its stuck at 800 x 600 and thats the only option (I think it was that anyway), will downloading the graphic rule solve that?
  • M13VulpeculaM13Vulpecula Posts: 16,922 Member
    JULES1111 wrote: »
    sorry if im being silly but i cant seem to change my shadows setting like all the options are greyed out and its stuck on high and im having issues with the black boxes for shadows :(

    Not silly at all. Did you run the graphic rules? It can be found here: https://www.simsnetwork.com/simpedia/the-sims-2/editions/the-sims-2/specials/graphics-rules-maker-improve-compatibility-with or on Leefish (not allowed to link there)

    If the only issue you have is with the black boxes, there is a mod you can use to get rid of them. http://www.modthesims.info/download.php?t=569585

    I know that sometimes if you have a higher end graphics card, the graphic rules might not effect the shadows option. I also have my shadows stuck on high and greyed out with my latest card, it worked on all my past cards, but the mod gets rid of the black boxes. Just download and extract it, then put it in your Downloads folder.

    Thank you, the mod worked! But now Im having issues trying to sort the resolution as its stuck at 800 x 600 and thats the only option (I think it was that anyway), will downloading the graphic rule solve that?

    Yes, it should solve that. :) And allow higher graphics as well.
  • theFellatheFella Posts: 297 Member
    What are these graphics rules? I did not have to do any tooling around with my game after install to make it look good.
    MeanBrilliantArrowworm-size_restricted.gif
  • JULES1111JULES1111 Posts: 4,487 Member
    edited February 2018
    JULES1111 wrote: »
    sorry if im being silly but i cant seem to change my shadows setting like all the options are greyed out and its stuck on high and im having issues with the black boxes for shadows :(

    Not silly at all. Did you run the graphic rules? It can be found here: https://www.simsnetwork.com/simpedia/the-sims-2/editions/the-sims-2/specials/graphics-rules-maker-improve-compatibility-with or on Leefish (not allowed to link there)

    If the only issue you have is with the black boxes, there is a mod you can use to get rid of them. http://www.modthesims.info/download.php?t=569585

    I know that sometimes if you have a higher end graphics card, the graphic rules might not effect the shadows option. I also have my shadows stuck on high and greyed out with my latest card, it worked on all my past cards, but the mod gets rid of the black boxes. Just download and extract it, then put it in your Downloads folder.

    Thank you, the mod worked! But now Im having issues trying to sort the resolution as its stuck at 800 x 600 and thats the only option (I think it was that anyway), will downloading the graphic rule solve that?

    Yes it should, unless you have a fairly recent graphics card. Sometimes after running the graphic rules you have to fine tune it by hand. Instructions for that here: http://simlili.tumblr.com/post/146373494212
    theFella wrote: »
    What are these graphics rules? I did not have to do any tooling around with my game after install to make it look good.

    The graphic rules allows the game to recognize newer graphics cards that released well after the game ended. So you can change the screen resolution, smooth edges and such. The game does not recognize some cards, so you have to tell it to, or else it will assume your card is below spec and will set everything at the lowest possible specs, and won't let you change them.
  • theFellatheFella Posts: 297 Member
    JULES1111 wrote: »
    JULES1111 wrote: »
    sorry if im being silly but i cant seem to change my shadows setting like all the options are greyed out and its stuck on high and im having issues with the black boxes for shadows :(

    Not silly at all. Did you run the graphic rules? It can be found here: https://www.simsnetwork.com/simpedia/the-sims-2/editions/the-sims-2/specials/graphics-rules-maker-improve-compatibility-with or on Leefish (not allowed to link there)

    If the only issue you have is with the black boxes, there is a mod you can use to get rid of them. http://www.modthesims.info/download.php?t=569585

    I know that sometimes if you have a higher end graphics card, the graphic rules might not effect the shadows option. I also have my shadows stuck on high and greyed out with my latest card, it worked on all my past cards, but the mod gets rid of the black boxes. Just download and extract it, then put it in your Downloads folder.

    Thank you, the mod worked! But now Im having issues trying to sort the resolution as its stuck at 800 x 600 and thats the only option (I think it was that anyway), will downloading the graphic rule solve that?

    Yes it should, unless you have a fairly recent graphics card. Sometimes after running the graphic rules you have to fine tune it by hand. Instructions for that here: http://simlili.tumblr.com/post/146373494212
    theFella wrote: »
    What are these graphics rules? I did not have to do any tooling around with my game after install to make it look good.

    The graphic rules allows the game to recognize newer graphics cards that released well after the game ended. So you can change the screen resolution, smooth edges and such. The game does not recognize some cards, so you have to tell it to, or else it will assume your card is below spec and will set everything at the lowest possible specs, and won't let you change them.

    @JULES1111 Guess my computer is older than I thought. I bought it in 2013, and I change change screen resolution, smoothness and other settings without doing nothin'
    MeanBrilliantArrowworm-size_restricted.gif
  • JULES1111JULES1111 Posts: 4,487 Member
    theFella wrote: »
    JULES1111 wrote: »
    JULES1111 wrote: »
    sorry if im being silly but i cant seem to change my shadows setting like all the options are greyed out and its stuck on high and im having issues with the black boxes for shadows :(

    Not silly at all. Did you run the graphic rules? It can be found here: https://www.simsnetwork.com/simpedia/the-sims-2/editions/the-sims-2/specials/graphics-rules-maker-improve-compatibility-with or on Leefish (not allowed to link there)

    If the only issue you have is with the black boxes, there is a mod you can use to get rid of them. http://www.modthesims.info/download.php?t=569585

    I know that sometimes if you have a higher end graphics card, the graphic rules might not effect the shadows option. I also have my shadows stuck on high and greyed out with my latest card, it worked on all my past cards, but the mod gets rid of the black boxes. Just download and extract it, then put it in your Downloads folder.

    Thank you, the mod worked! But now Im having issues trying to sort the resolution as its stuck at 800 x 600 and thats the only option (I think it was that anyway), will downloading the graphic rule solve that?

    Yes it should, unless you have a fairly recent graphics card. Sometimes after running the graphic rules you have to fine tune it by hand. Instructions for that here: http://simlili.tumblr.com/post/146373494212
    theFella wrote: »
    What are these graphics rules? I did not have to do any tooling around with my game after install to make it look good.

    The graphic rules allows the game to recognize newer graphics cards that released well after the game ended. So you can change the screen resolution, smooth edges and such. The game does not recognize some cards, so you have to tell it to, or else it will assume your card is below spec and will set everything at the lowest possible specs, and won't let you change them.

    @JULES1111 Guess my computer is older than I thought. I bought it in 2013, and I change change screen resolution, smoothness and other settings without doing nothin'

    You might want to consider yourself lucky then! Some people don't have to alter anything, but most do.
  • horseypotatohorseypotato Posts: 23 Member
    JULES1111 wrote: »
    JULES1111 wrote: »
    sorry if im being silly but i cant seem to change my shadows setting like all the options are greyed out and its stuck on high and im having issues with the black boxes for shadows :(

    Not silly at all. Did you run the graphic rules? It can be found here: https://www.simsnetwork.com/simpedia/the-sims-2/editions/the-sims-2/specials/graphics-rules-maker-improve-compatibility-with or on Leefish (not allowed to link there)

    If the only issue you have is with the black boxes, there is a mod you can use to get rid of them. http://www.modthesims.info/download.php?t=569585

    I know that sometimes if you have a higher end graphics card, the graphic rules might not effect the shadows option. I also have my shadows stuck on high and greyed out with my latest card, it worked on all my past cards, but the mod gets rid of the black boxes. Just download and extract it, then put it in your Downloads folder.

    Thank you, the mod worked! But now Im having issues trying to sort the resolution as its stuck at 800 x 600 and thats the only option (I think it was that anyway), will downloading the graphic rule solve that?

    Yes it should, unless you have a fairly recent graphics card. Sometimes after running the graphic rules you have to fine tune it by hand. Instructions for that here: http://simlili.tumblr.com/post/146373494212
    theFella wrote: »
    What are these graphics rules? I did not have to do any tooling around with my game after install to make it look good.

    The graphic rules allows the game to recognize newer graphics cards that released well after the game ended. So you can change the screen resolution, smooth edges and such. The game does not recognize some cards, so you have to tell it to, or else it will assume your card is below spec and will set everything at the lowest possible specs, and won't let you change them.

    Im still lost on what to do I followed everything in that tutorial to manually add my card as the graphics rule wouldnt work and im still stuck with 800x600 :(
  • horseypotatohorseypotato Posts: 23 Member
    scratch that I found a tutorial on leefish that finally sorted it for me but thank you guys for the help you gave me earlier!
  • JULES1111JULES1111 Posts: 4,487 Member
    scratch that I found a tutorial on leefish that finally sorted it for me but thank you guys for the help you gave me earlier!

    Glad you got it to work!
  • luvmebbyluvmebby Posts: 3 New Member
    my problem isn't with the graphics rule entirely. its with bodyshop, and simpe. I want to create again but since using windows 10 and ultimate collection, Simpe (latest version) is black with few white areas with words. I have to look at old tutorials with images just to see what the checkboxes are for when cloning an object. when creating clothing as soon as I package it and put it in game it pixelizes to a complete blur. my screen size is just fine but the details are still bad. I find even new meshes become twisted when packaging on windows 10 in simpe, I dont see simpe ever doing another update and not sure where else to turn. they were fine in milkshape but come out looking like a human turned into a tree but is blury. and for some reason it keeps blanking the alphas when exporting
  • luvmebbyluvmebby Posts: 3 New Member
    > @Cinebar said:

    > ETA: I see you have already ask over there and no one has answered. Have you tried to set the SimPE.exe to 32bit instead of 64bit? that might be part of the problem as most machines today are 64bit.

    how do I do that? I may need an image of where it is in program settings if its not currently visible.
  • Scribal_GoddessScribal_Goddess Posts: 748 Member
    Go down to your start bar, type in simPE, when it comes up, right click and choose "open location."

    This should, if you installed it correctly, take you to Program Files X86. (If not you need to reinstall to that location.)

    Once there, right click again, and first choose "troubleshoot compatibility" and follow the directions from there.

    If that doesn't work, you may need to set the compatibility mode manually: right click, go down to properties>compatibility and run the troubleshooter or follow the "how do I adjust settings manually."

    You can also choose to run the program as administrator if you right click the shortcut.

    You may also be missing the windows framework for the program, so go back to the downloads page and read through the page until you find the downloads link for the microsoft.net framework. (You may also want the directX meshes thing.)
    Patron Goddess of Newbs and Ninnyhammers.
    TS2 Graphics Fix Tutorial]
  • BMSOBMSO Posts: 1,973 Member
    My issue isn't flickering black screens it's buy mode. I click on anything and buy mode is so laggy it doesn't even load and this is playing it on Sims 2 UC. I've tried looking everywhere for a solution.
    Artist, Gamer and Geek, CC creator Origin ID: bmso85
    Art Gallery || My Simblr
    27613094538_1262ef3143_n.jpg

  • Scribal_GoddessScribal_Goddess Posts: 748 Member
    BMSO wrote: »
    My issue isn't flickering black screens it's buy mode. I click on anything and buy mode is so laggy it doesn't even load and this is playing it on Sims 2 UC. I've tried looking everywhere for a solution.

    This is usually a securom thing. Either update your game, or run it cracked and remove securom.
    Patron Goddess of Newbs and Ninnyhammers.
    TS2 Graphics Fix Tutorial]
  • BMSOBMSO Posts: 1,973 Member
    BMSO wrote: »
    My issue isn't flickering black screens it's buy mode. I click on anything and buy mode is so laggy it doesn't even load and this is playing it on Sims 2 UC. I've tried looking everywhere for a solution.

    This is usually a securom thing. Either update your game, or run it cracked and remove securom.

    I thought the securom was removed? I had to reinstall it yesterday and it started working again I'll give it an update today and hope for the best. Thanks for the tip.
    Artist, Gamer and Geek, CC creator Origin ID: bmso85
    Art Gallery || My Simblr
    27613094538_1262ef3143_n.jpg

  • JULES1111JULES1111 Posts: 4,487 Member
    BMSO wrote: »
    BMSO wrote: »
    My issue isn't flickering black screens it's buy mode. I click on anything and buy mode is so laggy it doesn't even load and this is playing it on Sims 2 UC. I've tried looking everywhere for a solution.

    This is usually a securom thing. Either update your game, or run it cracked and remove securom.

    I thought the securom was removed? I had to reinstall it yesterday and it started working again I'll give it an update today and hope for the best. Thanks for the tip.

    If you had the previous digital download or were using the disks, you still have securom on your pc. It does not uninstall with the game. You must use a special program to get rid of it, or it stays forever.
  • Seera1024Seera1024 Posts: 3,305 Member
    JULES1111 wrote: »
    BMSO wrote: »
    BMSO wrote: »
    My issue isn't flickering black screens it's buy mode. I click on anything and buy mode is so laggy it doesn't even load and this is playing it on Sims 2 UC. I've tried looking everywhere for a solution.

    This is usually a securom thing. Either update your game, or run it cracked and remove securom.

    I thought the securom was removed? I had to reinstall it yesterday and it started working again I'll give it an update today and hope for the best. Thanks for the tip.

    If you had the previous digital download or were using the disks, you still have securom on your pc. It does not uninstall with the game. You must use a special program to get rid of it, or it stays forever.

    Keep in mind that Sims 2 is not the only game out that comes with Securom. You may have another game that installed it on your PC, especially if you play older games.
Sign In or Register to comment.
Return to top