July 3 - No Friday without a Friday Highlight! Find this week's highlighted discussions here.
June 27 - Let's pick our Best of Simming for June 2020!
You are browsing an archived read-only section of the forums. The Sims 4 Help Center can now be found here.

- Grey/opaque windows -

Comments

  • PsychomoiPsychomoi Posts: 41 Member
    im guessing this is just never ever gonna get fixed eh... thank you EA
  • cheapermondaycheapermonday Posts: 198 New Member
    I have a retina and it's still occurring. Seriously aggravating. Gurus please help!
  • sunshineandsimoleonssunshineandsimoleons Posts: 8,412 Member
    .
    I have the same hardware specs as Psychomoi and I am on 10.10.3:

    Macbook pro 13" mid 2010
    2.4 GHZ intel core 2 duo
    4 GB 1067 MHz DDR 3
    NVIDIA GeForce 320M 256 MB

    I have noticed this issue happens in Laptop Mode with the base windows, but not with windows that came with GTW. I do not have Outdoors GP so I can't speak for that (if it even included windows).

    Its the same for me, only in laptop mode but the new windows dont have the problem. I play with LM off now because of this (and the cc hair issue lol)
    WLfAA9V.png
  • SakurachanchanSakurachanchan Posts: 1 New Member
    Hello!
    I have had the Sims 4 on my Mac for a while now and thought the greyed out windows was just what EA had decided to do with them ahah *-*
    Just before I went in game and turned off laptop mode and it made my camera controls really buggy and made it quite hard to play.

    Graphics Card: Intel HD Graphics 4000 1024 MB
    Operating System: Yosemite 10.10.2
    Laptop Mode: Yes
  • Xxmusiclover1xxXxmusiclover1xx Posts: 43 Member
    edited December 2015
    Hi! After the last patch I have had the greyed out windows problem.
    I tried several attempts at fixing including: repairing, replacing windows, deleting mod folder. I just uninstalled and reinstalled Origin and plan on reinstalling the game. Maybe that will help?

    Graphics Card: Intel HD Graphics 4600
    Operating System: Windows 10 Home 64-bit
    System Model: HP ENVY 17 Notebook PC
    Processor: Intel(R) Core(TM) i5-4200M CPU @ 2.50GHz (4 CPUs), ~2.5GHz
  • BluebellFloraBluebellFlora Posts: 7,079 Member
    Hi! After the last patch I have had the greyed out windows problem.
    I tried several attempts at fixing including: repairing, replacing windows, deleting mod folder. I just uninstalled and reinstalled Origin and plan on reinstalling the game. Maybe that will help?

    Graphics Card: Intel HD Graphics 4600
    Operating System: Windows 10 Home 64-bit
    System Model: HP ENVY 17 Notebook PC
    Processor: Intel(R) Core(TM) i5-4200M CPU @ 2.50GHz (4 CPUs), ~2.5GHz

    You should probably post in the TS4 tech. forum. This is the Mac forum :)

    apple-signature.png
  • babyroo1111babyroo1111 Posts: 35 Member
    Hello! I have the grey-opaque windows problem, too. However, I have a Retina display. How odd!
  • Stella_Bella_6Stella_Bella_6 Posts: 1 New Member
    Hello :smiley:
    I have greyed out windows and laptop mode is actually disabled.
    What do?
    iMac
    Version 10.9.5
    Processor 3.07 GHz Intel Core 2 duo
    Memory 16 GB 2067 MHz DDR3
    Graphics NVIDIA GeForce 9400 256 MB
    Hope you have something I can do :neutral:
  • BluebellFloraBluebellFlora Posts: 7,079 Member
    Hello :smiley:
    I have greyed out windows and laptop mode is actually disabled.
    What do?
    iMac
    Version 10.9.5
    Processor 3.07 GHz Intel Core 2 duo
    Memory 16 GB 2067 MHz DDR3
    Graphics NVIDIA GeForce 9400 256 MB
    Hope you have something I can do :neutral:

    Your Mac's graphics card is the absolute minimum the game requires to play so probably not very much unfortunately.
    apple-signature.png
  • geekchic96geekchic96 Posts: 152 Member
    This happens to me frequently when I turn on the game. It's very annoying. Very rarely do the windows look like they are supposed to. I have a 15inch retina display macbook pro.
  • BluebellFloraBluebellFlora Posts: 7,079 Member
    geekchic96 wrote: »
    This happens to me frequently when I turn on the game. It's very annoying. Very rarely do the windows look like they are supposed to. I have a 15inch retina display macbook pro.

    Entry level 15" or the higher spec. with the dedicated NVIDIA or AMD graphics?

    apple-signature.png
  • southaltansouthaltan Posts: 152 Member
    Hi! I see I'm that I'm not the only one with this problem, it started when I installed the Get Together EP.
  • southaltansouthaltan Posts: 152 Member
    OS X El Capitan
    Version 10.11.2
    Macbook Pro (13 in, Mid 2010)
    Processor: 2.4 Ghz Intel Core 2 Duo
    Memory 16 GB 1067 mhz ddr3
    GRAPHICS- NVIDIA George 320m 256 my

    The issue didn't start with the greyed out windows until I installed get together.
  • BluebellFloraBluebellFlora Posts: 7,079 Member
    southaltan wrote: »
    OS X El Capitan
    Version 10.11.2
    Macbook Pro (13 in, Mid 2010)
    Processor: 2.4 Ghz Intel Core 2 Duo
    Memory 16 GB 1067 mhz ddr3
    GRAPHICS- NVIDIA George 320m 256 my

    The issue didn't start with the greyed out windows until I installed get together.

    I think as the game has more added to it the 13" MBPs and MBAs are beginning to struggle because of the integrated graphics. There are more reports coming in of laggier games and graphics after patches and EP installs :( If you up the graphics settings to get rid of the grey windows does the game start to slow down a bit?
    apple-signature.png
  • southaltansouthaltan Posts: 152 Member
    southaltan wrote: »
    OS X El Capitan
    Version 10.11.2
    Macbook Pro (13 in, Mid 2010)
    Processor: 2.4 Ghz Intel Core 2 Duo
    Memory 16 GB 1067 mhz ddr3
    GRAPHICS- NVIDIA George 320m 256 my

    The issue didn't start with the greyed out windows until I installed get together.

    I think as the game has more added to it the 13" MBPs and MBAs are beginning to struggle because of the integrated graphics. There are more reports coming in of laggier games and graphics after patches and EP installs :( If you up the graphics settings to get rid of the grey windows does the game start to slow down a bit?

    i turned off tattoo mode, so far there isn't a lag, and the game is playing normal, and the windows aren't grey'd out. I still have misgivings my settings on high, but will probably have to lower them,as more content gets added.. (I think the only way I'm able to get away with high graphics, is because of the 16 GB memory I added..
  • BluebellFloraBluebellFlora Posts: 7,079 Member
    The RAM you added hasn't altered the graphics VRAM, but it would have meant that more was available to the game for processing it, if that makes sense! Just keep an eye on it. If you raise them too high and you can't launch the game just drag the Options.ini file to the Trash and relaunch the game. The settings will be back to default again.
    apple-signature.png
  • geekchic96geekchic96 Posts: 152 Member
    geekchic96 wrote: »
    This happens to me frequently when I turn on the game. It's very annoying. Very rarely do the windows look like they are supposed to. I have a 15inch retina display macbook pro.

    Entry level 15" or the higher spec. with the dedicated NVIDIA or AMD graphics?

    Sorry for the late reply! I have the higher spec 15 inch with two graphic cards. One is Intel and the other is AMD.
  • BluebellFloraBluebellFlora Posts: 7,079 Member
    geekchic96 wrote: »
    geekchic96 wrote: »
    This happens to me frequently when I turn on the game. It's very annoying. Very rarely do the windows look like they are supposed to. I have a 15inch retina display macbook pro.

    Entry level 15" or the higher spec. with the dedicated NVIDIA or AMD graphics?

    Sorry for the late reply! I have the higher spec 15 inch with two graphic cards. One is Intel and the other is AMD.

    That's interesting, your AMD GPU is more than capable of handling the game on high settings. Your Mac switches over to it when you load software that needs a lot of graphics power. Do you have laptop mode enabled in the game options? If you do turn it off.
    apple-signature.png
  • geekchic96geekchic96 Posts: 152 Member
    geekchic96 wrote: »
    geekchic96 wrote: »
    This happens to me frequently when I turn on the game. It's very annoying. Very rarely do the windows look like they are supposed to. I have a 15inch retina display macbook pro.

    Entry level 15" or the higher spec. with the dedicated NVIDIA or AMD graphics?

    Sorry for the late reply! I have the higher spec 15 inch with two graphic cards. One is Intel and the other is AMD.

    That's interesting, your AMD GPU is more than capable of handling the game on high settings. Your Mac switches over to it when you load software that needs a lot of graphics power. Do you have laptop mode enabled in the game options? If you do turn it off.

    Whenever I play the game laptop mode is switched off.
  • BluebellFloraBluebellFlora Posts: 7,079 Member
    Hmm, and do you have all the settings set to high? With the game running can you click on the Apple logo then About This Mac. What graphics card is showing in the details, the Intel or the AMD? When your Mac automatically switches to the AMD it should show up there instead of the Intel.

    As a way to test, go into System Preferences > Energy Saver and uncheck the box next to Automatic Graphics Switching. This means your Mac will always use the AMD. Load the game and see if the windows are grey still.
    apple-signature.png
  • geekchic96geekchic96 Posts: 152 Member
    Hmm, and do you have all the settings set to high? With the game running can you click on the Apple logo then About This Mac. What graphics card is showing in the details, the Intel or the AMD? When your Mac automatically switches to the AMD it should show up there instead of the Intel.

    As a way to test, go into System Preferences > Energy Saver and uncheck the box next to Automatic Graphics Switching. This means your Mac will always use the AMD. Load the game and see if the windows are grey still.

    The settings are on high. I tried what you said but the windows are still grey.
  • BluebellFloraBluebellFlora Posts: 7,079 Member
    geekchic96 wrote: »
    The settings are on high. I tried what you said but the windows are still grey.

    Oh, that is strange. And when you checked in About This Mac your Mac has switched to the AMD? Have you toggled disabling/enabling the retina setting in the game options? Not really sure what else to suggest :(

    apple-signature.png
  • cbartsch69cbartsch69 Posts: 167 Member
    I'm having the grayed out windows in laptop mode, too. Now I can't decide if it's better to run the game in laptop mode and deal with the windows or to play with it turned off and know that I'll be risking the random crashes... (Haven't noticed a crash since I started using laptop mode a few days ago, but then again, I haven't played much since then).

    Any new updates on how to get rid of the grayed windows while still using laptop mode?

    Oh, my specs:

    OS X El Capitan (v. 10.11.2)
    MacBook Pro (Retina, Mid 2012)
    Processor 2.6 GHz Intel Core i7
    Memory 8 GB
    Graphics NVIDIA GeForce GT 650M 1024 MB
  • Simfan923Simfan923 Posts: 5,551 Member
    @cbartsch69 Sorry, unfortunately the windows are going to stay greyed out in laptop mode. Only way to get rid of them is to turn laptop mode off.
    1FKDfKj.png
  • cbartsch69cbartsch69 Posts: 167 Member
    Simfan923 wrote: »
    @cbartsch69 Sorry, unfortunately the windows are going to stay greyed out in laptop mode. Only way to get rid of them is to turn laptop mode off.

    Thanks for the heads up -- that was the info. I was looking for. Any idea of the the highest settings we can use without being in laptop mode while avoiding the constant crashing issue?
Sign In or Register to comment.
Return to top