May 17 - Friday Highlight time! Check this week's out here!

- The Sims 4 help, troubleshooting & BUG Thread -

Comments

  • Tremayne4260Tremayne4260 Posts: 3,123 Member
    You should be able to go into the Game Options and turn off the Tutorials.
    Second Star to the Right and Straight on 'til Morning.
  • caroline_simscaroline_sims Posts: 31 Member
    @Tremayne4260 Thanks but the main problem is that all of my saves are gone and my cc too. do u have any idea how to fix that? anything could help i've already tried moving my saves and mods (which have nothing in them) to my desktop and then had the game create new ones, then i tried repairing the sims 4 on origin and nothing worked so far.
  • BluebellFloraBluebellFlora Posts: 7,049 Member
    I opened sims 4 today after I deleted a bunch of files off my mac

    You've just answered your own problem, you deleted the Sims 4 folder from Documents > Electronic Arts off your Mac. That folder holds all your saves, CC etc. Do you have a previous backup you can restore?

    apple-signature.png
  • uglyspiceuglyspice Posts: 5 New Member
    Hi!
    Long story short - I restarted my macbook accidentally and now my mods won't work..
    The restart deleted all of my sims (sims 4 btw) and mods, but I'm not overly concerned about the loss of the gameplay itself, more about the fact that mods will no longer run for me. I naively thought that i could just move the .package files back into the 'mod' folder but to no avail. I have made sure the cc and script mod options are turned on, I have even tried removing the 'mod' folder entirely and waiting for it to regenerate but it just won't. Origins 'repair' option does nothing either.
    I tried to ask EA for help about the broken folder but they just said that because they don't promote modding they can't help me, and so referred me to the forums.
    I have even tried uninstalling/reinstalling the sims and its still not working :(
    I am really desperate and if anyone could help me i would hugely appreciate it!

    Mac model: early 2015 13" macbook air
    Operating System: Sierra 10.12.6
    Processor: 1.6 GHz Intel Core i5
    Memory: 8 GB 1600 MHz DDR3
    Graphics: Intel HD Graphics 6000 1536 MB
    Official EA EPs/SPs/GPs installed: Cats and Dogs
  • Tremayne4260Tremayne4260 Posts: 3,123 Member
    Try this. Move the Sims 4 folder to your desktop (found Documents > Electronic Arts > Sims 4 to your Desktop. DO NOT DELETE IT! Then start your game up realizing that none of your saves or CC/Mods will be present in your game. Create a new Sim and play for at least an hour to insure that the game itself is working correctly. Then add a few of your Mods back into your game to see if they are working. If they are not, then the worst you may have to do is repeat the steps above and re-download your Mods.

    It is very odd that a restart of your computer would delete your Sims and your saved games. You must have done something else in the meantime to delete those games/Sims, like moving the Sims 4 folder to the trash.
    Second Star to the Right and Straight on 'til Morning.
  • GasolineCreaGasolineCrea Posts: 103 Member
    Hallo, I have a problem that I've had lurking for months. It's driving me insane and I've tried heaps of things. The last person I asked directed me to ask here, because being a mac user, some things may be a bit different. So, here's the issue;

    My sims reaction time is super wonky. Like...it's really really slow, and getting worse. I tell my sim to do something and they stand there, just shifting and looking sideways for a good five to ten seconds before the thing even appears in their action bar.
    I often pause the game, then unpause it, which helps fix the broken movement that one time, but the pausing is weird too. I click pause and it doesn't actually pause—it doesn't go red around the edge, and my sims are still doing the weird side look thing. After a few seconds, it usually then does pause, and I can unpause the game again.

    This is so, so much worse if I go on a higher speed. If I go on a higher speed, every action needs a pause to actually go through.

    It kind of varies from minute to minute, action to action. It's driving me insane. It almost killed my vampire because she would not leave the sunlight. It's making me not want to play. I know this is a long explanation, but I felt like it was the only way to get through the severity of this issue. I've already asked in the normal issue threads and got directed here.

    I've tried;
    Repairing Origin (so many times)
    Completely uninstalling and reinstalling both MCCC and the game.
    Deleting sims folder, opening the game to get a new one and moving the saves and stuff back in.
    Removing MCCC
    Disabling Origin in-game
    Playing in windowed mode (which did seem to help at first, then didn't)

    So, I'm at a loss for what to do now. Deleting the folder has made it a million times better (it only happens maybe 25% of the time now for a few seconds, instead of 80% for ten seconds) but it's still here. I feel like I'm stuck with this problem forever at this stage.

    I also feel like the problem is worse with bigger families, but I haven't actually tested that well. It's just a guess, on that front.

    I -am- having some last exception errors, but I don't know if they're the problem, a symptom of the problem, or completely unrelated. Nobody's told me "its the last exception" yet.


    I don't really know how to share the computer facts, but here goes:

    Macbook Pro (13-inch, 2017)
    2.3 GHz Intel Core i5
    8 GB
    Intel Iris Plus Graphics 640 1536 MB
    macOS High Sierra Version 10.13.1

    Official packs; Get Together, Get to Work, City Living, Cats and Dogs, Parenthood, Vampires, Jungle Adventure, Holiday Celebration Pack.

    No antiviruses, no nothing. Haven't really had my computer that long.
    No background tasks.
    The only mod/cc thing I have is MC Command Center.

    I think I run my graphics on high, I turned them down from Very High when the issues first returned, and it hasn't helped at all. I just figured it was worth mentioning.

    This issue was on the old computer I used, too. It wasn't here when I first got this computer, but it's gradually came back. Repairing it helps a tiny bit for maybe ten minutes, then it's in full swing mode again.

    This is such a long message, hope someone has some idea of what's going on, because I sure don't.

    Thanks ~ Crea.
    Who needs vampires when you have sorcerers?
  • Tremayne4260Tremayne4260 Posts: 3,123 Member
    Do you ever restart your computer or always leave it in sleep mode? Try restarting/rebooting it.
    Second Star to the Right and Straight on 'til Morning.
  • GasolineCreaGasolineCrea Posts: 103 Member
    If that's for me, then I restart it almost every day. I have some monitor connection issues, so restarting is a common thing.
    Who needs vampires when you have sorcerers?
  • BluebellFloraBluebellFlora Posts: 7,049 Member
    @GasolineCrea

    Can you empty your Sim's inventory and see if that helps?
    apple-signature.png
  • JazzpuzJazzpuz Posts: 79 Member
    edited April 2018
    EDIT: LOL! I had to reset Origin a few months back and didn't realise I forgot to disable Origin In-Game, wow that thing is a real sucker! Now TS4 launches in record speed again :D ! Hopefully that will eliminate the other issues as well.

    Sorry, I'm not that active on the forums and in stead of starting a whole new thread I'll try posting here first in case there has been anyone else with same issue (I don't really get the search-engine on this forum):
    For at least 4-5 months now I've noticed it takes considerable longer for my game to launch. It took maybe 5-15 sec before, now it can take up to 30-35 sec - and that's fine, thought maybe it's because I've bought much more DLCs lately => more to load.
    However, sometimes I also get other issues after launching, mainly there's no sound or, sometimes, a weird problem with click-input, I have to click at least twice, sometimes thrice for something to happen (eg. I click on the Options-button, nothing happens, I click once more and the Options-menu open, I click on Exit Game, nothing happens, I click once more and the game quits). If I relaunch game it's fine though, or at least it hasn't occured twice in a row. One of these two issues happens maybe 6-7/10 times.

    I'm no computer expert, but it seems these problems are related to the actual launch of the game. I have, of course, repaired game a dozen of times since it started and I have tried removing mods/CCs. It's not game-breaking, that's why it's taken so long for me to try figure it out, but it makes me a bit concerned and annoyed.

    If it's relevant:
    I have the low spec 2017 MacBook Pro 15" and all the DLCs except four stuff packs (My First Pet, Kids Room, Romantic Garden, Backyard).
  • SHOTSxFIREDSHOTSxFIRED Posts: 1 New Member
    So I play on a mac that I'm 1000% sure exceeds the standards for the sims 4. But I have recently come across an issue. Whenever I load into a save it will let me into the neighborhood but when I click on the household I want to play with and the big play button, the loading screen takes forever. The longest I've seen it load is 20 minutes and then I just force quitted the game. So I'm fairly positive it is never going to load no matter how long it takes. I know that it is a custom content problem because I have tried it without the mods folder and everything worked fine. Also when I go to the options section nothing shows up. It's just the graphics (I can't really remember what it says but I think it's graphics) tab on the side and nothing else. But when I click on it nothing shows anyway. This is also a cc problem. What I want to know is if there is something for mac that will help me filter out what is making my sims 4 not load since my folder is so big. Any help is appreciated, thank you.
  • Tremayne4260Tremayne4260 Posts: 3,123 Member
    Afraid not. It is a manual process. You will have to go through and figure out which is bad CC and what is good. The process is described best here.

    http://forums.thesims.com/en_US/discussion/938152/mac-users-best-friend-please-read-before-posting-sims-4-version#latest
    Second Star to the Right and Straight on 'til Morning.
  • The3CBThe3CB Posts: 6 New Member
    I can't seem to find the Sims 4 folder. It says it doesn't exist. I use origin, so I don't know why I can't find it. I want to download a mod, but it is so hard for me just to find the folder. I can't find the Sims 4 folder, origin folder, documents folder or anything relating to it. Just the application to open origin.
  • Tremayne4260Tremayne4260 Posts: 3,123 Member
    edited May 2018
    Open your hard drive folder on your Desktop. Next to it there should be a list of sub folders titled "Favorites" under which one should be Documents. From there the path is Documents > Electronic Arts > Sims 4.
    Post edited by Tremayne4260 on
    Second Star to the Right and Straight on 'til Morning.
  • The3CBThe3CB Posts: 6 New Member
    What hard drive folder? I don't think I have that either, but I don't know...
  • Tremayne4260Tremayne4260 Posts: 3,123 Member
    It's located right on your Desktop. It should be called Hard Drive. Usually it's found in the upper right hand corner.
    Second Star to the Right and Straight on 'til Morning.
  • The3CBThe3CB Posts: 6 New Member
    Nope, don't have it there...
  • Tremayne4260Tremayne4260 Posts: 3,123 Member
    Do you have any icons on your Desktop?
    Second Star to the Right and Straight on 'til Morning.
  • BluebellFloraBluebellFlora Posts: 7,049 Member
    The hard drive only shows up if you have selected it to, otherwise it's hidden by default. If you open a Finder window it may show up under Devices in the left sidebar. If not click on Finder > Preferences tick next to Hard disks under Devices. It will now show up in your Finder sidebar. If you want it to show up on the desktop click on Finder > General and tick next to Hard disks under Show these items on the desktop.
    apple-signature.png
  • The3CBThe3CB Posts: 6 New Member
    I just recently got a new computer, so this is what its on. I don't know if I have a Hard disks folder either but I'll keep looking into it...
  • fcurtifcurti Posts: 10 New Member
    Hi everyone, I need desperate help. I accidentally deleted my sims 4 folder on my mac, emptied my recycle bin and everything, thinking I would loose all my saved data on my sims game it is still there. How can I get the folder back? I have already opened and saved and exited my game. What can I do? Please someone help!
  • PandaHideawayPandaHideaway Posts: 1 New Member
    My account has been banned for some reason (I'm not sure if this counts as a technical issue but I'm still going to try). I contacted EA and they replied (thank god). However, they told me to contact the retailer and I'm not sure how. Someone, please help!!!
  • Tremayne4260Tremayne4260 Posts: 3,123 Member
    Not sure we can help you. We are players like you. You'd need to contact the new forum contact by PM.
    Second Star to the Right and Straight on 'til Morning.
  • EA_MageEA_Mage Posts: 1,354 EA Staff (retired)
    edited June 2018
    My account has been banned for some reason (I'm not sure if this counts as a technical issue but I'm still going to try). I contacted EA and they replied (thank god). However, they told me to contact the retailer and I'm not sure how. Someone, please help!!!

    @PandaHideaway If any of your EA accounts (forum or game account) have been banned, please get in touch with our Terms of Service team by following the steps in this article.

    Thanks,
    -Mage

  • Tremayne4260Tremayne4260 Posts: 3,123 Member
    @EA_Mage, thank you. <3
    Second Star to the Right and Straight on 'til Morning.
Sign In or Register to comment.
Return to top