The latest update addressed the crashing issue that some of you have been experiencing, Click here to found out more!
November 20 - Everyone ready for the Friday Highlight? It's ready for you here.
You are browsing an archived read-only section of the forums. The Sims 4 Help Center can now be found here.

- The Sims 4 help, troubleshooting & BUG Thread -

Comments

  • BluebellFloraBluebellFlora Posts: 7,089 Member
    Updated to reflect fixes in patch 1.6.69.1220.
    apple-signature.png
  • YoshiLoverYoshiLover Posts: 15 New Member
    OMG You are a lifesaver! Thank you so much :D <3
  • SimGuruModSquadSimGuruModSquad Posts: 597 SimGuru
    Hey guys, regarding the catalog not sorting consistently between Mac and PC for the basement and wall tool. Yes that is unexpected and weird. Probably not causing major issues but we are investigating to be sure.
    Update: We've determined what the cause of this is... nothing serious and we'll fix in an upcoming patch.
  • BluebellFloraBluebellFlora Posts: 7,089 Member
    edited May 2015
    Hey guys, regarding the catalog not sorting consistently between Mac and PC for the basement and wall tool. Yes that is unexpected and weird. Probably not causing major issues but we are investigating to be sure.
    Update: We've determined what the cause of this is... nothing serious and we'll fix in an upcoming patch.

    Lovely, thank you @SimGuruModSquad

    The bug list is now updated with the most common and serious bugs.

    apple-signature.png
  • Swaggy KiddySwaggy Kiddy Posts: 1 New Member
    Could you please help me
    I haven't played on The Sims 4 since April due to this issue
    Everytime I try to play the screen just stays on the, The Sims page and doesn't load
    If I go out of the game and onto a new tab it doesn't let me go back into The Sims
    It wont even let me go onto the homescreen page where it gives you the option to play or creat a new household
    I thought if I left the game for a while it would work but it wont and it has not
    I think the problem started because I had to turn my game and my computer off really quick
    I don't think the game turned off well bacause my computer crashed and didn't shut down properly
    After that the stopped working well
    I also had problems around December but it fixed on its own
    Please help me because I don't think I will be allowed to but a new game
    And I was looking forward to getting the expansion pack
    I tried repairing it and saving it to my desktop but nothing has changed
    Thank you if you help or know anything I can do to fix this problem xx
  • BluebellFloraBluebellFlora Posts: 7,089 Member
    Could you please help me
    I haven't played on The Sims 4 since April due to this issue
    Everytime I try to play the screen just stays on the, The Sims page and doesn't load
    If I go out of the game and onto a new tab it doesn't let me go back into The Sims
    It wont even let me go onto the homescreen page where it gives you the option to play or creat a new household
    I thought if I left the game for a while it would work but it wont and it has not
    I think the problem started because I had to turn my game and my computer off really quick
    I don't think the game turned off well bacause my computer crashed and didn't shut down properly
    After that the stopped working well
    I also had problems around December but it fixed on its own
    Please help me because I don't think I will be allowed to but a new game
    And I was looking forward to getting the expansion pack
    I tried repairing it and saving it to my desktop but nothing has changed
    Thank you if you help or know anything I can do to fix this problem xx

    - What Mac do you have?
    - Have you moved your TS4 folder from Documents > Electronic Arts out onto your desktop and tried a clean game, as recommended in this thread?
    - Have you cleanly uninstalled the game and Origin and reinstalled?
    - Do you use CC/Mods?

    apple-signature.png
  • bevedawnbevedawn Posts: 14 New Member
    when will the DLC problem be fixed not even the holiday pack is being detected as installed for me
  • BluebellFloraBluebellFlora Posts: 7,089 Member
    bevedawn wrote: »
    when will the DLC problem be fixed not even the holiday pack is being detected as installed for me

    It's not affecting everyone, just a few. Have you completely uninstalled and reinstalled Origin and TS4? When you uninstall Origin you need to get rid of ALL files.
    apple-signature.png
  • southaltansouthaltan Posts: 152 Member
    Has anyone tried to add custom music? I've added the files to the appropriate folder and the songs never play and show up in the music (in game options) but are blank, and you can click the play button to preview but nothing plays.
  • southaltansouthaltan Posts: 152 Member
    edited May 2015
    bevedawn wrote: »
    when will the DLC problem be fixed not even the holiday pack is being detected as installed for me

    I haven't had an issue since the May update
  • nattylonglegsnattylonglegs Posts: 65 Member
    So I moved the Sims 4 folder onto my desktop. Then my game worked when it generated a new one. I went back and deleted the CC I though was causing the problem. I moved original folder back and play my game only to find it is making me start the game over from the beginning. Sweet.
  • BluebellFloraBluebellFlora Posts: 7,089 Member
    So I moved the Sims 4 folder onto my desktop. Then my game worked when it generated a new one. I went back and deleted the CC I though was causing the problem. I moved original folder back and play my game only to find it is making me start the game over from the beginning. Sweet.

    Why didn't you just move your saves back into the newly generated folder? And then add the CC back in a piece at a time?
    apple-signature.png
  • nattylonglegsnattylonglegs Posts: 65 Member
    I'm not computer savvy at all :( sorry about that! I did it and it worked. Thank you so much!
  • BluebellFloraBluebellFlora Posts: 7,089 Member
    Great, glad it's working again :)
    apple-signature.png
  • norkalsimmernorkalsimmer Posts: 11 New Member
    edited May 2015
    Hi, I've been having trouble with TS4 Digital Deluxe for Mac ever since the beginning basically. My loading screens started out to be a decent length, but soon after started to become longer and longer. Then I added the Outdoor Retreat game pack and the loading screen times increased, and increased again with each addition ie. Get To Work and Luxury Party Stuff. Now my loading screens are always a minute and a half long plus, and there is now lag when changing speeds in the game and some sim freezing. I cleared out my cache properly following a simmer's tutorial on Youtube and that seemed to speed up the game startup, but as soon as I clicked on a house to play the loading screen was still as slow as ever. I am very disappointed to have this issue as I have played the game less than 100 hours and the computer I have is less than a year old. I have a 13 inch MacBook Pro with Retina display and here are my specs: Processor 2.6 GHz Intel Core i5 - Memory 8 GB 1600 MHz DDR3 - Graphics Intel Iris 1024 MB. I hope this is the right place to get help for this, I am confused as where to get help and it seems it should be here. Thanks.
  • BluebellFloraBluebellFlora Posts: 7,089 Member
    Hi, I've been having trouble with TS4 Digital Deluxe for Mac ever since the beginning basically. My loading screens started out to be a decent length, but soon after started to become longer and longer. Then I added the Outdoor Retreat game pack and the loading screen times increased, and increased again with each addition ie. Get To Work and Luxury Party Stuff. Now my loading screens are always a minute and a half long plus, and there is now lag when changing speeds in the game and some sim freezing. I cleared out my cache properly following a simmer's tutorial on Youtube and that seemed to speed up the game startup, but as soon as I clicked on a house to play the loading screen was still as slow as ever. I am very disappointed to have this issue as I have played the game less than 100 hours and the computer I have is less than a year old. I have a 13 inch MacBook Pro with Retina display and here are my specs: Processor 2.6 GHz Intel Core i5 - Memory 8 GB 1600 MHz DDR3 - Graphics Intel Iris 1024 MB. I hope this is the right place to get help for this, I am confused as where to get help and it seems it should be here. Thanks.

    - Move your Sims 4 folder out of your Documents folder (instructions in the opening post) and try again.

    - Have you tried repairing your game? Again, instructions in the opening post.

    - Disable Origin in game, instruction in the opening post.
    apple-signature.png
  • BluebellFloraBluebellFlora Posts: 7,089 Member
    Updated.
    apple-signature.png
  • RainbowPeacockRainbowPeacock Posts: 1 New Member
    The problem I've been having in my game is that the game will load just fine and when I go into the select household to play screen, I would pick my main household and it would load then it would just go back to the select world screen. I DO use CC and I've gone through most of it. I'm stuck and need help. Anyone willing?
  • BluebellFloraBluebellFlora Posts: 7,089 Member
    The problem I've been having in my game is that the game will load just fine and when I go into the select household to play screen, I would pick my main household and it would load then it would just go back to the select world screen. I DO use CC and I've gone through most of it. I'm stuck and need help. Anyone willing?

    Does this still happen when you play a clean game after moving out The Sims 4 folder?

    apple-signature.png
  • norkalsimmernorkalsimmer Posts: 11 New Member
    edited June 2015
    BluebellFlora,

    Unfortunately nothing worked. The only thing that made the game fast again was letting the game create a new folder but that makes the game new again, meaning nothing I've done is in it. By the way, from now on when giving that advice you should say that the game will be 100% new, because if I had deleted the game I have played on I would have been extremely upset. God forbid someone else does with that advice. Now, is there a way to get all of my progress into this new game? I tried moving folders but nothing worked. Thanks.
  • BluebellFloraBluebellFlora Posts: 7,089 Member
    The only thing that made the game fast again was letting the game create a new folder but that makes the game new again, meaning nothing I've done is in it.

    Exactly. There is something borked in your user data. Maybe a corrupt save or CC/Mods?
    By the way, from now on when giving that advice you should say that the game will be 100% new, because if I had deleted the game I have played on I would have been extremely upset. God forbid someone else does with that advice.

    Why would you think to delete the game when I clearly advised you to move it? It is the first and most basic step to take when troubleshooting a problem with your game and is recommended in all help threads when dealing with a broken or poorly performing game. Sorry if you don't understand this.
    Now, is there a way to get all of my progress into this new game? I tried moving folders but nothing worked. Thanks.

    So you copied over your saves folder, loaded up the game and your previous saves weren't there? Did you read the instructions in the opening post about where to put them (it may be instructions for moving over Windows saves but the location is obviously exactly the same)? And you have the base game and any subsequent EPs/SPs you've bought installed?
    apple-signature.png
  • norkalsimmernorkalsimmer Posts: 11 New Member
    BluebellFlora,

    I figured out what I was doing wrong when moving my saves. You were right, I didn't put them in the right place. I was a little off. I did finally manage to put them in their proper place and the ran the game with the "new" sims folder with my saves transferred. The game ran fine without my saves in it, but now that my saves are in the game it is running extremely slow again. I don't have any cc/mods. So as you were alluding, perhaps I have a corrupt save? Also, just forget my other comment. I wasn't trying to be rude or anything, just trying to make a suggestion for people who just don't really know what they're doing but nvm. Anyway, thanks for helping thus far, but what should I do next?
  • BluebellFloraBluebellFlora Posts: 7,089 Member
    BluebellFlora,

    I figured out what I was doing wrong when moving my saves. You were right, I didn't put them in the right place. I was a little off. I did finally manage to put them in their proper place and the ran the game with the "new" sims folder with my saves transferred. The game ran fine without my saves in it, but now that my saves are in the game it is running extremely slow again. I don't have any cc/mods. So as you were alluding, perhaps I have a corrupt save? Also, just forget my other comment. I wasn't trying to be rude or anything, just trying to make a suggestion for people who just don't really know what they're doing but nvm. Anyway, thanks for helping thus far, but what should I do next?

    No worries. You can try fixing the corrupt save. I've never done it myself but there are various threads relating to it on these forums, EA's Answers HQ and other places on the web. You might try searching in the tech. forum as corrupt saves isn't a Mac exclusive issue.

    Auto save issue - http://answers.ea.com/t5/The-Sims-4/SOLUTION-Saved-with-newer-version-Save-Error-0-Can-t-Build-Walls/td-p/4205460

    The issue could also be that your saved game files are big and your Mac is struggling to cope with whatever you are doing in game, either graphics wise, how much is happening in the world, how much your Sims have in their inventory, how many in the household etc.

    Your graphics settings may be too high to cope, try turning them down.
    apple-signature.png
  • norkalsimmernorkalsimmer Posts: 11 New Member
    BluebellFlora,

    So after carefully following the instructions I find that none of my saves are corrupt. I have been playing with my graphic settings very low, in laptop mode. I find it strange that the problem would be my mac coping because it is less than a year old and I have only ever really used it for the internet. Is there anything else I should do, like delete photos/screenshots from the game in the files? I don't need them. Thanks again.
  • BluebellFloraBluebellFlora Posts: 7,089 Member
    I find it strange that the problem would be my mac coping because it is less than a year old and I have only ever really used it for the internet. Is there anything else I should do, like delete photos/screenshots from the game in the files? I don't need them. Thanks again.

    Yes, your Mac is only a year old but it has integrated graphics which aren't the best for gaming. Whilst it can happily handle the base game the more you add to the game the more work it has to do to run the game. If you are in a more populated part of the game it will lag more. Does your Sim have a ton of stuff in their inventory like harvestables? That can also cause issues. From within your save, create a new Sim and move them into a small lot - how does that household play?
    apple-signature.png
Sign In or Register to comment.
Return to top