August 22 - It's patch day for The Sims 4 on console! Read the patch notes here.
August 23 - Ready for the Friday Highlight? Check it out here!
August 15 - We have updated the forum rules. Learn more here.

- The Sims 4 on Boot Camp & Virtual Machines -

Comments

  • BluebellFloraBluebellFlora Posts: 7,057 Member
    All updates come from Apple. As I said, we have the same graphics card and my game is fine, as are other peoples' games who have posted about their Boot Camp and TS4 experiences. Can you post a screenshot of your game?
    apple-signature.png
  • SweetK411SweetK411 Posts: 87 Member
    Lol i dunno how to sorry im terrible at these things
  • SweetK411SweetK411 Posts: 87 Member
    Cmd shift 3 doesn't work.
  • BluebellFloraBluebellFlora Posts: 7,057 Member
    - Take a picture in game by pressing C
    - Use an image hosting site like http://tinypic.com to upload your picture. You can find your screenshot by navigating to Documents > Electronic Arts > The Sims 4 > Screenshots
    - Start a new comment on here and click on the page icon in the writing tools right above the comment box. Copy and paste your image URL into the image field that appears.
    apple-signature.png
  • SweetK411SweetK411 Posts: 87 Member
    Ok thanks bluebell i'll have to do it when i get back home. But thanks so far 4 all the help :-)
  • Bk889Bk889 Posts: 30 Member
    Playing it on a 2012 15" retina macbook. Tad overclock on the GPU, 650m clocked at 1035mhz. Running at 2560x1440 on a Thunderbolt Display with the Ultra settings. Runs great, but running bootcamp for a single game is not going to happen in the long run... It would be really nice to get an ETA for the mac version.


    Specs:

    Core i7 2.3ghz Quad core
    Nvidia 650m 1024mb
    8gb DDR3 1600Mhz
  • SweetK411SweetK411 Posts: 87 Member
    Just thought i'd let you know it's working well now & on ultra settings minus the dimness from the brightness comes & goes which is weird but thanks again 4 the help :)
  • BluebellFloraBluebellFlora Posts: 7,057 Member
    SweetK411 wrote: »
    Just thought i'd let you know it's working well now & on ultra settings minus the dimness from the brightness comes & goes which is weird but thanks again 4 the help :)

    Great news. What did you do to make it work?
    apple-signature.png
  • msarobixmsarobix Posts: 192 Member
    I was having a bit of trouble updating Windows last night and I ended up removing my partition and starting from scratch. It was a pain and an all day adventure, but I now have windows up to date through BootCamp and TS4 re-installed. I really hate Microsoft.
  • athinasimsathinasims Posts: 157 Member
    I couldn't agree more. Microsoft is a pain as Windows is too. If I didn't want to play Sims 4 I wouldn't install Windows on my Mac ever!
    MICHAEL JACKSON XSCAPE
  • SweetK411SweetK411 Posts: 87 Member
    edited September 2014
    When i uninstalled the update 4 the Nvidia graphics driver thats when i noticed the game started lagging like crazy so what i did was re install & now it works great i& doesn't say un recognized video card no more & i have it on ultra settings & everything. Oh & the brightness thing was something soo silly it was because it was auto brightness lol
  • BluebellFloraBluebellFlora Posts: 7,057 Member
    Ok. Just be careful when you update through 3rd parties and don't use Apple's Boot Camp updates, it doesn't always work. It's still odd that we have the same graphics card yet you had the error message. Are you running Windows 8?
    apple-signature.png
  • BluebellFloraBluebellFlora Posts: 7,057 Member
    -bumping-
    apple-signature.png
  • tyenetyene Posts: 65 Member
    Unless they reveal they won't make MAC version (or unless there's no info until the new year) I refuse to bootcamp just for that reason. I really want them to make TS4 for Mac. I have TS3 and it runs generally great on my MacBook Air (and I have almost all expansions). I really really can't wait for TS4
  • BluebellFloraBluebellFlora Posts: 7,057 Member
    tyene wrote: »
    Unless they reveal they won't make MAC version (or unless there's no info until the new year) I refuse to bootcamp just for that reason. I really want them to make TS4 for Mac. I have TS3 and it runs generally great on my MacBook Air (and I have almost all expansions). I really really can't wait for TS4

    "One last thing, PLEASE don't use this thread to moan about TS4 not currently being available for OS X, this is a help thread :)"
    apple-signature.png
  • tyenetyene Posts: 65 Member
    Noted. Sorry. It's my first day at the forum :)
  • AshleeMDAndradeAshleeMDAndrade Posts: 53 Member
    Model Name: MacBook Pro
    Model Identifier: MacBookPro9,2
    Processor Name: Intel Core i5
    Processor Speed: 2.5 GHz
    Number of Processors: 1
    Total Number of Cores: 2
    L2 Cache (per Core): 256 KB
    L3 Cache: 3 MB
    Memory: 4 GB
    Boot ROM Version: MBP91.00D3.B09
    SMC Version (system): 2.2f44
    Serial Number (system): C1MJMHNMDTY3
    Hardware UUID: DC77DD51-D8B9-5344-ACCD-0A0896B602D0
    Sudden Motion Sensor:
    State: Enabled

    Here's my specs, thanks for the help. Let me know if you need more info, I'm not sure if it's enough. Again, I'm the one whose running sims 4 on bootcamp and it keeps crashing >_< thank you so much again..
    <3
  • BluebellFloraBluebellFlora Posts: 7,057 Member
    tyene wrote: »
    Noted. Sorry. It's my first day at the forum :)

    :)

    apple-signature.png
  • BluebellFloraBluebellFlora Posts: 7,057 Member
    Model Name: MacBook Pro
    Model Identifier: MacBookPro9,2
    Processor Name: Intel Core i5
    Processor Speed: 2.5 GHz
    Number of Processors: 1
    Total Number of Cores: 2
    L2 Cache (per Core): 256 KB
    L3 Cache: 3 MB
    Memory: 4 GB
    Boot ROM Version: MBP91.00D3.B09
    SMC Version (system): 2.2f44
    Serial Number (system): C1MJMHNMDTY3
    Hardware UUID: DC77DD51-D8B9-5344-ACCD-0A0896B602D0
    Sudden Motion Sensor:
    State: Enabled

    Here's my specs, thanks for the help. Let me know if you need more info, I'm not sure if it's enough. Again, I'm the one whose running sims 4 on bootcamp and it keeps crashing >_< thank you so much again..

    - What version of Windows are you using?
    - What's your graphics card?
    - When is it crashing?
    - Have you installed any Mods? If so, did you move them out before the latest patch?

    apple-signature.png
  • NyosimNyosim Posts: 799 Member
    edited September 2014
    Hi @BluebellFlora,

    I'm thinking about Bootcamping my Mac for TS4 and TS2 Ultimate Collection, and I just wanted to get your thoughts on how you TS4 would run with my specs. :)

    Mid-2010 iMac 21.5''
    Processor: 3.06 GHz Intel Core i3
    Memory: 4 GB 1333 MHz DDR3
    Graphics: ATI Radeon HD 4670 256 MB
    Software: OS X 10.9.4 (Mavericks)

    Edit 1: According to Apple, my Windows OS will be Windows 7 Home Premium (64-bit)

    Thanks in advance!
    900woh.png
  • BluebellFloraBluebellFlora Posts: 7,057 Member
    Have you checked the system requirements? It looks like it should run fine.
    apple-signature.png
  • NyosimNyosim Posts: 799 Member
    Have you checked the system requirements? It looks like it should run fine.

    I ask since this thread caught my eye
    (Sorry, I can't link it with text, writing on my ipod):

    http://forums.thesims.com/en_US/discussion/774696/updated-supported-graphics-card-list-the-sims-4-edition

    @ the ATI Raedon section, my graphics card can handle the game, just not on maxed out settings. I'm just curious if I'll end up with demon babies or something o_o;
    900woh.png
  • SamiJadeSamiJade Posts: 2 New Member
    Hi,
    I installed TS4 onto Parallels 9 running Win7 today, and I'm having problems with in-game menus. They have lines through them, pink and white if I member correctly. The Main menu (where you can select to quit game) is okay, but the others, including in CAS and all in-game like needs and stuff, are not. It makes it quite hard and unenjoyable to play. The rest is fine, graphics look great, sims are moving (mostly) smoothly. I originally had an issue with there being no sound but updating windows fixed that. Has anyone heard of this problem with the menus and any ideas how to fix it? I've tried changing from low graphics to ultra to high and I'm unsure if I'm running in the laptop mode as the part where what I'm assuming is the checkbox, is just blank. I've clicked there a few times while playing around so I really have no clue.
    My specs are:
    15 inch MacBook Pro with retina display
    Processor: 2 GHz Intel Core i7
    Memory:8GB 1600 MHz DDR3
    Graphics :Intel Iris Pro
    Software: 10.9.4

    Could it possibly be the Intel Iris Pro? :-(
    I've considered Bootcamping, although I really don't want to, but if it's the Intel Iris Pro, then would Bootcamping even make a difference?
    TIA :-)
  • ArielGrintArielGrint Posts: 50 Member
    edited September 2014
    SamiJade wrote: »
    Hi,
    I installed TS4 onto Parallels 9 running Win7 today, and I'm having problems with in-game menus. They have lines through them, pink and white if I member correctly. The Main menu (where you can select to quit game) is okay, but the others, including in CAS and all in-game like needs and stuff, are not. It makes it quite hard and unenjoyable to play. The rest is fine, graphics look great, sims are moving (mostly) smoothly. I originally had an issue with there being no sound but updating windows fixed that. Has anyone heard of this problem with the menus and any ideas how to fix it? I've tried changing from low graphics to ultra to high and I'm unsure if I'm running in the laptop mode as the part where what I'm assuming is the checkbox, is just blank. I've clicked there a few times while playing around so I really have no clue.<br />
    My specs are:
    15 inch MacBook Pro with retina display
    Processor: 2 GHz Intel Core i7
    Memory:8GB 1600 MHz DDR3
    Graphics :Intel Iris Pro
    Software: 10.9.4

    Could it possibly be the Intel Iris Pro? :-(
    I've considered Bootcamping, although I really don't want to, but if it's the Intel Iris Pro, then would Bootcamping even make a difference?
    TIA :-)

    hey, what version of parallels are you using? if it's 9.23something, try updating it till the latest one - I had this problem when I was trying to make the demo work, and somehow the older builds of parallels 9 make the purple lines appear...
  • AnthonySmith1288AnthonySmith1288 Posts: 43 New Member
    I saw someone had a MBA it will turbo boost to 2.0 GHz automatic when the game starts, so you do meet the system requirements.
Sign In or Register to comment.
Return to top