April 7 - We just released a patch Day for The Sims 4 on PC/MAC. Patch notes here.

Problem Resolved - Unable to save world.

Hi

So I'm having a weird problem with my world at the moment and I'm not sure what is causing it. Basically, I've done an export of my world to build in game but when I save and open it up from the main menu I'm being told that it requires expansion pack content which I no longer have in my system and therefore cannot open it. I have all SPs and EPs installed so clearly this isn't the case.

Possible causes from things I've done up till now:
1 - Houseboats
At the start of my project, I was playing around with houseboats and accidentally had all of the hulls appear on top of each other. I saved this as I needed the edited height and figured that if I delete the lot, the hulls would go away. This did not happen. I opened up edit in game and deleted them using TestingCheats which did get rid of them. The process however created the next possible cause.

2 - Global Layer
After doing what I needed in Edit-In-Game (figuring out how to use the gangway object), I noticed that global layer had stuff in it. I took no notice of this and continued on with my world. Before exporting my world I tried to delete the things that had formed in the global layer but every time I try I keep getting told that I have to delete it from Edit-In-Game, something which I can't do because I have no idea where to look for these objects especially because CAW shows them invisible at some weird edge of the world which I probably can't access.

3 - Cache
After exporting the world (yesterday) I today decided to install and uninstall some Store Content and custom content I didn't really want bloating up my catalogue. I always uninstall everything from the launcher then reinstall. I suspect the game could be trying to load something from one of these caches which no longer exists and is throwing me the error.

So does anyone have any idea on how I can salvage my world?

Comments

  • CinderellimouseCinderellimouse Posts: 19,369 Member
    edited December 2013
    Oh no! >_<

    I'm going to have a random guess and hopefully I might be able to help.

    Can you still open it and save and everything as normal in CAW?

    Personally, I would export it again but with a new name and WPID file: http://www.den.simlogical.com/denforum/index.php?topic=1264.0 and see if the new export has the same issue.
  • Rflong7Rflong7 Posts: 35,899 Member
    edited December 2013
    Hi :)

    I'm not sure if it has anything to do with the CC, did you use any in the world or did you check the world with Custard for CC?

    What did you name the world- does it have a . in the Name? Iirc, those can mess up save option in game.

    Good luck :D
  • Verbaltee99Verbaltee99 Posts: 403 New Member
    edited December 2013
    Tried both suggestions and helped.
    Thank you Cinderellimouse and Rflong7.
Sign In or Register to comment.
Return to top