Forum Announcement, Click Here to Read More From EA_Cade.

Advanced Rendering bug in diving

Hi guys!
I'm brazilian and I know, my English sucks. So I'll try to show you a bug that's happening in my game in diving mode with advanced rendering.

WITHOUT advanced rendering:
Screenshot-275.jpg

WITH advanced rendering:
Screenshot-276.jpg

My video card is Geforce 9600 GT. I was talking about it in a Sims fan forum and other players reported the same problem with advanced rendering in diving mode.

Too bad. :(
Zvt4d0O.gif

Comments

  • Options
    EvalenEvalen Posts: 10,223 Member
    edited June 2013
    so I don't know anything
    so can you explain, what is advance rendering and how do you know you have it. and what does it do.
    I don't quite know the differnece in the pictures except one is a little darker then the other.
    so can you turn it off and on. and what is the bug you are talking about.
    Do not get upset with my questions as I do not understand how this works.
  • Options
    182Tess182Tess Posts: 121 Member
    edited June 2013
    From the pictures it looks like either something else in your hardware configuration can't handle it, or that is in fact, what underwater is supposed to look like.

    I am in Australia so we haven't got the game yet.

    I would suggest posting this in Technical help.
  • Options
    auricio288auricio288 Posts: 149 Member
    edited June 2013
    Evalen wrote:
    so I don't know anything
    so can you explain, what is advance rendering and how do you know you have it. and what does it do.
    I don't quite know the differnece in the pictures except one is a little darker then the other.
    so can you turn it off and on. and what is the bug you are talking about.
    Do not get upset with my questions as I do not understand how this works.
    The graphic in the second image doesn't look smooth. It's pretty obvious, but ok... I mean, thanks for helping! ;)
    Zvt4d0O.gif
  • Options
    abeautifulletdownabeautifulletdown Posts: 304 Member
    edited June 2013
    Evalen wrote:
    so I don't know anything
    so can you explain, what is advance rendering and how do you know you have it. and what does it do.
    I don't quite know the differnece in the pictures except one is a little darker then the other.
    so can you turn it off and on. and what is the bug you are talking about.
    Do not get upset with my questions as I do not understand how this works.

    Advanced rendering is an option in the graphics settings. It changes the way the game renders textures. Grass, pet, pool and many other textures can look very grainy and poor when the option is off, though turning it on can reduce game performance if your computer can't handle it. The difference in the pictures is the detail. Look at the detail of the mermaid stone carving in the first picture. Almost invisible in the second and the rock looks grainy. Same thing with the scales on the male mermaid.

    Edit: typos.
  • Options
    abeautifulletdownabeautifulletdown Posts: 304 Member
    edited June 2013
    auricio288 wrote:
    Hi guys!
    I'm brazilian and I know, my English sucks. So I'll try to show you a bug that's happening in my game in diving mode with advanced rendering.

    WITHOUT advanced rendering:
    Screenshot-275.jpg

    WITH advanced rendering:
    Screenshot-276.jpg

    My video card is Geforce 9600 GT. I was talking about it in a Sims fan forum and other players reported the same problem with advanced rendering in diving mode.

    Too bad. :(

    Also to add to my above post, GeForce 9600 GT is known for having graphical issues with TS3 and its eps.
  • Options
    ShinobuTypeErrorShinobuTypeError Posts: 2,838 Member
    edited June 2013
    Someone posted in another thread that you have to have reflections and lighting/shadows set to "high" in order to get good underwater graphics. Also, correct me if I'm wrong, but I believe that after enabling Advanced Rendering you must restart the game in order for the changes to apply correctly.
    "It's like there's a pink elephant in the room and no one's allowed to talk about it."
  • Options
    JazminAdoreJazminAdore Posts: 1,434 Member
    edited June 2013
    I'm having the same issue, I have geforce gtx 650 ti. All of my settings are the highest they can be except lot detail which is on four. I wonder why, I thought advanced rendering was supposed to enhance textures and whatnot...?
    1238765_10201357648636928_204929354_n.jpg
  • Options
    JenieusaJenieusa Posts: 5,142 Member
    edited June 2013
    without AR...ground/textures and pets look horrible

    with AR it all looks normal...no way i am unchecking mine
  • Options
    conundrum_dragonconundrum_dragon Posts: 794 Member
    edited June 2013
    I have the GeForce GT 620 wonder if that will be an issue when I get under water, may just save time and drop Advanced Rendering now,
  • Options
    MafiastyleMafiastyle Posts: 714 Member
    edited June 2013
    I have rendering on and this is what mine looks like
    screenshot_original.jpg
    To me its super blurry on sims - My Graphics Card is a Radeon HD 7970. I am baffled, but C'est la vie
    39d589ef4e5a6ca8bd17fc4bfd12fec6.jpg
    Babies everywhere, thank you shadow cat.

  • Options
    auricio288auricio288 Posts: 149 Member
    edited June 2013
    I'm having the same issue, I have geforce gtx 650 ti. All of my settings are the highest they can be except lot detail which is on four. I wonder why, I thought advanced rendering was supposed to enhance textures and whatnot...?
    Same problem here. That's the point. I really will not disable advanced rendering just because of the dive mode, inasmuch as all the graphic will worsen.

    I hope that fix it... As noticed, just some video card models have the issue.
    Zvt4d0O.gif
  • Options
    JackBrevesJackBreves Posts: 511
    edited June 2013
    I've been having the same issue. When I turned off advanced rendering, it only sort of helped. Things were less pixilated and more fluent, but a lot of the dive area was gray and blurry; not to mention the rest of Isla Paradiso was the same, making it less paradise-y. I've switched it back, and'll keep my ears pinned for a solution that truly fixes the graphics while not taking away from the game.
  • Options
    aliciakayray86aliciakayray86 Posts: 71 Member
    edited June 2013
    I've been having the same problem. I wasn't sure if it was supposed to look like that bc your under water. It makes it very difficult to look around and find treasure and fish. :(
  • Options
    SkewedReality04SkewedReality04 Posts: 1,450 Member
    edited June 2013
    Just found out that mine is doing the same thing. I have an ATI card and I thought we'll gee they could have at least made the underwater look better. Turns out they did, but there's a weird glitch.
  • Options
    afpickrenafpickren Posts: 220 Member
    edited June 2013
    Yep, me too. Wow, this is disappointing. I was wondering why it was still a bit fuzzy :\
    Origin ID: TitanSimmer
    Twitter: TitanSimmer
    Tumblr: TitanSimmer
  • Options
    ShinobuTypeErrorShinobuTypeError Posts: 2,838 Member
    edited June 2013
    I'm having the same issue, I have geforce gtx 650 ti. All of my settings are the highest they can be except lot detail which is on four. I wonder why, I thought advanced rendering was supposed to enhance textures and whatnot...?


    I have the same exact card.. haven't tried diving underwater, yet. I wonder if I'll have the same issue... I hope not, lol... because my GPU is generally considered to be a pretty good one. You may need to update to the most recent driver if you haven't already.
    "It's like there's a pink elephant in the room and no one's allowed to talk about it."
  • Options
    Angeltear6547Angeltear6547 Posts: 19 New Member
    edited June 2013
    Thank you for finding out this bug. I was so disappointed when I saw that my underwater was such low resolution. I couldn't see fish or treasure. I turned it off like you suggested and its so crisp and clear now! I am so relieved I can play underwater now.
    Sucks that I have to turn it off but it'll do until an official fix comes out!!
  • Options
    sam123sam123 Posts: 4,539 Member
    edited June 2013
    Will they ever fix this? I have the ATI 5670 card and this issue sucks. I hope they really do make a fix for this. I feel like this issue is somehow related to the Pets issue concerning the fur.
  • Options
    gogogorillahgogogorillah Posts: 30
    edited June 2013
    I had the same problem too- what worked for me was going to "options" in the menu tab and changing the "lighting and shadows" to high.
  • Options
    antsims310antsims310 Posts: 1,154 New Member
    edited July 2013
    I think I have this same problem though it doesn't really bother me. My sims can still go scuba diving. I don't want to turn off advanced rendering because then everything will just not look nice.
  • Options
    SchantalSchantal Posts: 3,082 Member
    edited July 2013
    Having the same issue and I have the best graphic card on the market (Nvidia 680m) as well as a gaming rig so its def not a "hardware" problem.

    I honestly was so confused at first and thought that they just didn't bother with the graphics under the water until I saw your thread and many others and realized it isn't suppose to look like that.

    Edit: gogogorillah, thanks so much for the suggestion, going to try that when I go into my game next time. I thought I had everything set to high, but maybe that one isn't. Gonna check when I play next :-).
  • Options
    EiraRoseEiraRose Posts: 203 Member
    edited July 2013
    Unfortunately, I'm having the same issue, only mine is amplified.
    With Advanced Rendering on, my game runs as per usual... except that all lots that are underwater/partially underwater have a solid blue floor. There is no sandy texture... nothing. I turn off advance rendering and everything underwater/partially underwater works fine... but suddenly the land becomes masses of giant yellow blobs. If I want to dive under water, I have to turn advance rendering off. If I want to even come out of the water I have to turn it back on, save and restart my game. It's a frustrating game of tag. I hope EA gets it together and fixes this soon. The way my game is... it's unplayable.

    Edit to say my computer is a year old, and my graphics card is definitely above par (AMD Raedon HD 7770). I have a great processor and plenty of space and CPU processing power.
  • Options
    ZeulaZeula Posts: 506 New Member
    edited July 2013
    I have this same problem. I usually load the game with it turned on, then turn it off, then back on again and it fixes underwater. If I load my game with it off it makes the terrain on the whole map all messed up.
  • Options
    TheTallDarkTruthTheTallDarkTruth Posts: 4
    edited July 2013
    Happening to me too. I was wondering why the underwater graphics were so bad on my game but on other peoples screen shots they looked beautiful I found this forum. Unchecked Advanced rendering and its fine underwater and when I went back to land it didn't look any different so I though I wonder what AR does so I check it on again to see the difference and nothing changed. I went scuba diving forgetting I had checked AR on again and it was crystal clear (like the first time I unchecked AR). Really really weird. It's ll working fine and clear now. Hmmm. Strange
Sign In or Register to comment.
Return to top