February 15 - Friday Highlight is here, waiting for you to check it out!
How do we choose our Maxis Faves? - Our curation guide got a revamp! If you want to get an insight on how Maxis Faves are curated, check it out!

Graphics Glitches - NVIDIA GeForce GT cards identified - Patch 1.63 FIXES this issue.

I can play Seasons fine but when the season changes to Autumn (Fall) this happens:

screenshot-34.jpg

screenshot-33.jpg

screenshot-32.jpg

screenshot-29.jpg

screenshot-31.jpg

screenshot-27.jpg

All the leaves disappear off the trees but do not lie on the ground, they just disappear. In Map View the trees look gloriously autumnal in loads of different colours. The ground seems to rise up and looks really blocky and plum. In the 4th and 5th pictures those are water lilies you can see floating above the house! You can only see this blockiness from certain angles - camera low down to the ground looking up mainly.

When the full moon kicks in the graphics return to normal.

When the season changes to Winter everything is normal again and leaves are back on the trees:

screenshot-37.jpg

screenshot-38.jpg

As you can see there is nothing wrong with the graphics so it's not a driver issue.

Specs:
2012 15" MacBook Pro
OS 10.8.2
2.6Ghz Intel Core i7
8Gb 1600MHz DDR3
NVIDIA GeForce GT 650M 1024Mb

- I have no Mods or 3rd party CC, a completely vanilla game.
- I'm playing in one of my worlds, BlueBay Retreat which 100% does not have any 3rd party CC.
- My game is patched up to date 1.42.130.019002.
- I have all EPs and SPs to date apart from Showtime, Sweet Treats and Diesel.
- Memories are off. I'm logged into the launcher but not logged in for the social aspect in-game.
- All my installs are from disc, no digital downloads.

Just to clarify, the game isn't crashing or freezing, I've had it playing for about 8 hours today.

This only happens in the Fall season.
apple-signature.png

Comments

  • BluebellFloraBluebellFlora Posts: 7,033 Member
    edited November 2012
    Affected Macs:

    BluebellFlora -
    2012 15" MacBook Pro
    2.6Ghz Intel Quad Core i7
    8Gb RAM
    NVIDIA GeForce GT 650M 1024Mb
    OS 10.8.2
    Patch 1.42

    shortmikez -
    2012 15" MacBook Pro
    2.6Ghz Intel Quad Core i7
    8Gb RAM
    NVIDIA GeForce GT 650M 1024Mb
    OS 10.8.2
    Patch 1.42

    yenial -
    2012 15" MacBook Pro
    2.3Ghz Intel Quad Core i7
    8Gb RAM
    NVIDIA GeForce GT 650M 1024Mb
    OS 10.8.1
    Patch 1.42

    Datch -
    2012 15" MacBook Pro
    2.3Ghz Intel Quad Core i7
    8Gb RAM
    NVIDIA GeForce GT 650M 512Mb
    OS 10.8.2
    Patch 1.42

    via crinrict -
    2010 13" MacBook Pro
    2.4Ghz Intel Core 2 Duo
    4Gb RAM
    NVIDIA GeForce GT 320M 256Mb
    OS 10.7.5
    Patch 1.42

    Spectacularly -
    2010 15" MacBook Pro
    2.66Ghz Intel Core i7
    4Gb RAM
    NVIDIA GeForce GT 330M 512Mb
    OS 10.6.8
    Patch 1.42

    BethandMolson
    2012 15" MacBook Pro
    2.6Ghz Intel Quad Core i7
    16Gb RAM
    NVIDIA GeForce GT 650M 1024Mb
    OS 10.8
    Patch 1.42

    BodaciousFun -
    2008 15" MacBook Pro
    2.4Ghz Intel Core 2 Duo
    2Gb RAM
    NVIDIA GeForce GT 8600M 256Mb
    OS 10.5.8
    Patch 1.42
    Post edited by Unknown User on
    apple-signature.png
  • caspinwallcaspinwall Posts: 916 Member
    edited November 2012
    The horror! Very strange looking. Let's see if any other Mac simmers who have the game working at the moment get the same thing in Autumn. Or this could be something that isn't Mac-specific?
    GeneralSig_SF_03.png
  • extremeasaurextremeasaur Posts: 2,701 Member
    edited November 2012
    that is a really odd effect, and you can play through it?
  • BluebellFloraBluebellFlora Posts: 7,033 Member
    edited November 2012
    Awful isn't it? Yep, the game carries on playing fine and I just have to move the camera around to see my Sim.

    It's ONLY in Autumn, all other seasons are fine and the full moon event (when everything has a greenish tinge to it) temporarily stops it. Think I may post in Crin's thread too. No guarantee this will be seen over here :evil:
    apple-signature.png
  • extremeasaurextremeasaur Posts: 2,701 Member
    edited November 2012
    are they trees that are on your land? Can you remove them, or is all over the world?

    Does it do it other worlds?
  • BluebellFloraBluebellFlora Posts: 7,033 Member
    edited November 2012
    All over the world. That's a 10x10 lot. Haven't tried another world yet because I find the loading times of EA's world pretty unbearable. I'll try Hidden Springs later.
    apple-signature.png
  • Bel008Bel008 Posts: 2,370 Member
    edited December 2012
    I have a 15 inch Mac Book Pro 2012 OS 10.8.2
    Processor 2.6 GHz Intel Core i7
    Memory 8 GB 1600 MHz DDR3
    Graphics NVIDIA GeForce GT 650M 1024 MB

    I am playing sunlit tides. Only the festival lot has been doing that the rest of the world seems ok. It started in Autumn and continued on with the winter festival. My sims house is fine and the leaves did fall on the ground. If you move in and out of the festival lot with the camera you can get some screen shots without it but it is not great. I have never had this before seasons.

    Screenshot-15.jpg"width=600"

    Screenshot-19.jpg"width=600"

    Edited to include screenshots from the winter festival.

    Post edited by Unknown User on
  • mcruthiemcruthie Posts: 83 New Member
    edited November 2012
    I have this kind of issue too. If I remember correctly I saw this after I bought Lucky Palms and Sunlit Tides. Will post some pics if I see this again. Didn't complain much because I thought it was because of the custom hair I have.
  • BluebellFloraBluebellFlora Posts: 7,033 Member
    edited November 2012
    What graphics cards do you guys have? Shortmikez and I have the same Macs and are both experiencing this, only in Autumn, the other seasons are fine.

    Thanks to Crinrict who's come across this before as it's in her bug thread. It seems to be the NVIDIA GeForce GT 650M 1024Mb which is the culprit.

    Not game breaking like so many others are unfortunately experiencing but yet another issue that only EA can fix :evil:
    apple-signature.png
  • shortmikezshortmikez Posts: 154 New Member
    edited November 2012
    What graphics cards do you guys have? Shortmikez and I have the same Macs and are both experiencing this, only in Autumn, the other seasons are fine.

    Thanks to Crinrict who's come across this before as it's in her bug thread. It seems to be the NVIDIA GeForce GT 650M 1024Mb which is the culprit.

    Not game breaking like so many others are unfortunately experiencing but yet another issue that only EA can fix :evil:

    BluebellFlora I posted my topic in the Seasons and someone thinks its to do with the game not rendering fog properly. I guess that was just a suggestion.
  • BluebellFloraBluebellFlora Posts: 7,033 Member
    edited November 2012
    Crin thought it might be leaves as it's only in Autumn. Do you have Supernatural installed shortmikez? If so, does it happen during a full moon? My seasons are only on 3 day cycles so when it comes round to Autumn again I'll turn fog off and see what happens :)
    apple-signature.png
  • crinrictcrinrict Posts: 18,525 Member
    edited November 2012
    Would it help you guys if I made a post in my blog directing people to this thread to collect more data ?
    Crinrict's Help Blogs -- Twitter
    Please do not send me PMs/post on my wall if you're looking for help. I can't attend to those. You can find me at AnswerHQ.
    How to report bugs at AnswersHQ
    AHQ Tutorial

  • BluebellFloraBluebellFlora Posts: 7,033 Member
    edited November 2012
    crinrict wrote:
    Would it help you guys if I made a post in my blog directing people to this thread to collect more data ?

    Yes please Crin! I'm going to do a quick entry on mine. I've covered the other threads already but not yet this one.
    apple-signature.png
  • caspinwallcaspinwall Posts: 916 Member
    edited November 2012
    It's just great that no gurus at all have turned up in this forum to help Mac simmers, nobody from EA bothers to respond in Crin's bug thread to let her know that her efforts are helping, but the simguru in the Season's thread is busy collating data about whether there are enough coats in Outerwear!
    GeneralSig_SF_03.png
  • GBA91101Nver4getGBA91101Nver4get Posts: 4,965 Member
    edited November 2012
    What graphics cards do you guys have? Shortmikez and I have the same Macs and are both experiencing this, only in Autumn, the other seasons are fine.

    Thanks to Crinrict who's come across this before as it's in her bug thread. It seems to be the NVIDIA GeForce GT 650M 1024Mb which is the culprit.

    Not game breaking like so many others are unfortunately experiencing but yet another issue that only EA can fix :evil:

    I have a mid 2011 iMac with a ATI radeon 6770M hd graphics card. So far my game with seasons has played great. The only season i've experienced is summer. :) Hopefully your graphics will go back to normal. :)
    Nobody does it better, Steve Jobs you simply are the best RIP 10-5-11
  • crinrictcrinrict Posts: 18,525 Member
    edited November 2012
    Gonna do a post after I put the little one to bed.

    I'm sure you don't mind if I borrow some of those pics :)
    Crinrict's Help Blogs -- Twitter
    Please do not send me PMs/post on my wall if you're looking for help. I can't attend to those. You can find me at AnswerHQ.
    How to report bugs at AnswersHQ
    AHQ Tutorial

  • BluebellFloraBluebellFlora Posts: 7,033 Member
    edited November 2012
    Course not ;)
    apple-signature.png
  • shortmikezshortmikez Posts: 154 New Member
    edited November 2012
    Crin thought it might be leaves as it's only in Autumn. Do you have Supernatural installed shortmikez? If so, does it happen during a full moon? My seasons are only on 3 day cycles so when it comes round to Autumn again I'll turn fog off and see what happens :)

    Sorry, I don't have Super Natural as I had no interest in that expansion.
  • shortmikezshortmikez Posts: 154 New Member
    edited November 2012
    What graphics cards do you guys have? Shortmikez and I have the same Macs and are both experiencing this, only in Autumn, the other seasons are fine.

    Thanks to Crinrict who's come across this before as it's in her bug thread. It seems to be the NVIDIA GeForce GT 650M 1024Mb which is the culprit.

    Not game breaking like so many others are unfortunately experiencing but yet another issue that only EA can fix :evil:

    I have a mid 2011 iMac with a ATI radeon 6770M hd graphics card. So far my game with seasons has played great. The only season i've experienced is summer. :) Hopefully your graphics will go back to normal. :)

    Please tell us how fall plays out for you
  • crinrictcrinrict Posts: 18,525 Member
    edited November 2012
    OK. Made a post here: http://sims3.crinrict.com/en/2012/11/seasons-graphic-glitch-on-macs.html

    If you have any news, please let me know in the bug thread.
    Crinrict's Help Blogs -- Twitter
    Please do not send me PMs/post on my wall if you're looking for help. I can't attend to those. You can find me at AnswerHQ.
    How to report bugs at AnswersHQ
    AHQ Tutorial

  • BluebellFloraBluebellFlora Posts: 7,033 Member
    edited November 2012
    Of course, thanks Crin :)
    apple-signature.png
  • SpectacularlySpectacularly Posts: 10 New Member
    edited November 2012
    My game has been doing this too! I thought it was so weird! It does this in both autumn and winter. During autumn the leaves still fall on the ground, and my sims can rake the piles, etc. But the glitches are so weird! Like you said, I only have to move the camera to see my sim, but it's still strange.
  • BluebellFloraBluebellFlora Posts: 7,033 Member
    edited November 2012
    If you're experiencing it too then please can you post your Mac specs. to help us work out the issue? :)
    apple-signature.png
  • yenialyenial Posts: 198 New Member
    edited November 2012
    I am having the exact same issue as in the pictures!
    I hope EA will soon release a patch to fix it.

    My specs:

    2012 15" MacBook Pro
    OS 10.8.1
    2.3Ghz Intel Core i7
    8Gb 1600MHz DDR3
    NVIDIA GeForce GT 650M 1024Mb

    -No mods or CC's.
    -The game is patched.
    -Memories are off and I am not logged in the game.
    -All of the EP's and SP's and the base game are installed from the original CD's.
  • mcruthiemcruthie Posts: 83 New Member
    edited November 2012
    Hello again,

    My specs:

    Early 2011 13” MacBook Pro
    2.7Ghz Intel Core i7
    16Gb RAM
    Intel HD 3000 512Mb

    OSX Mountain Lion

    - All EPs and SPs

    I did not encounter this new graphics glitch last night and makes me realize.. could be because I upgraded my RAM to 16Gb before Seasons was released? Hmmm..



Sign In or Register to comment.
Return to top