This site will go into read-only mode on July 18th as the new Forums.EA.com are now live.

Game Telling Me My Login is Invalid. Anyone Else?

This made me a little edgy after hearing about some people's accounts being hacked....


I just started the game and after it automatically tried to log me in it tells me my login is invalid. I try again, and the same thing happens. I went to the internet logged out of the website and then logged back in and it worked fine and I am able to post this topic.

Is this something I should be concerned about or has anyone else encountered this problem?

Comments

  • Options
    Cat0EyeCat0Eye Posts: 4,629 New Member
    edited November 2012
    I had this last night too, but I changed my password yesterday so I thought it may have to do with that. After getting out of game then back in it let me log on so I am not sure what was going on.
  • Options
    LittleVLittleV Posts: 8,565 Member
    edited November 2012
    Well I just changed my password just to be safe. It's strange the website has no issue, but the game doesn't like my password :?
  • Options
    Cat0EyeCat0Eye Posts: 4,629 New Member
    edited November 2012
    That was my issue too...but it seemed to work its self out. I thought it was my game, like a saved password or something...I wonder if there is a delay when you change your password.
  • Options
    LittleVLittleV Posts: 8,565 Member
    edited November 2012
    I don't know. Possibly, however this happened without me ever changing my password in the first place, so it was saying that the password I have always had since I signed up on the website was invalid. I will have to try it again later I guess
  • Options
    KoinuRyokiKoinuRyoki Posts: 168 New Member
    edited November 2012
    I was having that issue yesterday, I change my password like 3 times and I couldn't log from inside the game cause it said it was invalid, I did freaked out a bit, but I was able to log in the website fine, so I just change my pass again and I was able to log in perfectly fine.
  • Options
    bob007bob007 Posts: 10,062 Member
    edited November 2012
    I got a message saying I was disconnected from the server. The launcher been like that for several hours. A short time ago it started working again.
    I do not work for EA nor do I have any association with EA. I am a gamer helping other gamers.
  • Options
    DruscyllaDruscylla Posts: 2,532 Member
    edited November 2012
    I changed my password on Tuesday and haven't been able to login since. I also can't see people's avatars anymore, the main home page for sims 3 site takes me to a Liam Oops! page, messages, amount of simpoints, gifts and friends icons are all gone and the top of this page says I am not logged in. I am so severely not amused. :evil:
    meow_zpsa650c518.gif
  • Options
    HGriffinlovessimsHGriffinlovessims Posts: 928 Member
    edited November 2012
    Druscylla wrote:
    I changed my password on Tuesday and haven't been able to login since. I also can't see people's avatars anymore, the main home page for sims 3 site takes me to a Liam Oops! page, messages, amount of simpoints, gifts and friends icons are all gone and the top of this page says I am not logged in. I am so severely not amused. :evil:


    I am having the same exact problem I have no clue! It is getting so frustrating
  • Options
    HGriffinlovessimsHGriffinlovessims Posts: 928 Member
    edited November 2012
    Oh and I can only get to the website from google... :evil:
  • Options
    Rabid47Rabid47 Posts: 625 New Member
    edited November 2012
    The site updated the user pages yesterday...the My Page address has changed, so, in-game details may have needed to update.
    It seems to be ok now, tho'.

    R47 8)
  • Options
    agstahagstah Posts: 2,866 Member
    edited November 2012
    Druscylla wrote:
    I changed my password on Tuesday and haven't been able to login since. I also can't see people's avatars anymore, the main home page for sims 3 site takes me to a Liam Oops! page, messages, amount of simpoints, gifts and friends icons are all gone and the top of this page says I am not logged in. I am so severely not amused. :evil:

    ^^ I have these exact same problems. I was just too tired and fed up with this site to type them all out and I figure it will get fixed eventually. Maybe. *sigh*
  • Options
    Shadowninja2Shadowninja2 Posts: 1,044 Member
    edited November 2012
    Yep I've had this problem, which is the first time. So annoying and from time to time I get that "server lost" thing. Can't even upload to the exchange. Wish they fix that.
Sign In or Register to comment.
Return to top