September 24th- It's time for our Friday Highlights! You can check them out here!

Caw FAQ's........Links to Tutorials, and Resources. Textures, & Troubleshooting

Comments

  • juncedajunceda Posts: 2,614 Member
    Thanks so much @RRArtie that was really helpfull
    firma_zps7hsuhx2i.png

    I can play at last TS2 TS3 and TS4 So great that toddlers are here!!!
  • juncedajunceda Posts: 2,614 Member
    About the statue if I recall it right you should set it to true and then sims will be able to move it around to get it where it is needed to open some closed path, if you set it false then it cannot be moved in game
    firma_zps7hsuhx2i.png

    I can play at last TS2 TS3 and TS4 So great that toddlers are here!!!
  • RRArtieRRArtie Posts: 204 Member
    edited December 2015
    junceda wrote: »
    About the statue if I recall it right you should set it to true and then sims will be able to move it around to get it where it is needed to open some closed path, if you set it false then it cannot be moved in game

    Thank you for the response and I am glad the install advice helped.

    "Toggle Switch Activation" is a mystery.

    There are three switches on the statue that I have experimented with. "Secretly Moveable" set True means the Sim has to inspect first and then it is moveable. "Visibly Moveable" set True means the Sim can move without inspection. Both False means the statue can't be moved and both true is not allowed.

    My experiments indicate that statue movement is not effected by "Toggle Switch Activation" and the name seems to imply that a switch activation is flip/flopped. But what switch activation and what moves make the flip or flop? It is still a mystery to me.

    The only reason I care, was I was trying things that I had not seen done to make the tombs more interesting/fun. I probably should snoop around the WA tombs and see if they set it true and how those statues work.

    Update 12/6/2016 Okay, I did an experiment that showed me how "Toggle Switch Activation" works. I set up a statue with "Visibly Moveable" and "Toggle Switch Activation" both true. I set up three floor steam traps which were dormant and hidden and had a fire rate of 0,1 for 2 minutes. These were in a line one after the other in front of the statue. I linked the statue to each so they would fire once when the statue was pushed forward. Each time the statue was pushed all three would fire a short blast of steam and then stop. As the statue was pushed over a trap it was destroyed. Pushing on any face of the statue set off the steam traps. Pulling did nothing, but move the statue. Now I have to figure out how to use this option in one of my tombs.
    Post edited by RRArtie on
  • RosedustRosedust Posts: 41 Member
    Hi everyone,

    I have been trying to create a world and am having problems when I zoom out. The top of the screen turns blue and the further I zoom out more and more becomes blue. If I have really high mountains the tops are the last things to show before being covered in the blue film. I turned fog off which got rid of the white. My distance is all the way to the right.

    I have only been able to find help on the blue field if you are EIG, which I must say I am not. I am strictly in CAW at this point and I can't zoom out to view the whole map, the furthest sections away just turn blue. I have been unable to see any distant terrain because of this as well as a birds eye view of what I am working with. Again this is NOT in the edit-in-game mode. This is in the base CAW preview window.
  • cheymatcheymat Posts: 46 Member
    edited March 2016
    @Rosedust , I had that problem too. It has something to do with 'Draw Height'. Go into your settings in EIG (edit in game) from CAW. Look under graphics options and put your draw height all the way to high. That is what fixed it for me. I hope that helped.
  • earthgirlearthgirl Posts: 1,019 Member
    Help!

    I have this issues with the layers in the terrain painting tool. How do I fix it??
    VYHciXO.jpg
    4ypYGmM.jpg

    I do happen to have a lot of layers in the world, but still, it only causes issues with one chunk.
    NK4koaX.png
  • juncedajunceda Posts: 2,614 Member
    Hi! May be you have too many painting layers one over the other in this particular chunk, if I don´t remember wrong it should be a max of eight, try to clean it up and start painting again. The lot can be also the problem, you should delete it in CAW (not EIG) save and open the world again and draw the lot again and see if this helps
    firma_zps7hsuhx2i.png

    I can play at last TS2 TS3 and TS4 So great that toddlers are here!!!
  • earthgirlearthgirl Posts: 1,019 Member
    I have 56 layers in the world! Repainting the whole thing would be rather tedious.

    But it looks like the issue(with the river at least) is gone after removing a duplicate layer.
    NK4koaX.png
  • juncedajunceda Posts: 2,614 Member
    I don´t mean the layers in the world but the painting layers in this particular chunk, when you paint a diferente shade of green over the other to get the one you want...
    firma_zps7hsuhx2i.png

    I can play at last TS2 TS3 and TS4 So great that toddlers are here!!!
  • Frogprincess_qFrogprincess_q Posts: 1,269 Member
    I found cleaning the paint layers easier once I figured out how to export the layer and open it with an image editor. Then importing it back in. Painting one colour over another just seems to leave both colours - not to mention how tedious it is to paint huge areas by hand in CAW.
    Edits made and not mentioned will be for typos.

    - Froggie
    1nr15n0.jpg
    WIP: http://forums.thesims.com/en_US/discussion/851667/australian-world-version-1-0-uploaded/p1
  • earthgirlearthgirl Posts: 1,019 Member
    Soooooo... Here's another question:
    What causes lag?
    I seem to get a lot of messages with unroutable sims/pets, but so far I only used the routing tool on the mountains. They usually get stuck on random points of the world(like lots and sometimes outside of lots) and I cannot tell what's causing it.
    I would really want to fix the lagging issues.
    NK4koaX.png
  • Frogprincess_qFrogprincess_q Posts: 1,269 Member
    earthgirl wrote: »
    Soooooo... Here's another question:
    What causes lag?
    I seem to get a lot of messages with unroutable sims/pets, but so far I only used the routing tool on the mountains. They usually get stuck on random points of the world(like lots and sometimes outside of lots) and I cannot tell what's causing it.
    I would really want to fix the lagging issues.

    Are you asking how to reduce lag on a pre-made world or one that you are building?

    Sims/pets can get stuck for all sorts of reasons. I had one world that I was playing where horses kept getting stuck in people gardens. They'd all pile in the gate and then couldn't get out because they were crammed in like sardines.

    If you take note of where they are getting stuck then it will be easier to fix.
    Edits made and not mentioned will be for typos.

    - Froggie
    1nr15n0.jpg
    WIP: http://forums.thesims.com/en_US/discussion/851667/australian-world-version-1-0-uploaded/p1
  • earthgirlearthgirl Posts: 1,019 Member
    It's a world I'm building and currently testing. I don't get this stuff with Sunset Valley.
    Well, I don't know. It's usually sims and smaller pets that keep getting stuck. I had my active sim get suck near the park once. Couldn't get anywhere or do anything, till she reset and I got the Unroutable Sim found message. She was on the sidewalk.
    I don't think I've had any other sim get stuck in that same place. So, it's kind of weird...
    NK4koaX.png
  • Frogprincess_qFrogprincess_q Posts: 1,269 Member
    Have you been rebuilding your routing? Have you had a look at your routing to see if the lines are a mess around trees and deco? Maybe you need to put some non-routable paint in a few places? Anywhere that is too steep, anywhere that is inaccessible (i.e. a flat spot surrounded by steep non-routable areas). Anywhere that is a mess of deco objects to the point of not being easily navigable. Be careful about not having lots overlap the edge of the road. Make sure that your roads are all joined properly. The list really goes on, doesn't it...?
    Edits made and not mentioned will be for typos.

    - Froggie
    1nr15n0.jpg
    WIP: http://forums.thesims.com/en_US/discussion/851667/australian-world-version-1-0-uploaded/p1
  • earthgirlearthgirl Posts: 1,019 Member
    I made sure to route my world carefully. Same with connecting roads.
    Just now I was thinking about lots overlapping with roads in some places, like where there's a curve. Maybe that might be it... I will need to take a look at those tomorrow.
    NK4koaX.png
  • bekkasanbekkasan Posts: 9,797 Member
    When I was testing my little world I put overwatch, error trap and MC in a mods folder in the exported version. I made sure overwatch's reset was turned off so I could find anyone that was getting stuck somewhere to see what needed to be fixed routing wise. That was a huge help in finding a couple of trouble spots.
  • juncedajunceda Posts: 2,614 Member
    Hi @earthgirl, no matter how much carefull you have been with your routing you must redo the route everytime you save your world in CAW because things that you delete or edit leave "shadows" and lost codes that can be interfering with the route. You have to take on acount also that when you rotate or delete a lot in EIG or in game, the spawners don´t get deleted and sum up with the spawners you place when replacing the lot, so you have to manually delete the extra-spawners before you replace the lot.

    If you place a tree or anything of the kind in your world in CAW the routing marks this point as unroutable, if you delete the ítem and you don´t rebuild the route afterwards before saving the world, the point will be unroutable forever and will be empty!, anything spawned in this point in game (and there are a lot of ítems as wild horses, small animals, tourist, NPCs etc that are spawned at random points in game and can be spawned in those unroutable though empty points, plus the game seems to love those unroutable places more tan any other...) the same happens if you edit the world in EIG or in game and remember you can only rebuild the route in CAW, so rebuilding the route in CAW is never too much.

    You have to set your unroutable painting carefully, covering all the zones of your world that can be problematic, unroutable painted zones are not used by the game to spawn anything, but you have to remember that then all that space will not be avaliable for your sims or to build etc.

    And again, you never rebuild your route in CAW too much!
    firma_zps7hsuhx2i.png

    I can play at last TS2 TS3 and TS4 So great that toddlers are here!!!
  • earthgirlearthgirl Posts: 1,019 Member
    @junceda
    That's nice to know.

    I haven't been deleting too many trees or other objects from the world, apart from moving some that were misplaced on the roads for whatever reason and the road was not on an unroutable area anyway. I have only found one single point in an unroutable zone, which I covered.

    I'm going to give the game another test-run now to see if it still lags after moving the lots and checking the routing. I know it needs to take several sim days before it starts lagging badly but in my last game I fixed it with resetsim *.
    NK4koaX.png
  • RRArtieRRArtie Posts: 204 Member
    earthgirl wrote: »
    @junceda
    I'm going to give the game another test-run now to see if it still lags after moving the lots and checking the routing. I know it needs to take several sim days before it starts lagging badly but in my last game I fixed it with resetsim *.

    I have found small dogs and horses to be a continual problem, but I like playing with them. Also, if you reuse some of the EA buildings community, home, houseboat, etc. they may have routing problems. As suggested use Master Controller, when it reports a stuck Sim or animal, click on the icon and the game focus goes to that point. You may see a toilet blocking a shower, circular stairs with pictures on the wall to close etc. You can reset that sim and later fix the bad spot.

    I kept getting small dog caught in Varg's Tavern and never fixed it. Good luck
  • earthgirlearthgirl Posts: 1,019 Member
    I have another question:
    When I was test-playing my world, I have noticed that some sims, particularly those in the Medical career keep skipping work. They can get into the building just fine, I see them go to work, just to run away 5 minutes later, during their shift. I don't know what's causing this, I didn't see any routing problems and other sims don't slack the way my medics do. Might be an issue with the rabbit hole building, but I'm not sure. I keep getting messages about them being extra lazy.

    @RRArtie I rarely use EA premade buildings in my worlds, but I did have a problem with sims getting stuck behind the bistro, because I drew the fence too close to the building and they couldn't get out of there. I fixed that, though.
    In my latest gameplay, I didn't have too many lag issues since I moved the lots further from the roads. I got some unroutable sims here and there, but I have yet to find the problem area.
    NK4koaX.png
  • RosedustRosedust Posts: 41 Member
    Hi, I saw this tutorial some time ago about removing lots in CAW and readding them later to help prevent crashing and reduce loading time however I can not find it again. It had something to do with removing the lot folders and saving them elsewhere then re adding them when done to work on different sections of a town at a time. Does this sound familiar to anyone or know of the tutorial I'm looking for?
  • ukbuildfreakukbuildfreak Posts: 1 New Member
    Hi there simsboffins,

    I'm having a pretty specific building problem when it comes to changing the height of levels using CFE. When I try to change the height of a level I only seem to be able to go down in standard freize sizes, or 4-5 steps at a time. I can't go down by a specific number of steps, nor can I make any level shorter than the height of a standard freize - it just lowers the ground below my building. I think I'm missing a cheat or something but I don't know what it is. At the moment I'm just using testingcheatsenabled true, moveobjects on, and constrainfloorelevation false.

    I would love any advice you can give me, thanks so much!
  • juncedajunceda Posts: 2,614 Member
    Hi @ukbuildfreak and wellcome!

    there are a lot of good tutorials on the fórum... look for the Zoo professor University, I think it is lesson five or so
    firma_zps7hsuhx2i.png

    I can play at last TS2 TS3 and TS4 So great that toddlers are here!!!
  • 23kels8923kels89 Posts: 803 Member
    I know this is a "where-have-you-been?-you're-so-outdated" question but, how do I organize my terrain paint layers? because the way I'm doing it, I'm just clicking on "Add Layer" and choosing the texture from my files, renaming them, and repeat. But it definitely doesn't look organized considering I have Rocks, Sand, Dirt, and Grass all in an unorganized manner, none are corresponding by type of texture where all Grass textures are in order, then the Rock textures, and so on...
    Also, I've clicked on the link on page 1 but it's not working properly for me.


    Find me on the Sims 3
    Find me on Origin



  • RRArtieRRArtie Posts: 204 Member

    I am building a world with several tombs and wanted a complicated set of traps and floor switches. There is a description of the activated behavior of traps in the Tomb Building: Triggers and Activated Behavior post (http://wiki.thesimsresource.com/index.php?title=Tomb_Building:_Triggers_and_Activated_Behaviours), but because the trap can have several states (such as Armed and Hidden), I thought the description should consider those states. In addition, I did not understand the difference between “Deactivate” and “Dormant” or “Set to Fire” and “Fire Once”.

    The description below (from the post) lists the seven activated behaviors and gives a brief description of the result.
    • Fire once - Fires once then sets to "armed”
    • Appear - Makes a hidden trap appear
    • Arm/Decativate - Arms or disarms the trap
    • Set to dormant - Sets the trap to dormant (not dangerous)
    • Destroy - Destroys the trap
    • Set to fire - Sets the trap state to fire

    I conducted tests using statues pushed onto floor switches and step on floor switches. I used each of the five initial states and had the floor switch activate one of the seven Activated Behavior on one of seven wall traps. During these tests I noticed that the statue had to have “Toggle Switch Activation” set to true to make the statue effective on the floor switch. I also noticed that independent of the visual style of the floor switch a Sim could step on the switch or push a statue on the switch to cause the activated behavior.

    The five initial trap states are listed below with an abbreviations used in the rest of this explanation:
    • D&H – Dormant and Hidden
    • A&H – Armed and Hidden
    • A&V – Armed and Visible
    • F&V – Firing and Visible
    • Dis&V - Disarmed and Visible

    The description below is my fuller description derived from these tests:
    • Arm – Arms a dormant trap, but no change for any other state
    • Appear – Makes a hidden trap visible, but no change for any visible trap
    • Fire once – Fires the trap for one cycle of the fire rate and then the trap returns to its initial state. Except firing traps stop firing and go to the A&V state and there is no change for disarmed traps
    • Set to fire – Makes the trap fire continuously and changes the trap state to F&V. Except there is no change for firing and disarmed traps
    • Destroy – Fires the trap and sets it to Dis&V
    • Set to dormant – Sets the trap to D&H. Except there is no change for a trap already in the D&H state.
    • Deactivate – There was no change for any trap, except a firing trap stopped firing and went to A&V

    For these test I set up the FX effect for the Activated Behavior. In a case where no change was caused the FX effect didn’t show. For instance, when the activated behavior was “Appear” and the trap was already visible, then the string of lights would not be generated. I used the “no change” phrase in the description above to indicate this response.

    I hope this helps world builders. Now back to creating!
Sign In or Register to comment.
Return to top