Twitter links taking eons to load

luthienrisingluthienrising Posts: 36,473 Member
What the title says. For the last few days, Twitter links have taken eons to load the image of the tweet. Like, at least 10 minutes and I'm on a very fast connection. I'm not having this issue anywhere else.
Want to be notified of new Broken/Updated Mods/CC lists and new Info threads? Follow me at https://www.patreon.com/luthienrising

Comments

  • Chaotic_MoiraChaotic_Moira Posts: 482 Member
    This has been happening to me for at least over a week. I am not sure how long. I thought maybe my connection was the problem, but I don't have trouble loading any other linked pictures or anything.

    Features I'd like brought back from the dead.
    | Picture in Picture mode | Custom Paintings | Preset scenarios for resident sims | Placing my own lots |
    | Saving my own Buy Mode collections! | Saving an outfit in CAS | CaSt. Smaller is ok | Open World |
  • catloverplayercatloverplayer Posts: 92,070 Member
    Same here.
  • BabykittyjadeBabykittyjade Posts: 4,472 Member
    Mine has been loading fine.
    Zombies, oh please oh please give us zombies!! :'(
  • Calico45Calico45 Posts: 2,038 Member
    It isn't 10 minutes bad, but I have definitely noticed the slow load times as well.
  • simgirl1010simgirl1010 Posts: 29,239 Member
    I'm usually on Firefox and noticed a slowdown in my community giveaway thread. Switched to Chrome and it loaded much faster.
    💚 TS4
    Things are as they are. Always hope. But never expect.
  • luthienrisingluthienrising Posts: 36,473 Member
    I'm on Firefox at home, where it's bad. It's slightly better on my laptop on Edge.
    Want to be notified of new Broken/Updated Mods/CC lists and new Info threads? Follow me at https://www.patreon.com/luthienrising
Sign In or Register to comment.
Return to top