JANUARY 11 - It's Patch Day for The Sims 4 on PC/MAC! Check out what's fixed.

tmethei New Member

About

Username
tmethei
Joined
Visits
2
Last Active
Roles
General
Points
6
Badges
1
Posts
4
  • Re: Sims 3 launches with sound, but no picture

    The game may have set the unsupported resolution. I had such a case. To solve the problem, you may try to look for the Electronic Arts/Sims 3 folder in the Documents folder in Finder, then find the Options.ini file and open it in TextEdit. There, look for the "resolution" line. It then has the three numbers after the word "resolution", corresponding to the automatically set resolution. I personally recommend to change it to 1440 900 0, as it's good for higher performance. Try this tip!)
  • Re: Intel Iris Pro graphics cards - please post here if you have a Macbook with Intel Iris Pro card

    > That would be a great addition to this thread and help a lot of people. Are you running Yosemite? Have the updated graphics drivers in Yosemite maybe solved the issue? :)
    No, the problem hasn't been resolved due to the Yosemite update, what I've done is all about changing the game files manually. I'm glad that has raised some attention, so I'll try to find some time in the nearest day or so and will definitely post the detailed instructions of what to do to get the game running on medium->high setting. I'll head here as soon I have free time, hope that won't take me long!!
  • Re: Intel Iris Pro graphics cards - please post here if you have a Macbook with Intel Iris Pro card

    Well, first of all, I've managed to get the game running rather smoothly thanks to the post the link to which you can see above. Unfortunately, as it's my second comment here, I'm not allowed to post any links

    What I want to do is to give you the idea of how to do that on a retina MacBook sporting the Iris Pro graphics card and running OS X (Yosemite, in my case)

    1. Go to /Applications/The Sims 3/The Sims 3
    2. Right click on folder name and select Show Package Contents
    3. There, go to Contents/Resources/transgaming/c_drive/Program Files/Electronic Arts/The Sims 3/Game/Bin
    4. Look for the following two files: GraphicsCards.sgr
    GraphicsRules.sgr
    5. Back them up in case you do smth wrong, so it's better to copy them and paste in some other directory. I just made copies if them in the same folder, renamed them as it was advised in the link above. We'll edit them later.
    6. Click the apple logo in top left corner of your status bar. Open the About this Mac dialog. Click on Graphics/Displays under Hardware. You'll find the Vendor and Device ID information clearly labelled. For me, the figures are: Vendor: Intel (0x8086); Device ID: 0x0d26
    7. Open GraphicsCards.sgr with TextEdit
    8. Search for the following lines:
    card 0x0152 "Desktop IvyBridge GT1"
    card 0x0156 "Mobile IvyBridge GT1"
    card 0x015A "Server IvyBridge GT1"
    card 0x015E "Reserved - IvyBridge GT1"
    card 0x0162 "Desktop IvyBridge GT2"
    card 0x0166 "Mobile IvyBridge GT2"
    card 0x016A "Server IvyBridge GT2"
    9. Replace them with these lines:
    card 0x0d26 "IntelIrisPro"
    card 0x0d26 "IntelIrisPro"
    card 0x0d26 "IntelIrisPro"
    card 0x0d26 "IntelIrisPro"
    card 0x0d26 "IntelIrisPro"
    card 0x0d26 "IntelIrisPro"
    card 0x0d26 "IntelIrisPro"
    10. Save the file and if prompted to overwrite, answer Yes.
    11. Open GraphicsRules.sgr with TextEdit
    12. Search for the following line:
    elseif (match("${cardName}", "*IvyBridge*"))
    13. Replace it with this line:
    elseif (match("${cardName}", "*IntelIrisPro*"))
    14. Save the file and if prompted to overwrite, answer Yes.
    15. That's almost it! Now load up the game and set the resolution to one of the native ones (the best in terms of support is 1440 by 900 px)
    16. If you can't (you may be hearing the sound but not seeing the picture, not 100% sure), go to /Documents/Electronic Arts/The Sims 3/
    16. Find Options.ini, open with TextEdit
    17. Look for the line:
    resolution = ***
    In my case, that's:
    resolution = 1440 900 0
    I recommend you to set the same resolution as mine, and you'll be able to play with the display settings later yourself. Personally, I've set everything to medium, and the Sims details and Texture details are on high, and I really like what I see: smooth, fast performance and crisp graphics.
    If you ever have the problem of hearing the sound but not seeing the picture, that must be the problem with the unsupported resolution. So, go to step 16 and follow the next few steps.

    Guys, I would like to get some feedback here, so, please, if the manual is of any help, write your impression here!

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Badges

First Comment

About

Username
tmethei
Joined
Visits
2
Last Active
Roles
General
Points
6
Badges
1
Posts
4