JANUARY 11 - It's Patch Day for The Sims 4 on PC/MAC! Check out what's fixed.

cheat console won't open?

Comments

  • southaltansouthaltan Posts: 142 Member
    I was able to use a keyboard app on my iPad, and was able to open the cheat console that way.
  • BluebellFloraBluebellFlora Posts: 6,887 Member
    southaltan wrote: »
    I was able to use a keyboard app on my iPad, and was able to open the cheat console that way.

    There you go people, try plugging in, bluetoothing or using an iOS app keyboard to bring up the cheat console. Either all of you have damaged keyboards or a previous firmware update has affected your keyboard input.
    apple-signature.png
  • hernanzmyhernanzmy Posts: 10 New Member
    Thanks guys i had no idea my control key was broken until now. i found out how to change my keyboard so when i press caps lock it equates to the control key, Thanks for helping me btw the option to do this is in the keyboard sectionof the system preferences in modifiers so you dont have to use other apps or bluetooth to use the cheats
  • dayyliciousdayylicious Posts: 1 New Member
    My platform is MAC & the cheat console will not show up. Someone please help me. I've tried everything.
  • BluebellFloraBluebellFlora Posts: 6,887 Member
    My platform is MAC & the cheat console will not show up. Someone please help me. I've tried everything.

    Have you actually read this thread?

    apple-signature.png
  • JeansooJeansoo Posts: 2,341 Member
    edited March 2015
    In my case, it just randomly comes. I'm using 2 Languages, English and Korean as I'm a Native Korean. Commonly, I use 'command key with space bar' to change my language. I think cheat console is not working when the language is set to Korean. So I usually, switch it over to English, then use the cheat key but sometimes, the cheat console is not showing up in English. It doesn't work randomly in my case. Sometimes, it does but sometimes it doesn't without reason.
  • BluebellFloraBluebellFlora Posts: 6,887 Member
    Jeansoo wrote: »
    In my case, it just randomly comes. I'm using 2 Languages, English and Korean as I'm a Native Korean. Commonly, I use 'command key with space bar' to change my language. I think cheat console is not working when the language is set to Korean. So I usually, switch it over to English, then use the cheat key but sometimes, the cheat console is not showing up in English. It doesn't work randomly in my case. Sometimes, it does but sometimes it doesn't without reason.

    It's definitely a key mapping problem. It could be different keyboard setups for languages or Modifier Key setups, or in some cases it may be a broken CTRL key. One possible workaround is connecting a 3rd party keyboard or using an app like @southaltan did. Setting the input source keyboard to British/US/Canadian or Australian can also work.

    Thanks for the update, very helpful :)
    apple-signature.png
  • andreaordahlandreaordahl Posts: 1 New Member
    the only thing that worked for me was:

    1. click apple icon in top left corner and go to system preferences
    2. go to keyboard and click "modifier keys" in bottom left corner
    3. the last thing (command key), click drop down list and change to control
    4. when in the game use command, shift, c all at once and it should work!

    I think it is some weird change with the newest mac update, but this change worked for me.
  • BluebellFloraBluebellFlora Posts: 6,887 Member
    edited June 2015
    the only thing that worked for me was:

    1. click apple icon in top left corner and go to system preferences
    2. go to keyboard and click "modifier keys" in bottom left corner
    3. the last thing (command key), click drop down list and change to control
    4. when in the game use command, shift, c all at once and it should work!

    I think it is some weird change with the newest mac update, but this change worked for me.

    It's nothing to do with an OS update otherwise everyone would experience it. It's one of three things - the CTRL key is simply not working, the keyboard settings have been manually changed in System Preferences (like you've done to fix your problem), or a 3rd party app has changed or overridden the OS keyboard settings. :)
    apple-signature.png
  • southaltansouthaltan Posts: 142 Member
    the only thing that worked for me was:

    1. click apple icon in top left corner and go to system preferences
    2. go to keyboard and click "modifier keys" in bottom left corner
    3. the last thing (command key), click drop down list and change to control
    4. when in the game use command, shift, c all at once and it should work!

    I think it is some weird change with the newest mac update, but this change worked for me.

    Omg that worked on my system!!!!
  • NO1WHOVIANNO1WHOVIAN Posts: 3 New Member
    Control is at the bottom left of the keyboard, alt is also known as option and c is c.
  • BleubellBleubell Posts: 432 Member
    I have found the solution! Type ctrl + shift + c on the right side of the keyboard, rather than the left.
  • BluebellFloraBluebellFlora Posts: 6,887 Member
    Bleubell wrote: »
    I have found the solution! Type ctrl + shift + c on the right side of the keyboard, rather than the left.

    That would indicate a problem with the CTRL key on the left hand side of your keyboard. It could be either physically broken or the key mapping has been changed.

    apple-signature.png
  • CorvinowCorvinow Posts: 58 Member
    I've finally manage to open the window but none of the codes work, anyone have any idea why?
    Or yet in wise old Ravenclaw If you've a ready mind, where those of wit and learning will always find their kind
  • Tremayne4260Tremayne4260 Posts: 2,847 Member
    Your keyboard may be reconfigured incorrectly.
    Second Star to the Right and Straight on 'til Morning.
  • AbsolXAbsolX Posts: 8 New Member
    When I try to open the cheat console on my mac a screenshot is taking by the software
  • BluebellFloraBluebellFlora Posts: 6,887 Member
    edited November 2015
    AbsolX wrote: »
    When I try to open the cheat console on my mac a screenshot is taking by the software

    Then you need to go into System Preferences > Keyboard and change the shortcuts for your keyboard setup. If you have installed a 3rd party app to take screenshots then you go into that app's settings and change them.

    The default setting in OS X for taking screenshots is CMD, Shift, 3. For a screen selection screenshot it is CMD, Shift, 4.

    The cheat console for TS4 and TS3 is CTRL, Shift, C

    apple-signature.png
  • AbsolXAbsolX Posts: 8 New Member
    I'm sorry if I wasn't clear. The seenshot is taken by Sims 4, rather than a third pary swoftware or my operating system. The pictures can be found in camera controls and made into memories. I'm pretty sure there is no way to change key bindings of the game controls.
  • BluebellFloraBluebellFlora Posts: 6,887 Member
    AbsolX wrote: »
    I'm sorry if I wasn't clear. The seenshot is taken by Sims 4, rather than a third pary swoftware or my operating system. The pictures can be found in camera controls and made into memories. I'm pretty sure there is no way to change key bindings of the game controls.

    That would indicate that your keyboard is only recognising the C key, not the CTRL and Shift keys. Have you checked your keyboard settings in System Preferences? Maybe a program you have downloaded has changed the keyboard mapping slightly. It has been known to happen. Or maybe the keys are sticky or need cleaning?

    apple-signature.png
  • mpwbdmpwbd Posts: 1 New Member
    JUST EXIT THE GAME ONCE AND RE-ENTER.
  • OWEEVANSOWEEVANS Posts: 9 New Member
    > @juprado said:
    > I've finally manage to open the window but none of the codes work, anyone have any idea why?

    HOW DID YOU DO IT PLEZ
  • OWEEVANSOWEEVANS Posts: 9 New Member
    HELP ME SOMEONE I DO NOT WORK FOR ME PLEZZZZ HELP ME
  • OWEEVANSOWEEVANS Posts: 9 New Member
    > @AbsolX said:
    > When I try to open the cheat console on my mac a screenshot is taking by the software

    SAME
  • Tremayne4260Tremayne4260 Posts: 2,847 Member
    The command for opening the Cheat window is exactly the same as on the Windows side. Control + Shift + C.
    Second Star to the Right and Straight on 'til Morning.
  • PASSENGER27PASSENGER27 Posts: 1 New Member
    im pressing COMMAND+SHIFT+C but not working :/ maybe from the window ?
Sign In or Register to comment.
Return to top