Friday Highlights for July 20th are here! Head over here to check them out!
JULY 19 - It's Patch Day for The Sims 4 on Console! Patch notes here.
JULY 10 - It's Patch Day for The Sims 4 on PC/MAC Patch notes here.

Script call Failed

Hi guys
I moved my MODs folder out of my Sims 4 file and then back in again and now when i go into the game and build mode, i cannot use ANY buy CC. Every time i try to place again it says "Script call failed." Anyone know of any suspicious mods or items that could be causing this. I have thousands of CC's so really would like to avoid the whole taking things out and back in again.
Thank you xxx

Comments

  • rosemowrosemow Posts: 133,945 Member
    Hello
    Sims 4 Studio tool has updated its program, and has a batch fix that includes fixing the cc items broken by the last patch
    http://sims4studio.com/board/6/download-sims-studio-open-version (register with the site first before trying to access the download page )
    It would be good to download the latest version and run the batch fix .
    After installing the program, click the tools label at the top of the screen, the batch fix options will be able to be accessed from the drop down menu
    You need to register on the site but it is free. You need to be logged in to access the download page.
  • 1978sariya1978sariya Posts: 1 New Member
    Thank you for the tip..
  • K_PopperK_Popper Posts: 7 New Member
    In my game, I can not place lots from the Gallery as it takes to long even if it shows that it is loading. I can't place lots in build mode on the actual lot correctly, the building goes down but the even if I hit furnished the lot is always empty. Trying to place items from the game, not CC items will not place and I get a small pop up saying Script Call Failed. So I restarted the game and then tried to load a lot to try building a house from scratch. It did not load, It showed that the game was working on loading it but after 15 minutes of nothing I ended the game.
    I have no idea what is going on, it was fine before the base game update, not nothing seems to work and I don't know why.
    I do have CC active in the game so is that the reason?

    Help Please, I really want to get this all sorted before I buy the Seasons pack and install it.
  • Bananas_45Bananas_45 Posts: 3,677 Member
    K_Popper wrote: »
    In my game, I can not place lots from the Gallery as it takes to long even if it shows that it is loading. I can't place lots in build mode on the actual lot correctly, the building goes down but the even if I hit furnished the lot is always empty. Trying to place items from the game, not CC items will not place and I get a small pop up saying Script Call Failed. So I restarted the game and then tried to load a lot to try building a house from scratch. It did not load, It showed that the game was working on loading it but after 15 minutes of nothing I ended the game.
    I have no idea what is going on, it was fine before the base game update, not nothing seems to work and I don't know why.
    I do have CC active in the game so is that the reason?

    Help Please, I really want to get this all sorted before I buy the Seasons pack and install it.

    Try moving your Mods folder to your desktop, then repair the game and see if you can load houses without the Mods/CC in the game. If you don't want to lose your CC placement, do not save the game while you are trying this. If your game works without Mods and CC, slowly add them back in (either in small batches or one at a time) to see if the problem occurs again then delete the problem CC/Mod.

    You may also want to check and see if any of your Mods were broken with the last patch, you may have something that requires updating. There is a list here that you can check:
    https://forums.thesims.com/en_US/discussion/941998/broken-updated-mods-seasons-june-2018-patch/p1

    To repair your game go to "My Game Library" in Origin and right click on The Sims 4, the option to "Repair" should appear. Click on it and let it run.
  • K_PopperK_Popper Posts: 7 New Member
    > Try moving your Mods folder to your desktop, then repair the game and see if you can load houses without the Mods/CC in the game. If you don't want to lose your CC placement, do not save the game while you are trying this. If your game works without Mods and CC, slowly add them back in (either in small batches or one at a time) to see if the problem occurs again then delete the problem CC/Mod.
    >
    > You may also want to check and see if any of your Mods were broken with the last patch, you may have something that requires updating. There is a list here that you can check:
    >
    > To repair your game go to "My Game Library" in Origin and right click on The Sims 4, the option to "Repair" should appear. Click on it and let it run.

    Thank you, I definitely try what you are suggesting.
Sign In or Register to comment.
Return to top