The Sims 3 website is undergoing maintenance. Will update as soon as maintenance is complete.
The Sims 4 Is Coming To Xbox One and PlayStation 4! Read the blog for more info.

High frame rates and NVIDIA control panel has disappeared

tiger_lily5tiger_lily5 Posts: 3,898 Member
Hi everyone. I've got a problem with my laptop and high frame rates and I would really appreciate any help with it.

I haven't been able to play for a couple of months but I tried to play TS3 today and all the graphic options had returned to default and with fps on cheat on, I could see that frame rates were over 200. I presumed this was because a NVIDIA update was installed in June and I haven't played since the update.

I went to adjust the settings in NVIDIA control panel like I know I need to do after an update but the NVIDIA control panel has disappeared!

It used to be under hidden icons but it's not there anymore. I tried to find it by searching but the only NVIDIA thing that I can find on my laptop is the NVIDIA GeForce Experience which I've never used.

I've searched for info on this and found this thread which details a similar problem:

I followed the steps in one of the posts and checked under Intel control panel, 3d settings and browsed for the TS3W file under programs files and have reset it to 'use application default settings'. I've since loaded my game again and it's still over 200 fps.

Oh and this is what it says in my device config file:

=== Graphics device info ===
Number: 0
Name (driver): NVIDIA GeForce GTX 960M
Name (database): GeForce GTX 660M [Found: 1, Matched: 1]
Vendor: NVIDIA
Chipset: Vendor: 10de, Device: 139b, Board: 115b1462, Chipset: 00a2
Driver: nvldumd.dll, Version:, GUID: D7B71E3E-50DB-11CF-DF57-563118C2DB35
Driver version: 8205

Could anyone please help me? I don't know what to try next.


  • igazorigazor Posts: 12,461 Member
    Regardless of how this came about, can you get anywhere with Nvidia Inspector?
    (under the 2nd spoiler)
  • tiger_lily5tiger_lily5 Posts: 3,898 Member

    Thank you for replying. I'm always a bit nervous about downloading things on my laptop because of the risk of viruses but I think I'll need to try it.

    Silly question but if I click under Download Locations and 'Download Nvidia Profile Inspector - Mirror EU' will that one be safe to download?
  • igazorigazor Posts: 12,461 Member
    edited August 13
    Yes, that is a safe download link. Just avoid any download links that might appear in the upper right corner if your browser does not have an ad blocker -- those would be advertisements, not the real program.
  • tiger_lily5tiger_lily5 Posts: 3,898 Member

    I've downloaded Nvidia Inspector now but it's a rar file and it won't open. Is there a way to open rar files on Windows 10? I'm sorry for asking so many silly questions! I do appreciate the help.
  • igazorigazor Posts: 12,461 Member
    edited August 13
    You need to have a third party program to open rar files. WinRAR is popular, but it will keep nagging you to upgrade to the paid version. I prefer 7-zip, it's free, open source, and very easy to use once installed (right click to decompress). It works with rars, 7zs, and other more unusual compression types.
  • tiger_lily5tiger_lily5 Posts: 3,898 Member

    Thanks for the link for 7zip. I've followed the instructions for Nvidia Inspector and set it to Force On for TS3 but I've gone back into my game and it's still over 200 fps, it even went up to 400 as I was quitting the game. I just don't understand what's going wrong. :(

    I did notice something but I don't know if makes a difference. In the screenshot for Inspector on the other thread, it shows Antialiasing fix as on but in mine it's off, could that be affecting anything?
  • igazorigazor Posts: 12,461 Member
    edited August 13
    Probably not. In addition to Force On, have you set Inspector's Frame Rate Limiter (further up the screen but in the same section) to 60 or whatever the refresh rate of your monitor is?

    And...if on Win 10, is it possible that you have recently gotten the Creators Update thing, which might be what is getting in the way here?
  • igazorigazor Posts: 12,461 Member
  • tiger_lily5tiger_lily5 Posts: 3,898 Member

    I've just set the frame rate limiter to 60 and that seems to have fixed it! I'm in game now with the fps cheat on and it hasn't gone over 60 since. :)

    I've just googled how to find what my monitors refresh rate is (honestly I find windows 10 so confusing to use!) and I found it under display adapter properties. It says 60 hertz so hopefully that matches the 60 I set it to in Nvidia Inspector.

    Thank you so much for your help! I would never have got this far on my own. Just one more question, will I need to set it again in Nvidia Inspector after each graphic card update?

    Oh and yes I do have the creators update, I didn't think of that. I'm hoping it'll stay capped now but I will look into that if anything happens again.

    Thanks again for your help! :)
  • igazorigazor Posts: 12,461 Member
    edited August 13
    Most monitors are indeed 60 Hz, so yes 60 fps should have been the goal/setting. There are some monitors that can run higher, but anyway sounds like you are fine there.

    It is possible you will need to look at this again after every graphics driver update to make sure Inspector is continuing to keep things locked in, yes. The card on my simming computer is AMD, not Nvidia, so I have to use a different tool for all of this myself.

    And you're welcome. :)
  • tiger_lily5tiger_lily5 Posts: 3,898 Member

    Okay, I'll check the settings in Inspector next time I get an update and I'll be keeping an eye on the fps with the cheat on just in case it happens again.

    Thanks again! :)
Sign In or Register to comment.
Return to top