JANUARY 11 - It's Patch Day for The Sims 4 on PC/MAC! Check out what's fixed.

Graphics performance in OS X - we need your info!

Comments

  • Lunder89Lunder89 Posts: 153 Member
    @BrownBlossoms‌ When you are playing the game on OS X, does the fan kick in? (In other words, the Mac generating enough heat to actually need cooling)
    I have last years model of MBPr 15", and I am not running far from your setup, and I am generating around 40 FPS average.
    The Edge smoothing to medium could give a little bit better performance, Maybe disabling Post processing effects could give a little too.
  • ErikTheRodErikTheRod Posts: 47 Member
    > @BrownBlossoms said:
    > Graphics card - NVIDIA GeForce GT 750M, 2GB GDDR5 memory (I have a late 2013 mbp retina 15" laptop with 512 GB space)
    > Operating System - Yosemite 10.10.2
    >
    > Graphics Quality - Custom
    > Display Type - Fullscreen
    > Resolution - 1600 x1200
    > Vertical Sync - No
    > Sims - High
    > Objects - High
    > Lighting - High
    > Reflections - High
    > Visual Effects - High
    > Edge Smoothing - High
    > 3D Scene Resolution - High
    > View Distance - High
    > Uncompressed Sim Textures - No
    > Post Processing Effects - Yes
    > Laptop Mode - No
    >
    > FPS Live Mode: 20-24
    > FPS Build Mode: 11-12
    >
    > Okay, so judging by the above FPS and the horrible gameplay lag I'm experiencing, I'm wondering if my graphics card isn't kicking in here? I just...right now, I don't have a single clue why it's playing so horribly on the Mac side for me.
    >
    > However, here are my Bootcamp specs:
    >
    > Graphics Quality - Custom
    > Display Type - Fullscreen
    > Resolution - 1920 x 1200
    > Refresh Rate: 60
    > Vertical Sync - No
    > Sims - High
    > Objects - High
    > Lighting - High
    > Reflections - High
    > Visual Effects - High
    > Edge Smoothing - High
    > 3D Scene Resolution - High
    > View Distance - High
    > Uncompressed Sim Textures - No
    > Post Processing Effects - Yes
    > Laptop Mode - No
    >
    >
    > FPS Live Mode: 40-50
    > FPS Build Mode: 30-40
    >
    > Gameplay is MUCH smoother on Bootcamp for me.
    >
    >

    Try playing at your native 2880x1800 resolution under OS X with Retina ON and Edge Smoothing OFF (make sure to restart the game). I noticed that Edge Smoothing causes a huge hit in performance and at higher (retina) resolutions it is largely unncessary.

    If that does not work, I would recommend playing at 1440x900 (half your native resolution), with Edge Smoothing on LOW (possibly turning Retina OFF for UI size).

    Your graphics card is pretty decent, I would expect it able to play it at decent settings.
  • BluebellFloraBluebellFlora Posts: 6,886 Member
    edited February 2015
    Chumcha wrote: »
    I have the 2013 MBA 13"
    4 gb, 1.3 processor, HD 5000

    Resolution - 1440 x 900
    Vertical Sync - yes
    Sims - med
    Objects - med
    Lighting - low
    Reflections - low
    Visual Effects - med
    Edge Smoothing - off
    3D Scene Resolution - med
    View Distance - high
    Uncompressed Sim Textures - no
    Post Processing Effects - no
    Laptop Mode - no

    FPS Live Mode: 40-50's
    FPS Build Mode: 30-50's

    @Chumcha, please can you confirm how much VRAM your graphics uses, is it 512Mb?

    Apple icon > About This Mac > Intel HD 5000 ????

    I also need to know which operating system you're running. Without these 2 crucial bits of information your specs. are useless.

    apple-signature.png
  • BluebellFloraBluebellFlora Posts: 6,886 Member
    lisamwitt wrote: »
    Graphics card - Intel HD graphics 4000 & NVIDIA GEForce GT 650M
    Operating System - Yosemite 10.10.2

    Now onto the graphics settings in game:

    Graphics Quality - Custom
    Display Type - Windowed
    Resolution - 2560x1484
    Vertical Sync - No
    Sims - High
    Objects - High
    Lighting - High
    Reflections - High
    Visual Effects - High
    Edge Smoothing - Medium
    3D Scene Resolution - High
    View Distance - Low
    Uncompressed Sim Textures - No
    Post Processing Effects - No
    Laptop Mode - No


    FPS Live Mode: 50-55
    FPS Build Mode: 45-50

    How happy are you with the overall graphics performance. Are you experiencing any lag? I'm disappointed. They touted how it would run on low end machines. I have a decent machine. But, in fullscreen mode I have to have my settings all on low to play without significant lag. Now, in windowed mode I can play with most settings (but not all) on high and it plays pretty well. But it's disappointing that I have to play in windowed mode.

    And finally, if you were previously playing the game in Boot Camp (ONLY Boot Camp, not a separate PC or VM), how do the graphics compare:

    It played better in bootcamp. I had all my settings on high, fullscreen, no lag at all. If the playability doesn't improve for me, I may switch back to playing in bootcamp.

    @lisamwitt - does your NVIDIA card have 512MB VRAM or 1GB?
    apple-signature.png
  • BluebellFloraBluebellFlora Posts: 6,886 Member
    @EAfan99 @Jazzpuz @conday884‌

    If you turn off Laptop Mode, are your windows still greyed out?
    apple-signature.png
  • MasonGamerMasonGamer Posts: 7,531 Member
    Macbook Pro (Retina 13-inch Late 2013)
    Yosemite 10.10.2
    2.5GHz intelcore i5
    8 GB 1600 MHz DDR3
    Intel HD Graphics 4000 1024 MB

    in game settings:

    Graphics Quality - Custom
    Display Type - Full
    Resolution - 2560x x 1600
    Vertical Sync - No
    Sims - High
    Objects - High
    Lighting - High
    Reflections - High
    Visual Effects - High
    Edge Smoothing - medium
    3D Scene Resolution - High
    View Distance - High
    Uncompressed Sim Textures - yes
    Post Processing Effects - no
    Laptop Mode - unchecked

    No lag, no issues yet.
    All I need in the Sims is Magic, Seasons, Survival, Adventure
    This is Magic: http://forums.thesims.com/en_US/discussion/771995/the-sims-4-magic-is-coming-updated/p1

    tumblr_ofi2tk8xHN1tlgqkgo4_540.gif
  • BluebellFloraBluebellFlora Posts: 6,886 Member
    @MasonGamer Thank you :) if you have Laptop Mode checked do you get the grey, opaque windows?
    apple-signature.png
  • MasonGamerMasonGamer Posts: 7,531 Member
    @MasonGamer Thank you :) if you have Laptop Mode checked do you get the grey, opaque windows?

    Not on my laptop no.

    I'm installing it on my 2007 iMac now, I'll see what happens with that.
    All I need in the Sims is Magic, Seasons, Survival, Adventure
    This is Magic: http://forums.thesims.com/en_US/discussion/771995/the-sims-4-magic-is-coming-updated/p1

    tumblr_ofi2tk8xHN1tlgqkgo4_540.gif
  • BluebellFloraBluebellFlora Posts: 6,886 Member
    @MasonGamer which iMac? I have the 20" 2007 2.4Ghz, 4Gb RAM, ATI Radeon HD 2600 256MB and the game runs fine. Graphics are a bit plum though.
    apple-signature.png
  • BluebellFloraBluebellFlora Posts: 6,886 Member
  • JazzpuzJazzpuz Posts: 72 Member
    edited February 2015
    > @BluebellFlora said:
    > EAfan99 Jazzpuz conday884‌
    >
    > If you turn off Laptop Mode, are your windows still greyed out?

    Nope, no grey windows now :D but now it doesn't run as smoothly.
  • MasonGamerMasonGamer Posts: 7,531 Member

    yes
    All I need in the Sims is Magic, Seasons, Survival, Adventure
    This is Magic: http://forums.thesims.com/en_US/discussion/771995/the-sims-4-magic-is-coming-updated/p1

    tumblr_ofi2tk8xHN1tlgqkgo4_540.gif
  • lisamwittlisamwitt Posts: 3,494 Member

    @lisamwitt - does your NVIDIA card have 512MB VRAM or 1GB?

    1024 MB actually.
  • BluebellFloraBluebellFlora Posts: 6,886 Member
    lisamwitt wrote: »

    @lisamwitt - does your NVIDIA card have 512MB VRAM or 1GB?

    1024 MB actually.

    That's equivalent to 1GB - thank you :)

    apple-signature.png
  • BluebellFloraBluebellFlora Posts: 6,886 Member
    @lisamwitt is your Retina Resolution ticked?
    apple-signature.png
  • kaiserjkaiserj Posts: 25 New Member
    I actually play TS4 on two different Macs

    Macbook Pro 15 late 2011 w/ Radeon HD 6770M 1gb and iMac 21 inch late 2013 w/ NVIDIA GeForce 750m 1gb.

    The settings for both are:

    Display: Fullscreen
    Resolution: 1440x900 (for Macbook Pro) and 1920 x 1080 (for iMac)
    Vertical Sync: No
    Graphics Quality: Custom
    Sims: High
    Lighting: Medium
    Reflections: Medium
    Visual Effects: High
    Edge Smoothing: Low
    3D Scene Resolution: High
    View Distance: High
    Post Processing Effects: Yes
    Laptop Mode: No

    Game runs great, no lag and in my opinion runs better than under Bootcamp.
  • kaiserjkaiserj Posts: 25 New Member
    > @kaiserj said:
    > I actually play TS4 on two different Macs
    >
    > Macbook Pro 15 late 2011 w/ Radeon HD 6770M 1gb and iMac 21 inch late 2013 w/ NVIDIA GeForce 750m 1gb.
    >
    > The settings for both are:
    >
    > Display: Fullscreen
    > Resolution: 1440x900 (for Macbook Pro) and 1920 x 1080 (for iMac)
    > Vertical Sync: No
    > Graphics Quality: Custom
    > Sims: High
    > Lighting: Medium
    > Reflections: Medium
    > Visual Effects: High
    > Edge Smoothing: Low
    > 3D Scene Resolution: High
    > View Distance: High
    > Post Processing Effects: Yes
    > Laptop Mode: No
    >
    > Game runs great, no lag and in my opinion runs better than under Bootcamp.

    Forgot Objects which is on high
  • lisamwittlisamwitt Posts: 3,494 Member
    @lisamwitt is your Retina Resolution ticked?

    Yes it is.
  • BluebellFloraBluebellFlora Posts: 6,886 Member
    lisamwitt wrote: »
    @lisamwitt is your Retina Resolution ticked?

    Yes it is.
    Thanks :)
    apple-signature.png
  • BluebellFloraBluebellFlora Posts: 6,886 Member
    @kaiserj what OS are running on both machines?
    apple-signature.png
  • kaiserjkaiserj Posts: 25 New Member
    > @BluebellFlora said:
    > kaiserj what OS are running on both machines?

    OS X Yosemite 10.10.2
  • BrownBlossomsBrownBlossoms Posts: 7 New Member
    @Lunder89 - Oddly enough, it took several minutes for my fan to kick in; when it finally did, it was only a slight whisper (doesn't run nearly as loudly as when I'm playing on my bootcamped partition, but perhaps that's due to a number of different things?).

    @ErikTheRod - Thank you SO MUCH for those suggestions! They helped with the look of the game, but the lag and low frame rate is still appearing, and I have no idea why.

    I actually have a separate, odd issue now that I can't find a lot out there for. I'm hesitant to post it here (lest I clog up this post with random error information), but if anyone's had a dialog box pop up that said "vmmap needs to take control of another process for debugging to continue. Type your password to allow this", OR "Developer Tools Access needs to take control of another process for debugging to continue. Type your password to allow this", I'd be grateful to hear about what you did. My game quit unexpectedly after those two messages appeared, so...sigh. Going to try and investigate more and give more info if I find anything out.
  • jedimacfanjedimacfan Posts: 11 New Member
    edited February 2015
    Graphics card - NVIDIA GeForce GT 750M 2GB
    Operating System - Yosemite 10.10.2
    Processor: i7 2.8 GHz
    RAM: 16 GB
    HD: 1 TB

    Now onto the graphics settings in game:

    Graphics Quality - Custom
    Display Type - Fullscreen
    Resolution - 1440 x 900
    Retina Resolution: No
    Vertical Sync - No
    Sims - High
    Objects - High
    Lighting - High
    Reflections - High
    Visual Effects - High
    Edge Smoothing - Medium
    3D Scene Resolution - High
    View Distance - Low
    Uncompressed Sim Textures - Yes
    Post Processing Effects - Yes
    Laptop Mode - No

    Boot Camp comparison - Boot Camp is significantly faster. I can run the game at 1920 x 1200 with Ultra Settings and still get 30–50 FPS with no trouble. On OS X, I get lag even in the character creator. I'm going back to the Boot Camp version because Open GL just can't compete with DirectX.
  • jackjack_kjackjack_k Posts: 7,894 Member
    White MacBook Mid-2010 (5GB Ram)
    OSX Mavericks
    NVIDIA GeForce 320M 256MB
    Great considering on my Windows Partition it ran at Low Medium on Laptop Mode otherwise it crashed, and I went back to my Gaming PC.
    On OSX, it played on High on Laptop Mode and didn't crash during Gameplay.
    Windows were fine.

    However, it did crash a few times if I clicked too many things in the Gallery at once (like Open a Tab and instantly click on what I wanted).
    Not sure if that's an issue for me, but it didn't happen on the Windows Partition. And the Gallery doesn't change on different settings.
    Through Gameplay it ran perfectly fine for 3 hours or so straight.

    Does anyone else have this problem?
    My Top 5 Sims Games:
    1. The Sims 2
    2. The Sims 4
    3. The Sims 3 (would be higher if it worked properly)
    4. The Sims 1
    5. The Sims Medieval

    xyIcMqt.png
  • BluebellFloraBluebellFlora Posts: 6,886 Member
    @Lunder89 - Oddly enough, it took several minutes for my fan to kick in; when it finally did, it was only a slight whisper (doesn't run nearly as loudly as when I'm playing on my bootcamped partition, but perhaps that's due to a number of different things?).

    @ErikTheRod - Thank you SO MUCH for those suggestions! They helped with the look of the game, but the lag and low frame rate is still appearing, and I have no idea why.

    I actually have a separate, odd issue now that I can't find a lot out there for. I'm hesitant to post it here (lest I clog up this post with random error information), but if anyone's had a dialog box pop up that said "vmmap needs to take control of another process for debugging to continue. Type your password to allow this", OR "Developer Tools Access needs to take control of another process for debugging to continue. Type your password to allow this", I'd be grateful to hear about what you did. My game quit unexpectedly after those two messages appeared, so...sigh. Going to try and investigate more and give more info if I find anything out.

    Sounds like a RAM issue, like the debug error in TS3. Have you tried purging RAM regularly during gameplay? Make sure you pause your game beforehand.

    http://bluebellflora.com/resetting-ram-during-gameplay/

    I've already started doing this and it's freeing up between 1-2 Gb at a time.
    apple-signature.png
Sign In or Register to comment.
Return to top